]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- updated to 5.0
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  tcl                     # Tcl bindings
10 %bcond_without  x                       # X11-based utilities
11 %bcond_without  gpm                     # mouse tracking via GPM
12 %bcond_without  libbraille              # libbraille Braille driver
13 %bcond_without  espeak                  # eSpeak synthesizer driver
14 %bcond_without  flite                   # Flite synthesizer driver
15 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
16 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
17 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
18 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
19 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
20 %bcond_without  at_spi                  # AtSpi screen driver
21 %bcond_without  at_spi2                 # AtSpi2 screen driver
22 #
23 %define         brlapi_ver      0.6.1
24 #
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        5.0
30 Release:        1
31 Group:          Daemons
32 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  44c71a973424658557b931f703017481
35 Patch0:         %{name}-format.patch
36 Patch1:         %{name}-java.patch
37 Patch2:         %{name}-speech-dispatcher.patch
38 Patch3:         %{name}-python.patch
39 URL:            http://mielke.cc/brltty/
40 BuildRequires:  alsa-lib-devel
41 %{?with_at_spi:BuildRequires:   at-spi-devel}
42 BuildRequires:  autoconf >= 2.62
43 BuildRequires:  automake
44 BuildRequires:  bison
45 # just headers
46 BuildRequires:  bluez-libs-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 %{?with_espeak:BuildRequires:   espeak-devel}
50 %{?with_flite:BuildRequires:    flite-devel}
51 %{?with_gpm:BuildRequires:      gpm-devel}
52 %{?with_java:BuildRequires:     jdk}
53 %{?with_java:BuildRequires:     jpackage-utils}
54 %{?with_libbraille:BuildRequires:       libbraille-devel}
55 BuildRequires:  libicu-devel
56 BuildRequires:  ncurses-devel
57 %{?with_ocaml:BuildRequires:    ocaml}
58 BuildRequires:  pkgconfig
59 %{?with_python:BuildRequires:   python-Cython}
60 %{?with_java:BuildRequires:     rpm-javaprov}
61 %{?with_python:BuildRequires:   rpm-pythonprov}
62 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
63 BuildRequires:  tar >= 1:1.22
64 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
65 %if %{with x}
66 BuildRequires:  xorg-lib-libX11-devel
67 BuildRequires:  xorg-lib-libXaw-devel
68 BuildRequires:  xorg-lib-libXext-devel
69 BuildRequires:  xorg-lib-libXt-devel
70 BuildRequires:  xorg-lib-libXtst-devel
71 %endif
72 BuildRequires:  xz
73 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
74 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
75 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
76 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 BRLTTY is a background process (daemon) which provides access to the
81 Linux/Unix console (when in text mode) for a blind person using a
82 refreshable Braille display. It drives the Braille display, and
83 provides complete screen review functionality. Some speech capability
84 has also been incorporated.
85
86 %description -l pl.UTF-8
87 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
88 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
89 odświeżaniem (refreshable Braille display). BRLTTY steruje
90 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
91 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
92 mowy.
93
94 %package -n brlapi
95 Summary:        Application Programming Interface for BRLTTY
96 Summary(pl.UTF-8):      API do BRLTTY
97 License:        LGPL v2.1+
98 Group:          Libraries
99
100 %description -n brlapi
101 This package provides the run-time support for the Application
102 Programming Interface to BRLTTY.
103
104 Install this package if you have an application which directly
105 accesses a refreshable Braille display.
106
107 %description -n brlapi -l pl.UTF-8
108 Ten pakiet zawiera środowisko uruchomieniowe dla programów
109 korzystających z API BRLTTY.
110
111 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
112 wyświetlacza Braille'a z odświeżaniem.
113
114 %package -n brlapi-devel
115 Summary:        Headers and documentation for BrlAPI
116 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
117 License:        LGPL v2.1+
118 Group:          Development/Libraries
119 Requires:       brlapi = %{version}-%{release}
120
121 %description -n brlapi-devel
122 This package provides the header files, shared object linker
123 reference, and reference documentation for BrlAPI (the Application
124 Programming Interface to BRLTTY). It enables the implementation of
125 applications which take direct advantage of a refreshable Braille
126 display in order to present information in ways which are more
127 appropriate for blind users and/or to provide user interfaces which
128 are more specifically atuned to their needs.
129
130 Install this package if you're developing or maintaining an
131 application which directly accesses a refreshable Braille display.
132
133 %description -n brlapi-devel -l pl.UTF-8
134 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
135 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
136 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
137 bardziej przystosowany dla osób niewidomych.
138
139 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
140 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
141
142 %package -n brlapi-static
143 Summary:        Static BrlAPI library
144 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
145 License:        LGPL v2.1+
146 Group:          Development/Libraries
147 Requires:       brlapi-devel = %{version}-%{release}
148
149 %description -n brlapi-static
150 This is package with static BrlAPI library.
151
152 %description -n brlapi-static -l pl.UTF-8
153 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
154
155 %package -n brlapi-apidocs
156 Summary:        BrlAPI documentation
157 Summary(pl.UTF-8):      Documentacja BrlAPI
158 Group:          Documentation
159
160 %description -n brlapi-apidocs
161 Documentation for BrlAPI in HTML format generated from brltty
162 sources by doxygen.
163
164 %description -n brlapi-apidocs -l pl.UTF-8
165 Dokumentacja BrlAPI w formacie HTML generowane ze
166 źrodeł brltty przez doxygen.
167
168 %package -n java-brlapi
169 Summary:        BrlAPI library for Java
170 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
171 License:        LGPL v2.1+
172 Group:          Libraries
173 Requires:       brlapi = %{version}-%{release}
174
175 %description -n java-brlapi
176 BrlAPI library for Java.
177
178 %description -n java-brlapi -l pl.UTF-8
179 Biblioteka BrlAPI dla Javy.
180
181 %package -n ocaml-brlapi
182 Summary:        OCaml binding for BrlAPI
183 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
184 License:        LGPL v2.1+
185 Group:          Libraries
186 Requires:       brlapi = %{version}-%{release}
187 %requires_eq    ocaml-runtime
188
189 %description -n ocaml-brlapi
190 OCaml binding for BrlAPI.
191
192 %description -n ocaml-brlapi -l pl.UTF-8
193 Wiązania OCamla do BrlAPI.
194
195 %package -n ocaml-brlapi-devel
196 Summary:        OCaml binding for BrlAPI - development files
197 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
198 License:        LGPL v2.1+
199 Group:          Libraries
200 Requires:       ocaml-brlapi = %{version}-%{release}
201 %requires_eq    ocaml
202
203 %description -n ocaml-brlapi-devel
204 OCaml binding for BrlAPI - development files.
205
206 %description -n ocaml-brlapi-devel -l pl.UTF-8
207 Wiązania OCamla do BrlAPI - pliki programistyczne.
208
209 %package -n python-brlapi
210 Summary:        Python interface to BrlAPI
211 Summary(pl.UTF-8):      Pythonowy interfejs do BrlAPI
212 License:        LGPL v2.1+
213 Group:          Libraries
214 Requires:       brlapi = %{version}-%{release}
215
216 %description -n python-brlapi
217 Python interface to BrlAPI.
218
219 %description -n python-brlapi -l pl.UTF-8
220 Pythonowy interfejs do BrlAPI.
221
222 %package -n brlapi-tcl
223 Summary:        BrlAPI library for Tcl
224 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
225 License:        LGPL v2.1+
226 Group:          Libraries
227 Requires:       brlapi = %{version}-%{release}
228
229 %description -n brlapi-tcl
230 BrlAPI library for Tcl.
231
232 %description -n brlapi-tcl -l pl.UTF-8
233 Biblioteka BrlAPI dla Tcl.
234
235 %prep
236 %setup -q
237 %patch0 -p1
238 %patch1 -p1
239 %patch2 -p1
240 %patch3 -p1
241
242 %build
243 %{__autoconf}
244 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
245 %configure \
246         %{?with_java:JAVA_HOME=%{java_home}} \
247         --with-install-root="$RPM_BUILD_ROOT" \
248         %{!?with_libbraille:--without-libbraille} \
249         %{!?with_espeak:--without-espeak} \
250         %{!?with_flite:--without-flite} \
251         %{!?with_speech_dispatcher:--without-speechd} \
252         %{!?with_ocaml:--disable-caml-bindings} \
253         %{!?with_gpm:--disable-gpm} \
254         %{!?with_java:--disable-java-bindings} \
255         %{!?with_python:--disable-python-bindings} \
256         %{!?with_tcl:--disable-tcl-bindings} \
257         %{!?with_x:--disable-x} \
258         --enable-api
259
260 %{__make} -j1
261
262 directory="doc"
263 mkdir -p "$directory"
264 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
265 do
266         mkdir -p "$directory/${file%/*}"
267         cp -rp "$file" "$directory/$file"
268 done
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272
273 %{__make} -j1 install \
274         OCAML_INSTALL_TARGET=install-without-findlib
275
276 %if %{_lib} != "lib"
277         # Fix java plugin install path on 64-bit archs
278         install -d $RPM_BUILD_ROOT%{_libdir}/java
279         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
280 %endif
281
282 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
283
284 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
285 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
286 d /var/run/brltty 0755 root root -
287 EOF
288
289 %find_lang %{name}
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %pre
295 # The pre-install scriptlet.
296
297 # If a configuration file already exists then rpm installs the new one as
298 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
299 # already exists.
300
301 # There's no explicit way to tell if a configuration file has been installed
302 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
303 # erasing the .rpmnew file now so that we can see if it gets created later.
304 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
305
306 %post
307 # The post-install scriptlet.
308
309 # If BRLTTY's boot parameter has been specified then update the just installed
310 # configuration file template to reflect the options supplied thereby.
311
312 # First, we need to determine which file to update. If there's a .rpmnew file
313 # then update it since a previous configuration file must already have existed.
314 file="%{_sysconfdir}/brltty.conf"
315 new="${file}.rpmnew"
316 [ -f "${new}" ] && file="${new}"
317
318 # Update the configuration file template via the Bootdisks/bp2cf script.
319 # Include it right within this scriptlet so that it needn't be installed.
320 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
321 (
322         # First, set bp2cf's command line arguments.
323         set -- -u -f "${file}"
324
325 #!/bin/sh
326 ###############################################################################
327 # BRLTTY - A background process providing access to the Linux console (when in
328 #          text mode) for a blind person using a refreshable Braille display.
329 #
330 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
331 #
332 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
333 #
334 # This is free software, placed under the terms of the
335 # GNU General Public License, as published by the Free Software
336 # Foundation.  Please see the file COPYING for details.
337 #
338 # Web Page: http://mielke.cc/brltty/
339 #
340 # This software is maintained by Dave Mielke <dave@mielke.cc>.
341 ###############################################################################
342
343 # Convert the boot parameter to configuration file directives.
344 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
345 # If /proc is not mounted then use the brltty environment variable.
346 # Invoke with -h for usage information.
347
348 programName="${0##*/}"
349 programMessage()
350 {
351         echo 2>&1 "${programName}: ${1}"
352 }
353 syntaxError()
354 {
355         programMessage "${1}"
356         exit 2
357 }
358 internalError()
359 {
360         programMessage "${1}"
361         exit 3
362 }
363
364 configurationFile=""
365 requestedAction=create
366 deviceTranslation=none
367 requestedParameter=""
368 OPTIND=1
369 while getopts ":f:cundop:h" option
370 do
371         case "${option}" in
372             f) configurationFile="${OPTARG}";;
373             c) requestedAction=create;;
374             u) requestedAction=update;;
375             n) deviceTranslation=none;;
376             d) deviceTranslation=devfs;;
377             o) deviceTranslation=old;;
378             p) requestedParameter="${OPTARG}";;
379             h)
380                 cat <<EOF
381 Usage: ${programName} [option ...]
382 -f file  The configuration file to create/update.
383 -c       Create the configuration file (write to stdout if no -f).
384 -u       Update the configuration file (copying from stdin to stdout if no -f).
385 -n       Do not translate device paths.
386 -d       Do old-style to devfs device path translation.
387 -o       Do devfs to old-style device path translation.
388 -p [driver][,[device][,[table]]]
389          Explicitly specify the boot parameter.
390 -h       Display this usage summary.
391 EOF
392                 exit 0
393                 ;;
394             \?) syntaxError "unknown option: -${OPTARG}";;
395             :) syntaxError "missing value: -${OPTARG}";;
396             *) internalError "unimplemented option: -${option}";;
397         esac
398 done
399 shift "`expr $OPTIND - 1`"
400 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
401
402 case "${requestedAction}" in
403     create)
404         putConfigurationLine()
405         {
406                 echo "${1}" || exit 4
407         }
408         startConfigurationFile()
409         {
410                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
411                 putConfigurationLine "`makeHeaderLine Created`"
412                 putConfigurationLine "`makeParameterLine`"
413                 putConfigurationLine ""
414         }
415         putConfigurationDirective()
416         {
417                 putConfigurationLine "${1} ${2}"
418         }
419         finalizeConfigurationFile()
420         {
421                 :
422         }
423         ;;
424     update)
425         putSedCommand()
426         {
427                 sedScript="${sedScript}
428 ${1}"
429         }
430         startConfigurationFile()
431         {
432                 if [ -n "${configurationFile}" ]; then
433                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
434                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
435                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
436                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
437                         outputFile="${configurationFile}.new"
438                         exec <"${configurationFile}" >"${outputFile}"
439                 fi
440                 sedScript=""
441                 putSedCommand "1i\\
442 `makeHeaderLine Updated`\\
443 `makeParameterLine`\\
444 "
445         }
446         putConfigurationDirective()
447         {
448                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
449                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
450                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
451         }
452         finalizeConfigurationFile()
453         {
454                 sed -e "${sedScript}"
455                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
456         }
457         ;;
458     *) internalError "unimplemented action: ${requestedAction}";;
459 esac
460
461 translateDevice_none()
462 {
463         :
464 }
465 translateDevice_devfs()
466 {
467         minor="${device#ttyS}"
468         if [ "${minor}" != "${device}" ]; then
469                 device="tts/${minor}"
470                 return 0
471         fi
472         minor="${device#lp}"
473         if [ "${minor}" != "${device}" ]; then
474                 device="printers/${minor}"
475                 return 0
476         fi
477         programMessage "unsupported old-style device: ${device}"
478 }
479 translateDevice_old()
480 {
481         major="${device%%/*}"
482         if [ "${major}" != "${device}" ]; then
483                 minor="${device#*/}"
484                 case "${major}" in
485                     tts) devfs="ttyS${minor}";;
486                     printers) devfs="lp${minor}";;
487                 esac
488         fi
489         if [ -n "${devfs}" ]; then
490                 device="${devfs}"
491         else
492                 programMessage "unsupported devfs device: ${device}"
493         fi
494 }
495
496 makeHeaderLine()
497 {
498         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
499 }
500 makeParameterLine()
501 {
502         echo "# Boot Parameter:${bootParameter}"
503 }
504 putConfigurationFile()
505 {
506         startConfigurationFile
507         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
508         [ -n "${brailleDevice}" ] && {
509         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
510         if [ "${device#/}" = "${device}" ]; then
511                 translateDevice_${deviceTranslation}
512         fi
513         putConfigurationDirective "braille-device" "${device}"
514         }
515         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
516         finalizeConfigurationFile
517 }
518 parseBootParameter()
519 {
520         bootParameter="${bootParameter} ${1}"
521         number=1
522         while [ "${number}" -le 3 ]; do
523                 cut="cut -d, -f${number}"
524                 [ "${number}" -gt 1 ] && cut="${cut} -s"
525                 operand="`echo ${1} | ${cut}`"
526                 if [ -n "${operand}" ]; then
527                         case "${number}" in
528                             1) brailleDriver="${operand}";;
529                             2) brailleDevice="${operand}";;
530                             3) textTable="${operand}";;
531                         esac
532                 fi
533                 number="`expr ${number} + 1`"
534         done
535 }
536 putBootParameter()
537 {
538         parseBootParameter "${1}"
539         putConfigurationFile
540 }
541 parseBootCommand()
542 {
543         found=false
544         while [ "${#}" -gt 0 ]; do
545                 case "${1}" in
546                     "brltty="*)
547                         found=true
548                         parseBootParameter "${1#*=}"
549                         ;;
550                 esac
551                 shift
552         done
553         "${found}" && putConfigurationFile
554 }
555
556 brailleDriver=""
557 brailleDevice=""
558 textTable=""
559 bootCommandFile="/proc/cmdline"
560 if [ -n "${requestedParameter}" ]; then
561         putBootParameter "${requestedParameter}"
562 elif [ -f "${bootCommandFile}" ]; then
563         parseBootCommand `cat "${bootCommandFile}"`
564 elif [ -n "${brltty}" ]; then
565         putBootParameter "${brltty}"
566 fi
567 exit 0
568 )
569
570 %post   -n brlapi -p /sbin/ldconfig
571 %postun -n brlapi -p /sbin/ldconfig
572
573 %files -f %{name}.lang
574 %defattr(644,root,root,755)
575 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
576 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
577 %attr(755,root,root) %{_bindir}/brltty
578 %attr(755,root,root) %{_bindir}/brltty-config
579 %attr(755,root,root) %{_bindir}/brltty-ctb
580 %attr(755,root,root) %{_bindir}/brltty-install
581 %attr(755,root,root) %{_bindir}/brltty-trtxt
582 %attr(755,root,root) %{_bindir}/brltty-ttb
583 %attr(755,root,root) %{_bindir}/eutp
584 %attr(755,root,root) %{_bindir}/vstp
585 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
586 %dir %{_libdir}/brltty
587 # Braille drivers
588 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
589 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
590 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
591 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
592 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
593 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
594 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
595 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
596 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
597 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
598 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
599 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
600 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
601 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
602 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
603 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
604 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
605 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
606 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
607 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
608 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
609 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
610 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
611 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
612 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
613 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
614 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
615 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
616 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
617 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
618 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
619 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
620 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
621 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
622 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
623 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
624 # speech synthesizer drivers
625 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
626 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
627 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
628 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
629 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
630 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
632 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
633 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
634 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
635 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
636 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
638 # screen drivers
639 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
640 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
643 %{_sysconfdir}/brltty
644 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
645 /usr/lib/tmpfiles.d/brltty.conf
646 %dir /var/lib/BrlAPI
647 %dir /var/run/brltty
648 %{_mandir}/man1/brltty.1*
649 %{_mandir}/man1/eutp.1*
650 %{_mandir}/man1/vstp.1*
651 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
652
653 %if %{with x}
654 # gdm autostart - subpackage?
655 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
656 %endif
657
658 %files -n brlapi
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
661 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
662
663 %files -n brlapi-devel
664 %defattr(644,root,root,755)
665 %doc Documents/Manual-BrlAPI/English/BrlAPI*
666 %attr(755,root,root) %{_libdir}/libbrlapi.so
667 %{_includedir}/brltty
668 %{_includedir}/brlapi*.h
669 %{_mandir}/man3/brlapi_*.3*
670
671 %files -n brlapi-static
672 %defattr(644,root,root,755)
673 %{_libdir}/libbrlapi.a
674
675 %if %{with apidocs}
676 %files -n brlapi-apidocs
677 %defattr(644,root,root,755)
678 %doc Documents/BrlAPIref/html/*
679 %endif
680
681 %if %{with java}
682 %files -n java-brlapi
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
685 %{_javadir}/brlapi.jar
686 %endif
687
688 %if %{with ocaml}
689 %files -n ocaml-brlapi
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
692 %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
693
694 %files -n ocaml-brlapi-devel
695 %defattr(644,root,root,755)
696 %dir %{_libdir}/ocaml/brlapi
697 %{_libdir}/ocaml/brlapi/META
698 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
699 %{_libdir}/ocaml/brlapi/brlapi.mli
700 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
701 %endif
702
703 %if %{with python}
704 %files -n python-brlapi
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{py_sitedir}/brlapi.so
707 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
708 %endif
709
710 %if %{with tcl}
711 %files -n brlapi-tcl
712 %defattr(644,root,root,755)
713 %dir %{_libdir}/brlapi-%{brlapi_ver}
714 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
715 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
716 %endif
This page took 0.104153 seconds and 4 git commands to generate.