]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- sys/sysmacros.h needs to be explicitely included
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_with     at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23
24 %define         brlapi_ver      0.6.6
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        5.5
30 Release:        3
31 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
32 Group:          Daemons
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  cd2fb2158b9fc85b23c4225d1d067df6
35 Patch1:         %{name}-speech-dispatcher.patch
36 Patch2:         %{name}-python.patch
37 Patch3:         make.patch
38 Patch4:         %{name}-glibc25.patch
39 URL:            http://mielke.cc/brltty/
40 BuildRequires:  alsa-lib-devel
41 %{?with_at_spi:BuildRequires:   at-spi-devel}
42 BuildRequires:  autoconf >= 2.64
43 BuildRequires:  automake
44 BuildRequires:  bison
45 BuildRequires:  rpmbuild(macros) >= 1.710
46 # just headers
47 BuildRequires:  bluez-libs-devel
48 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
49 %{?with_apidocs:BuildRequires:  doxygen}
50 %{?with_espeak:BuildRequires:   espeak-devel}
51 %{?with_flite:BuildRequires:    flite-devel}
52 %{?with_gpm:BuildRequires:      gpm-devel}
53 %{?with_java:BuildRequires:     jdk}
54 %{?with_java:BuildRequires:     jpackage-utils}
55 %{?with_libbraille:BuildRequires:       libbraille-devel}
56 BuildRequires:  libicu-devel
57 BuildRequires:  ncurses-devel
58 %{?with_ocaml:BuildRequires:    ocaml}
59 BuildRequires:  pkgconfig
60 %{?with_python:BuildRequires:   python-Cython}
61 %{?with_python3:BuildRequires:  python3-Cython}
62 %{?with_java:BuildRequires:     rpm-javaprov}
63 %{?with_python:BuildRequires:   rpm-pythonprov}
64 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
65 BuildRequires:  systemd-devel
66 BuildRequires:  tar >= 1:1.22
67 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
68 %if %{with x}
69 BuildRequires:  xorg-lib-libX11-devel
70 BuildRequires:  xorg-lib-libXaw-devel
71 BuildRequires:  xorg-lib-libXext-devel
72 BuildRequires:  xorg-lib-libXt-devel
73 BuildRequires:  xorg-lib-libXtst-devel
74 %endif
75 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
76 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
77 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
78 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
79 BuildRequires:  xz
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 BRLTTY is a background process (daemon) which provides access to the
84 Linux/Unix console (when in text mode) for a blind person using a
85 refreshable Braille display. It drives the Braille display, and
86 provides complete screen review functionality. Some speech capability
87 has also been incorporated.
88
89 %description -l pl.UTF-8
90 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
91 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
92 odświeżaniem (refreshable Braille display). BRLTTY steruje
93 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
94 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
95 mowy.
96
97 %package -n brlapi
98 Summary:        Application Programming Interface for BRLTTY
99 Summary(pl.UTF-8):      API do BRLTTY
100 License:        LGPL v2.1+
101 Group:          Libraries
102
103 %description -n brlapi
104 This package provides the run-time support for the Application
105 Programming Interface to BRLTTY.
106
107 Install this package if you have an application which directly
108 accesses a refreshable Braille display.
109
110 %description -n brlapi -l pl.UTF-8
111 Ten pakiet zawiera środowisko uruchomieniowe dla programów
112 korzystających z API BRLTTY.
113
114 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
115 wyświetlacza Braille'a z odświeżaniem.
116
117 %package -n brlapi-devel
118 Summary:        Headers and documentation for BrlAPI
119 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
120 License:        LGPL v2.1+
121 Group:          Development/Libraries
122 Requires:       brlapi = %{version}-%{release}
123
124 %description -n brlapi-devel
125 This package provides the header files, shared object linker
126 reference, and reference documentation for BrlAPI (the Application
127 Programming Interface to BRLTTY). It enables the implementation of
128 applications which take direct advantage of a refreshable Braille
129 display in order to present information in ways which are more
130 appropriate for blind users and/or to provide user interfaces which
131 are more specifically atuned to their needs.
132
133 Install this package if you're developing or maintaining an
134 application which directly accesses a refreshable Braille display.
135
136 %description -n brlapi-devel -l pl.UTF-8
137 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
138 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
139 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
140 bardziej przystosowany dla osób niewidomych.
141
142 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
143 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
144
145 %package -n brlapi-static
146 Summary:        Static BrlAPI library
147 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
148 License:        LGPL v2.1+
149 Group:          Development/Libraries
150 Requires:       brlapi-devel = %{version}-%{release}
151
152 %description -n brlapi-static
153 This is package with static BrlAPI library.
154
155 %description -n brlapi-static -l pl.UTF-8
156 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
157
158 %package -n brlapi-apidocs
159 Summary:        BrlAPI documentation
160 Summary(pl.UTF-8):      Documentacja BrlAPI
161 Group:          Documentation
162 %if "%{_rpmversion}" >= "5"
163 BuildArch:      noarch
164 %endif
165
166 %description -n brlapi-apidocs
167 Documentation for BrlAPI in HTML format generated from brltty sources
168 by doxygen.
169
170 %description -n brlapi-apidocs -l pl.UTF-8
171 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
172 doxygen.
173
174 %package -n java-brlapi
175 Summary:        BrlAPI library for Java
176 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
177 License:        LGPL v2.1+
178 Group:          Libraries
179 Requires:       brlapi = %{version}-%{release}
180
181 %description -n java-brlapi
182 BrlAPI library for Java.
183
184 %description -n java-brlapi -l pl.UTF-8
185 Biblioteka BrlAPI dla Javy.
186
187 %package -n ocaml-brlapi
188 Summary:        OCaml binding for BrlAPI
189 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
190 License:        LGPL v2.1+
191 Group:          Libraries
192 Requires:       brlapi = %{version}-%{release}
193 %requires_eq    ocaml-runtime
194
195 %description -n ocaml-brlapi
196 OCaml binding for BrlAPI.
197
198 %description -n ocaml-brlapi -l pl.UTF-8
199 Wiązania OCamla do BrlAPI.
200
201 %package -n ocaml-brlapi-devel
202 Summary:        OCaml binding for BrlAPI - development files
203 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
204 License:        LGPL v2.1+
205 Group:          Libraries
206 Requires:       ocaml-brlapi = %{version}-%{release}
207 %requires_eq    ocaml
208
209 %description -n ocaml-brlapi-devel
210 OCaml binding for BrlAPI - development files.
211
212 %description -n ocaml-brlapi-devel -l pl.UTF-8
213 Wiązania OCamla do BrlAPI - pliki programistyczne.
214
215 %package -n python-brlapi
216 Summary:        Python 2.x interface to BrlAPI
217 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
218 License:        LGPL v2.1+
219 Group:          Libraries
220 Requires:       brlapi = %{version}-%{release}
221
222 %description -n python-brlapi
223 Python 2.x interface to BrlAPI.
224
225 %description -n python-brlapi -l pl.UTF-8
226 Interfejs Pythona 2.x do BrlAPI.
227
228 %package -n python3-brlapi
229 Summary:        Python 3.x interface to BrlAPI
230 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
231 License:        LGPL v2.1+
232 Group:          Libraries
233 Requires:       brlapi = %{version}-%{release}
234
235 %description -n python3-brlapi
236 Python 3.x interface to BrlAPI.
237
238 %description -n python3-brlapi -l pl.UTF-8
239 Interfejs Pythona 3.x do BrlAPI.
240
241 %package -n brlapi-tcl
242 Summary:        BrlAPI library for Tcl
243 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
244 License:        LGPL v2.1+
245 Group:          Libraries
246 Requires:       brlapi = %{version}-%{release}
247
248 %description -n brlapi-tcl
249 BrlAPI library for Tcl.
250
251 %description -n brlapi-tcl -l pl.UTF-8
252 Biblioteka BrlAPI dla Tcl.
253
254 %prep
255 %setup -q
256 %patch1 -p1
257 %patch2 -p1
258 %patch3 -p1
259 %patch4 -p1
260
261 %build
262 %{__autoconf}
263 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
264 %configure \
265         %{?with_java:JAVA_HOME=%{java_home}} \
266         --with-install-root="$RPM_BUILD_ROOT" \
267         %{!?with_libbraille:--without-libbraille} \
268         %{!?with_espeak:--without-espeak} \
269         %{!?with_flite:--without-flite} \
270         %{!?with_speech_dispatcher:--without-speechd} \
271         %{!?with_ocaml:--disable-caml-bindings} \
272         %{!?with_gpm:--disable-gpm} \
273         %{!?with_java:--disable-java-bindings} \
274         %{!?with_python:--disable-python-bindings} \
275         %{!?with_tcl:--disable-tcl-bindings} \
276         %{!?with_x:--disable-x} \
277         --enable-api
278
279 %{__make} -j1
280
281 %if %{with python}
282 cd Bindings/Python
283 %py_build
284 cd ../..
285 %endif
286
287 %if %{with python3}
288 cd Bindings/Python
289 %py3_build
290 cd ../..
291 %endif
292
293 %install
294 rm -rf $RPM_BUILD_ROOT
295
296 %{__make} -j1 install \
297         OCAML_INSTALL_TARGET=install-without-findlib
298
299 # findlib-specific, useless in rpm
300 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
301
302 %if %{with python}
303 cd Bindings/Python
304 %py_install
305 cd ../..
306 %endif
307
308 %if %{with python3}
309 cd Bindings/Python
310 %py3_install
311 cd ../..
312 %endif
313
314 %if %{_lib} != "lib"
315         # Fix java plugin install path on 64-bit archs
316         install -d $RPM_BUILD_ROOT%{_libdir}/java
317         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
318 %endif
319
320 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
321
322 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
323 cat >$RPM_BUILD_ROOT%{systemdtmpfilesdir}/brltty.conf <<EOF
324 d /var/run/brltty 0755 root root -
325 EOF
326
327 # no sign in source wheter it is zh_CN or zh_TW so just remove it
328 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
329
330 %find_lang %{name}
331
332 %clean
333 rm -rf $RPM_BUILD_ROOT
334
335 %pre
336 # The pre-install scriptlet.
337
338 # If a configuration file already exists then rpm installs the new one as
339 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
340 # already exists.
341
342 # There's no explicit way to tell if a configuration file has been installed
343 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
344 # erasing the .rpmnew file now so that we can see if it gets created later.
345 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
346
347 %post
348 # The post-install scriptlet.
349
350 # If BRLTTY's boot parameter has been specified then update the just installed
351 # configuration file template to reflect the options supplied thereby.
352
353 # First, we need to determine which file to update. If there's a .rpmnew file
354 # then update it since a previous configuration file must already have existed.
355 file="%{_sysconfdir}/brltty.conf"
356 new="${file}.rpmnew"
357 [ -f "${new}" ] && file="${new}"
358
359 # Update the configuration file template via the Bootdisks/bp2cf script.
360 # Include it right within this scriptlet so that it needn't be installed.
361 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
362 (
363         # First, set bp2cf's command line arguments.
364         set -- -u -f "${file}"
365
366 #!/bin/sh
367 ###############################################################################
368 # BRLTTY - A background process providing access to the Linux console (when in
369 #          text mode) for a blind person using a refreshable Braille display.
370 #
371 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
372 #
373 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
374 #
375 # This is free software, placed under the terms of the
376 # GNU General Public License, as published by the Free Software
377 # Foundation.  Please see the file COPYING for details.
378 #
379 # Web Page: http://mielke.cc/brltty/
380 #
381 # This software is maintained by Dave Mielke <dave@mielke.cc>.
382 ###############################################################################
383
384 # Convert the boot parameter to configuration file directives.
385 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
386 # If /proc is not mounted then use the brltty environment variable.
387 # Invoke with -h for usage information.
388
389 programName="${0##*/}"
390 programMessage()
391 {
392         echo 2>&1 "${programName}: ${1}"
393 }
394 syntaxError()
395 {
396         programMessage "${1}"
397         exit 2
398 }
399 internalError()
400 {
401         programMessage "${1}"
402         exit 3
403 }
404
405 configurationFile=""
406 requestedAction=create
407 deviceTranslation=none
408 requestedParameter=""
409 OPTIND=1
410 while getopts ":f:cundop:h" option
411 do
412         case "${option}" in
413             f) configurationFile="${OPTARG}";;
414             c) requestedAction=create;;
415             u) requestedAction=update;;
416             n) deviceTranslation=none;;
417             d) deviceTranslation=devfs;;
418             o) deviceTranslation=old;;
419             p) requestedParameter="${OPTARG}";;
420             h)
421                 cat <<EOF
422 Usage: ${programName} [option ...]
423 -f file  The configuration file to create/update.
424 -c       Create the configuration file (write to stdout if no -f).
425 -u       Update the configuration file (copying from stdin to stdout if no -f).
426 -n       Do not translate device paths.
427 -d       Do old-style to devfs device path translation.
428 -o       Do devfs to old-style device path translation.
429 -p [driver][,[device][,[table]]]
430          Explicitly specify the boot parameter.
431 -h       Display this usage summary.
432 EOF
433                 exit 0
434                 ;;
435             \?) syntaxError "unknown option: -${OPTARG}";;
436             :) syntaxError "missing value: -${OPTARG}";;
437             *) internalError "unimplemented option: -${option}";;
438         esac
439 done
440 shift "`expr $OPTIND - 1`"
441 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
442
443 case "${requestedAction}" in
444     create)
445         putConfigurationLine()
446         {
447                 echo "${1}" || exit 4
448         }
449         startConfigurationFile()
450         {
451                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
452                 putConfigurationLine "`makeHeaderLine Created`"
453                 putConfigurationLine "`makeParameterLine`"
454                 putConfigurationLine ""
455         }
456         putConfigurationDirective()
457         {
458                 putConfigurationLine "${1} ${2}"
459         }
460         finalizeConfigurationFile()
461         {
462                 :
463         }
464         ;;
465     update)
466         putSedCommand()
467         {
468                 sedScript="${sedScript}
469 ${1}"
470         }
471         startConfigurationFile()
472         {
473                 if [ -n "${configurationFile}" ]; then
474                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
475                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
476                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
477                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
478                         outputFile="${configurationFile}.new"
479                         exec <"${configurationFile}" >"${outputFile}"
480                 fi
481                 sedScript=""
482                 putSedCommand "1i\\
483 `makeHeaderLine Updated`\\
484 `makeParameterLine`\\
485 "
486         }
487         putConfigurationDirective()
488         {
489                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
490                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
491                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
492         }
493         finalizeConfigurationFile()
494         {
495                 sed -e "${sedScript}"
496                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
497         }
498         ;;
499     *) internalError "unimplemented action: ${requestedAction}";;
500 esac
501
502 translateDevice_none()
503 {
504         :
505 }
506 translateDevice_devfs()
507 {
508         minor="${device#ttyS}"
509         if [ "${minor}" != "${device}" ]; then
510                 device="tts/${minor}"
511                 return 0
512         fi
513         minor="${device#lp}"
514         if [ "${minor}" != "${device}" ]; then
515                 device="printers/${minor}"
516                 return 0
517         fi
518         programMessage "unsupported old-style device: ${device}"
519 }
520 translateDevice_old()
521 {
522         major="${device%%/*}"
523         if [ "${major}" != "${device}" ]; then
524                 minor="${device#*/}"
525                 case "${major}" in
526                     tts) devfs="ttyS${minor}";;
527                     printers) devfs="lp${minor}";;
528                 esac
529         fi
530         if [ -n "${devfs}" ]; then
531                 device="${devfs}"
532         else
533                 programMessage "unsupported devfs device: ${device}"
534         fi
535 }
536
537 makeHeaderLine()
538 {
539         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
540 }
541 makeParameterLine()
542 {
543         echo "# Boot Parameter:${bootParameter}"
544 }
545 putConfigurationFile()
546 {
547         startConfigurationFile
548         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
549         [ -n "${brailleDevice}" ] && {
550         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
551         if [ "${device#/}" = "${device}" ]; then
552                 translateDevice_${deviceTranslation}
553         fi
554         putConfigurationDirective "braille-device" "${device}"
555         }
556         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
557         finalizeConfigurationFile
558 }
559 parseBootParameter()
560 {
561         bootParameter="${bootParameter} ${1}"
562         number=1
563         while [ "${number}" -le 3 ]; do
564                 cut="cut -d, -f${number}"
565                 [ "${number}" -gt 1 ] && cut="${cut} -s"
566                 operand="`echo ${1} | ${cut}`"
567                 if [ -n "${operand}" ]; then
568                         case "${number}" in
569                             1) brailleDriver="${operand}";;
570                             2) brailleDevice="${operand}";;
571                             3) textTable="${operand}";;
572                         esac
573                 fi
574                 number="`expr ${number} + 1`"
575         done
576 }
577 putBootParameter()
578 {
579         parseBootParameter "${1}"
580         putConfigurationFile
581 }
582 parseBootCommand()
583 {
584         found=false
585         while [ "${#}" -gt 0 ]; do
586                 case "${1}" in
587                     "brltty="*)
588                         found=true
589                         parseBootParameter "${1#*=}"
590                         ;;
591                 esac
592                 shift
593         done
594         "${found}" && putConfigurationFile
595 }
596
597 brailleDriver=""
598 brailleDevice=""
599 textTable=""
600 bootCommandFile="/proc/cmdline"
601 if [ -n "${requestedParameter}" ]; then
602         putBootParameter "${requestedParameter}"
603 elif [ -f "${bootCommandFile}" ]; then
604         parseBootCommand `cat "${bootCommandFile}"`
605 elif [ -n "${brltty}" ]; then
606         putBootParameter "${brltty}"
607 fi
608 exit 0
609 )
610
611 %post   -n brlapi -p /sbin/ldconfig
612 %postun -n brlapi -p /sbin/ldconfig
613
614 %files -f %{name}.lang
615 %defattr(644,root,root,755)
616 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
617 %attr(755,root,root) %{_bindir}/brltty
618 %attr(755,root,root) %{_bindir}/brltty-atb
619 %attr(755,root,root) %{_bindir}/brltty-config
620 %attr(755,root,root) %{_bindir}/brltty-ctb
621 %attr(755,root,root) %{_bindir}/brltty-ktb
622 %attr(755,root,root) %{_bindir}/brltty-trtxt
623 %attr(755,root,root) %{_bindir}/brltty-ttb
624 %attr(755,root,root) %{_bindir}/brltty-tune
625 %attr(755,root,root) %{_bindir}/eutp
626 %attr(755,root,root) %{_bindir}/vstp
627 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
628 %dir %{_libdir}/brltty
629 # Braille drivers
630 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
632 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
633 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
639 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
649 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
662 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
667 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
668 # speech synthesizer drivers
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
671 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
672 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
673 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
674 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
676 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
677 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
678 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
679 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
680 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
681 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
682 # screen drivers
683 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
684 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
685 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
686 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
687 %{_sysconfdir}/brltty
688 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
689 %{systemdtmpfilesdir}/brltty.conf
690 %dir /var/lib/BrlAPI
691 %dir /var/run/brltty
692 %{_mandir}/man1/brltty.1*
693 %{_mandir}/man1/eutp.1*
694 %{_mandir}/man1/vstp.1*
695 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
696
697 %if %{with x}
698 # gdm autostart - subpackage?
699 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
700 #/etc/X11/Xsession.d/60xbrlapi
701 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
702 %endif
703 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
704
705 %files -n brlapi
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
709
710 %files -n brlapi-devel
711 %defattr(644,root,root,755)
712 %doc Documents/Manual-BrlAPI/English/BrlAPI*
713 %attr(755,root,root) %{_libdir}/libbrlapi.so
714 %{_includedir}/brltty
715 %{_includedir}/brlapi*.h
716 %{_mandir}/man3/brlapi_*.3*
717
718 %files -n brlapi-static
719 %defattr(644,root,root,755)
720 %{_libdir}/libbrlapi.a
721
722 %if %{with apidocs}
723 %files -n brlapi-apidocs
724 %defattr(644,root,root,755)
725 %doc Documents/BrlAPIref/html/*
726 %endif
727
728 %if %{with java}
729 %files -n java-brlapi
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
732 %{_javadir}/brlapi.jar
733 %endif
734
735 %if %{with ocaml}
736 %files -n ocaml-brlapi
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
739
740 %files -n ocaml-brlapi-devel
741 %defattr(644,root,root,755)
742 %dir %{_libdir}/ocaml/brlapi
743 %{_libdir}/ocaml/brlapi/META
744 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
745 %{_libdir}/ocaml/brlapi/brlapi.mli
746 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
747 %endif
748
749 %if %{with python}
750 %files -n python-brlapi
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{py_sitedir}/brlapi.so
753 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
754
755 %if %{with python3}
756 %files -n python3-brlapi
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
759 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
760 %endif
761 %endif
762
763 %if %{with tcl}
764 %files -n brlapi-tcl
765 %defattr(644,root,root,755)
766 %dir %{_libdir}/brlapi-%{brlapi_ver}
767 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
768 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
769 %endif
This page took 0.126055 seconds and 4 git commands to generate.