]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- updated to 6.0 (note: new libbrlapi soname)
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  liblouis                # liblouis in-line contracted Braille support
15 %bcond_without  espeak                  # eSpeak synthesizer driver
16 %bcond_without  espeak_ng               # eSpeak-NG synthesizer driver
17 %bcond_without  flite                   # Flite synthesizer driver
18 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
19 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
20 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
21 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
22 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
23 %bcond_with     at_spi                  # AtSpi screen driver
24 %bcond_without  at_spi2                 # AtSpi2 screen driver
25
26 %define         brlapi_ver      0.7.0
27 %include        /usr/lib/rpm/macros.java
28 Summary:        Braille display driver for Linux/Unix
29 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
30 Name:           brltty
31 Version:        6.0
32 Release:        1
33 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
34 Group:          Daemons
35 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
36 # Source0-md5:  feca8c2f22b13a4c67b1366191033c0e
37 Patch1:         %{name}-speech-dispatcher.patch
38 Patch2:         %{name}-python.patch
39 Patch3:         make.patch
40 Patch4:         %{name}-glibc25.patch
41 URL:            http://mielke.cc/brltty/
42 BuildRequires:  alsa-lib-devel
43 %{?with_at_spi:BuildRequires:   at-spi-devel}
44 BuildRequires:  autoconf >= 2.64
45 BuildRequires:  automake
46 BuildRequires:  bison
47 # just headers
48 BuildRequires:  bluez-libs-devel
49 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
50 %{?with_apidocs:BuildRequires:  doxygen}
51 %{?with_espeak:BuildRequires:   espeak-devel}
52 %{?with_espeak_ng:BuildRequires:        espeak-ng-devel}
53 BuildRequires:  expat-devel
54 %{?with_flite:BuildRequires:    flite-devel}
55 BuildRequires:  gettext-tools
56 %{?with_gpm:BuildRequires:      gpm-devel}
57 %{?with_java:BuildRequires:     jdk}
58 %{?with_java:BuildRequires:     jpackage-utils}
59 %{?with_libbraille:BuildRequires:       libbraille-devel}
60 BuildRequires:  libicu-devel
61 %{?with_liblouis:BuildRequires: liblouis-devel}
62 BuildRequires:  ncurses-devel
63 %{?with_ocaml:BuildRequires:    ocaml}
64 BuildRequires:  pkgconfig
65 BuildRequires:  polkit-devel
66 %{?with_python:BuildRequires:   python-Cython}
67 %{?with_python3:BuildRequires:  python3-Cython}
68 %{?with_java:BuildRequires:     rpm-javaprov}
69 %{?with_python:BuildRequires:   rpm-pythonprov}
70 BuildRequires:  rpmbuild(macros) >= 1.710
71 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
72 BuildRequires:  systemd-devel
73 BuildRequires:  tar >= 1:1.22
74 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
75 %if %{with x}
76 BuildRequires:  xorg-lib-libX11-devel
77 BuildRequires:  xorg-lib-libXaw-devel
78 BuildRequires:  xorg-lib-libXext-devel
79 BuildRequires:  xorg-lib-libXt-devel
80 BuildRequires:  xorg-lib-libXtst-devel
81 %endif
82 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
83 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
84 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
85 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
86 BuildRequires:  xz
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %description
90 BRLTTY is a background process (daemon) which provides access to the
91 Linux/Unix console (when in text mode) for a blind person using a
92 refreshable Braille display. It drives the Braille display, and
93 provides complete screen review functionality. Some speech capability
94 has also been incorporated.
95
96 %description -l pl.UTF-8
97 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
98 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
99 odświeżaniem (refreshable Braille display). BRLTTY steruje
100 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
101 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
102 mowy.
103
104 %package -n brlapi
105 Summary:        Application Programming Interface for BRLTTY
106 Summary(pl.UTF-8):      API do BRLTTY
107 License:        LGPL v2.1+
108 Group:          Libraries
109
110 %description -n brlapi
111 This package provides the run-time support for the Application
112 Programming Interface to BRLTTY.
113
114 Install this package if you have an application which directly
115 accesses a refreshable Braille display.
116
117 %description -n brlapi -l pl.UTF-8
118 Ten pakiet zawiera środowisko uruchomieniowe dla programów
119 korzystających z API BRLTTY.
120
121 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
122 wyświetlacza Braille'a z odświeżaniem.
123
124 %package -n brlapi-devel
125 Summary:        Headers and documentation for BrlAPI
126 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
127 License:        LGPL v2.1+
128 Group:          Development/Libraries
129 Requires:       brlapi = %{version}-%{release}
130
131 %description -n brlapi-devel
132 This package provides the header files, shared object linker
133 reference, and reference documentation for BrlAPI (the Application
134 Programming Interface to BRLTTY). It enables the implementation of
135 applications which take direct advantage of a refreshable Braille
136 display in order to present information in ways which are more
137 appropriate for blind users and/or to provide user interfaces which
138 are more specifically atuned to their needs.
139
140 Install this package if you're developing or maintaining an
141 application which directly accesses a refreshable Braille display.
142
143 %description -n brlapi-devel -l pl.UTF-8
144 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
145 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
146 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
147 bardziej przystosowany dla osób niewidomych.
148
149 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
150 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
151
152 %package -n brlapi-static
153 Summary:        Static BrlAPI library
154 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
155 License:        LGPL v2.1+
156 Group:          Development/Libraries
157 Requires:       brlapi-devel = %{version}-%{release}
158
159 %description -n brlapi-static
160 This is package with static BrlAPI library.
161
162 %description -n brlapi-static -l pl.UTF-8
163 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
164
165 %package -n brlapi-apidocs
166 Summary:        BrlAPI documentation
167 Summary(pl.UTF-8):      Documentacja BrlAPI
168 Group:          Documentation
169 %if "%{_rpmversion}" >= "5"
170 BuildArch:      noarch
171 %endif
172
173 %description -n brlapi-apidocs
174 Documentation for BrlAPI in HTML format generated from brltty sources
175 by doxygen.
176
177 %description -n brlapi-apidocs -l pl.UTF-8
178 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
179 doxygen.
180
181 %package -n java-brlapi
182 Summary:        BrlAPI library for Java
183 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
184 License:        LGPL v2.1+
185 Group:          Libraries
186 Requires:       brlapi = %{version}-%{release}
187
188 %description -n java-brlapi
189 BrlAPI library for Java.
190
191 %description -n java-brlapi -l pl.UTF-8
192 Biblioteka BrlAPI dla Javy.
193
194 %package -n ocaml-brlapi
195 Summary:        OCaml binding for BrlAPI
196 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
197 License:        LGPL v2.1+
198 Group:          Libraries
199 Requires:       brlapi = %{version}-%{release}
200 %requires_eq    ocaml-runtime
201
202 %description -n ocaml-brlapi
203 OCaml binding for BrlAPI.
204
205 %description -n ocaml-brlapi -l pl.UTF-8
206 Wiązania OCamla do BrlAPI.
207
208 %package -n ocaml-brlapi-devel
209 Summary:        OCaml binding for BrlAPI - development files
210 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
211 License:        LGPL v2.1+
212 Group:          Libraries
213 Requires:       ocaml-brlapi = %{version}-%{release}
214 %requires_eq    ocaml
215
216 %description -n ocaml-brlapi-devel
217 OCaml binding for BrlAPI - development files.
218
219 %description -n ocaml-brlapi-devel -l pl.UTF-8
220 Wiązania OCamla do BrlAPI - pliki programistyczne.
221
222 %package -n python-brlapi
223 Summary:        Python 2.x interface to BrlAPI
224 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
225 License:        LGPL v2.1+
226 Group:          Libraries
227 Requires:       brlapi = %{version}-%{release}
228
229 %description -n python-brlapi
230 Python 2.x interface to BrlAPI.
231
232 %description -n python-brlapi -l pl.UTF-8
233 Interfejs Pythona 2.x do BrlAPI.
234
235 %package -n python3-brlapi
236 Summary:        Python 3.x interface to BrlAPI
237 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
238 License:        LGPL v2.1+
239 Group:          Libraries
240 Requires:       brlapi = %{version}-%{release}
241
242 %description -n python3-brlapi
243 Python 3.x interface to BrlAPI.
244
245 %description -n python3-brlapi -l pl.UTF-8
246 Interfejs Pythona 3.x do BrlAPI.
247
248 %package -n brlapi-tcl
249 Summary:        BrlAPI library for Tcl
250 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
251 License:        LGPL v2.1+
252 Group:          Libraries
253 Requires:       brlapi = %{version}-%{release}
254
255 %description -n brlapi-tcl
256 BrlAPI library for Tcl.
257
258 %description -n brlapi-tcl -l pl.UTF-8
259 Biblioteka BrlAPI dla Tcl.
260
261 %prep
262 %setup -q
263 %patch1 -p1
264 %patch2 -p1
265 #patch3 -p1
266 %patch4 -p1
267
268 %build
269 %{__autoconf}
270 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
271 %configure \
272         %{?with_java:JAVA_HOME=%{java_home}} \
273         --with-install-root="$RPM_BUILD_ROOT" \
274         %{!?with_libbraille:--without-libbraille} \
275         %{!?with_espeak:--without-espeak} \
276         %{!?with_espeak_ng:--without-espeak_ng} \
277         %{!?with_flite:--without-flite} \
278         %{!?with_speech_dispatcher:--without-speechd} \
279         %{!?with_ocaml:--disable-caml-bindings} \
280         %{!?with_gpm:--disable-gpm} \
281         %{!?with_java:--disable-java-bindings} \
282         %{!?with_liblouis:--disable-liblouis} \
283         --enable-lisp-bindings \
284         %{!?with_python:--disable-python-bindings} \
285         %{!?with_tcl:--disable-tcl-bindings} \
286         %{!?with_x:--disable-x} \
287         --enable-api
288
289 %{__make} -j1
290
291 %if %{with python}
292 cd Bindings/Python
293 %py_build
294 cd ../..
295 %endif
296
297 %if %{with python3}
298 cd Bindings/Python
299 %py3_build
300 cd ../..
301 %endif
302
303 %install
304 rm -rf $RPM_BUILD_ROOT
305
306 %{__make} -j1 install install-appstream \
307         OCAML_INSTALL_TARGET=install-without-findlib
308
309 # findlib-specific, useless in rpm
310 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
311
312 %if %{with python}
313 cd Bindings/Python
314 %py_install
315 cd ../..
316 %endif
317
318 %if %{with python3}
319 cd Bindings/Python
320 %py3_install
321 cd ../..
322 %endif
323
324 %if %{_lib} != "lib"
325         # Fix java plugin install path on 64-bit archs
326         install -d $RPM_BUILD_ROOT%{_libdir}/java
327         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
328 %endif
329
330 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
331
332 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
333 cat >$RPM_BUILD_ROOT%{systemdtmpfilesdir}/brltty.conf <<EOF
334 d /var/run/brltty 0755 root root -
335 EOF
336
337 # no sign in source wheter it is zh_CN or zh_TW
338 # but seems to contain Traditional Chinese characters
339 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_TW}
340
341 %find_lang %{name}
342
343 %clean
344 rm -rf $RPM_BUILD_ROOT
345
346 %pre
347 # The pre-install scriptlet.
348
349 # If a configuration file already exists then rpm installs the new one as
350 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
351 # already exists.
352
353 # There's no explicit way to tell if a configuration file has been installed
354 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
355 # erasing the .rpmnew file now so that we can see if it gets created later.
356 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
357
358 %post
359 # The post-install scriptlet.
360
361 # If BRLTTY's boot parameter has been specified then update the just installed
362 # configuration file template to reflect the options supplied thereby.
363
364 # First, we need to determine which file to update. If there's a .rpmnew file
365 # then update it since a previous configuration file must already have existed.
366 file="%{_sysconfdir}/brltty.conf"
367 new="${file}.rpmnew"
368 [ -f "${new}" ] && file="${new}"
369
370 # Update the configuration file template via the Bootdisks/bp2cf script.
371 # Include it right within this scriptlet so that it needn't be installed.
372 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
373 (
374         # First, set bp2cf's command line arguments.
375         set -- -u -f "${file}"
376
377 #!/bin/sh
378 ###############################################################################
379 # BRLTTY - A background process providing access to the Linux console (when in
380 #          text mode) for a blind person using a refreshable Braille display.
381 #
382 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
383 #
384 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
385 #
386 # This is free software, placed under the terms of the
387 # GNU General Public License, as published by the Free Software
388 # Foundation.  Please see the file COPYING for details.
389 #
390 # Web Page: http://mielke.cc/brltty/
391 #
392 # This software is maintained by Dave Mielke <dave@mielke.cc>.
393 ###############################################################################
394
395 # Convert the boot parameter to configuration file directives.
396 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
397 # If /proc is not mounted then use the brltty environment variable.
398 # Invoke with -h for usage information.
399
400 programName="${0##*/}"
401 programMessage()
402 {
403         echo 2>&1 "${programName}: ${1}"
404 }
405 syntaxError()
406 {
407         programMessage "${1}"
408         exit 2
409 }
410 internalError()
411 {
412         programMessage "${1}"
413         exit 3
414 }
415
416 configurationFile=""
417 requestedAction=create
418 deviceTranslation=none
419 requestedParameter=""
420 OPTIND=1
421 while getopts ":f:cundop:h" option
422 do
423         case "${option}" in
424             f) configurationFile="${OPTARG}";;
425             c) requestedAction=create;;
426             u) requestedAction=update;;
427             n) deviceTranslation=none;;
428             d) deviceTranslation=devfs;;
429             o) deviceTranslation=old;;
430             p) requestedParameter="${OPTARG}";;
431             h)
432                 cat <<EOF
433 Usage: ${programName} [option ...]
434 -f file  The configuration file to create/update.
435 -c       Create the configuration file (write to stdout if no -f).
436 -u       Update the configuration file (copying from stdin to stdout if no -f).
437 -n       Do not translate device paths.
438 -d       Do old-style to devfs device path translation.
439 -o       Do devfs to old-style device path translation.
440 -p [driver][,[device][,[table]]]
441          Explicitly specify the boot parameter.
442 -h       Display this usage summary.
443 EOF
444                 exit 0
445                 ;;
446             \?) syntaxError "unknown option: -${OPTARG}";;
447             :) syntaxError "missing value: -${OPTARG}";;
448             *) internalError "unimplemented option: -${option}";;
449         esac
450 done
451 shift "`expr $OPTIND - 1`"
452 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
453
454 case "${requestedAction}" in
455     create)
456         putConfigurationLine()
457         {
458                 echo "${1}" || exit 4
459         }
460         startConfigurationFile()
461         {
462                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
463                 putConfigurationLine "`makeHeaderLine Created`"
464                 putConfigurationLine "`makeParameterLine`"
465                 putConfigurationLine ""
466         }
467         putConfigurationDirective()
468         {
469                 putConfigurationLine "${1} ${2}"
470         }
471         finalizeConfigurationFile()
472         {
473                 :
474         }
475         ;;
476     update)
477         putSedCommand()
478         {
479                 sedScript="${sedScript}
480 ${1}"
481         }
482         startConfigurationFile()
483         {
484                 if [ -n "${configurationFile}" ]; then
485                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
486                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
487                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
488                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
489                         outputFile="${configurationFile}.new"
490                         exec <"${configurationFile}" >"${outputFile}"
491                 fi
492                 sedScript=""
493                 putSedCommand "1i\\
494 `makeHeaderLine Updated`\\
495 `makeParameterLine`\\
496 "
497         }
498         putConfigurationDirective()
499         {
500                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
501                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
502                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
503         }
504         finalizeConfigurationFile()
505         {
506                 sed -e "${sedScript}"
507                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
508         }
509         ;;
510     *) internalError "unimplemented action: ${requestedAction}";;
511 esac
512
513 translateDevice_none()
514 {
515         :
516 }
517 translateDevice_devfs()
518 {
519         minor="${device#ttyS}"
520         if [ "${minor}" != "${device}" ]; then
521                 device="tts/${minor}"
522                 return 0
523         fi
524         minor="${device#lp}"
525         if [ "${minor}" != "${device}" ]; then
526                 device="printers/${minor}"
527                 return 0
528         fi
529         programMessage "unsupported old-style device: ${device}"
530 }
531 translateDevice_old()
532 {
533         major="${device%%/*}"
534         if [ "${major}" != "${device}" ]; then
535                 minor="${device#*/}"
536                 case "${major}" in
537                     tts) devfs="ttyS${minor}";;
538                     printers) devfs="lp${minor}";;
539                 esac
540         fi
541         if [ -n "${devfs}" ]; then
542                 device="${devfs}"
543         else
544                 programMessage "unsupported devfs device: ${device}"
545         fi
546 }
547
548 makeHeaderLine()
549 {
550         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
551 }
552 makeParameterLine()
553 {
554         echo "# Boot Parameter:${bootParameter}"
555 }
556 putConfigurationFile()
557 {
558         startConfigurationFile
559         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
560         [ -n "${brailleDevice}" ] && {
561         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
562         if [ "${device#/}" = "${device}" ]; then
563                 translateDevice_${deviceTranslation}
564         fi
565         putConfigurationDirective "braille-device" "${device}"
566         }
567         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
568         finalizeConfigurationFile
569 }
570 parseBootParameter()
571 {
572         bootParameter="${bootParameter} ${1}"
573         number=1
574         while [ "${number}" -le 3 ]; do
575                 cut="cut -d, -f${number}"
576                 [ "${number}" -gt 1 ] && cut="${cut} -s"
577                 operand="`echo ${1} | ${cut}`"
578                 if [ -n "${operand}" ]; then
579                         case "${number}" in
580                             1) brailleDriver="${operand}";;
581                             2) brailleDevice="${operand}";;
582                             3) textTable="${operand}";;
583                         esac
584                 fi
585                 number="`expr ${number} + 1`"
586         done
587 }
588 putBootParameter()
589 {
590         parseBootParameter "${1}"
591         putConfigurationFile
592 }
593 parseBootCommand()
594 {
595         found=false
596         while [ "${#}" -gt 0 ]; do
597                 case "${1}" in
598                     "brltty="*)
599                         found=true
600                         parseBootParameter "${1#*=}"
601                         ;;
602                 esac
603                 shift
604         done
605         "${found}" && putConfigurationFile
606 }
607
608 brailleDriver=""
609 brailleDevice=""
610 textTable=""
611 bootCommandFile="/proc/cmdline"
612 if [ -n "${requestedParameter}" ]; then
613         putBootParameter "${requestedParameter}"
614 elif [ -f "${bootCommandFile}" ]; then
615         parseBootCommand `cat "${bootCommandFile}"`
616 elif [ -n "${brltty}" ]; then
617         putBootParameter "${brltty}"
618 fi
619 exit 0
620 )
621
622 %post   -n brlapi -p /sbin/ldconfig
623 %postun -n brlapi -p /sbin/ldconfig
624
625 %files -f %{name}.lang
626 %defattr(644,root,root,755)
627 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
628 %attr(755,root,root) %{_bindir}/brltty
629 %attr(755,root,root) %{_bindir}/brltty-atb
630 %attr(755,root,root) %{_bindir}/brltty-config
631 %attr(755,root,root) %{_bindir}/brltty-cldr
632 %attr(755,root,root) %{_bindir}/brltty-ctb
633 %attr(755,root,root) %{_bindir}/brltty-ktb
634 %attr(755,root,root) %{_bindir}/brltty-lscmds
635 %attr(755,root,root) %{_bindir}/brltty-lsinc
636 %attr(755,root,root) %{_bindir}/brltty-morse
637 %attr(755,root,root) %{_bindir}/brltty-trtxt
638 %attr(755,root,root) %{_bindir}/brltty-ttb
639 %attr(755,root,root) %{_bindir}/brltty-tune
640 %attr(755,root,root) %{_bindir}/eutp
641 %attr(755,root,root) %{_bindir}/vstp
642 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
643 %dir %{_libdir}/brltty
644 # Braille drivers
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
662 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttybic.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
665 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
667 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
671 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
672 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
673 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
674 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
676 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
677 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
678 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
679 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
680 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
681 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
682 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
683 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
684 # speech synthesizer drivers
685 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
686 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
687 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
688 %{?with_espeak_ng:%attr(755,root,root) %{_libdir}/brltty/libbrlttysen.so}
689 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
690 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
691 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
692 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
693 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
694 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
695 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
696 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
697 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
698 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
699 # screen drivers
700 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
701 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
702 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
703 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
704 %{_sysconfdir}/brltty
705 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
706 %{systemdtmpfilesdir}/brltty.conf
707 %dir /var/lib/BrlAPI
708 %dir /var/run/brltty
709 %{_mandir}/man1/brltty.1*
710 %{_mandir}/man1/eutp.1*
711 %{_mandir}/man1/vstp.1*
712 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
713
714 %if %{with x}
715 # gdm autostart - subpackage?
716 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
717 #/etc/X11/Xsession.d/60xbrlapi
718 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
719 %endif
720 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
721
722 %files -n brlapi
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.7
726
727 %files -n brlapi-devel
728 %defattr(644,root,root,755)
729 %doc Documents/Manual-BrlAPI/English/BrlAPI*
730 %attr(755,root,root) %{_libdir}/libbrlapi.so
731 %{_includedir}/brltty
732 %{_includedir}/brlapi*.h
733 %{_mandir}/man3/brlapi_*.3*
734
735 %files -n brlapi-static
736 %defattr(644,root,root,755)
737 %{_libdir}/libbrlapi.a
738
739 %if %{with apidocs}
740 %files -n brlapi-apidocs
741 %defattr(644,root,root,755)
742 %doc Documents/BrlAPIref/html/*
743 %endif
744
745 %if %{with java}
746 %files -n java-brlapi
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
749 %{_javadir}/brlapi.jar
750 %endif
751
752 %if %{with ocaml}
753 %files -n ocaml-brlapi
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
756
757 %files -n ocaml-brlapi-devel
758 %defattr(644,root,root,755)
759 %dir %{_libdir}/ocaml/brlapi
760 %{_libdir}/ocaml/brlapi/META
761 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
762 %{_libdir}/ocaml/brlapi/brlapi.mli
763 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
764 %endif
765
766 %if %{with python}
767 %files -n python-brlapi
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{py_sitedir}/brlapi.so
770 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
771
772 %if %{with python3}
773 %files -n python3-brlapi
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
776 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
777 %endif
778 %endif
779
780 %if %{with tcl}
781 %files -n brlapi-tcl
782 %defattr(644,root,root,755)
783 %dir %{_libdir}/brlapi-%{brlapi_ver}
784 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
785 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
786 %endif
This page took 0.690882 seconds and 3 git commands to generate.