]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- removed obsolete patch entry
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  liblouis                # liblouis in-line contracted Braille support
15 %bcond_without  espeak                  # eSpeak synthesizer driver
16 %bcond_without  espeak_ng               # eSpeak-NG synthesizer driver
17 %bcond_without  flite                   # Flite synthesizer driver
18 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
19 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
20 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
21 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
22 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
23 %bcond_with     at_spi                  # AtSpi screen driver
24 %bcond_without  at_spi2                 # AtSpi2 screen driver
25
26 %define         brlapi_ver      0.7.0
27 %include        /usr/lib/rpm/macros.java
28 Summary:        Braille display driver for Linux/Unix
29 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
30 Name:           brltty
31 Version:        6.0
32 Release:        1
33 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
34 Group:          Daemons
35 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
36 # Source0-md5:  feca8c2f22b13a4c67b1366191033c0e
37 Patch1:         %{name}-speech-dispatcher.patch
38 Patch2:         %{name}-python.patch
39 Patch4:         %{name}-glibc25.patch
40 URL:            http://mielke.cc/brltty/
41 BuildRequires:  alsa-lib-devel
42 %{?with_at_spi:BuildRequires:   at-spi-devel}
43 BuildRequires:  autoconf >= 2.64
44 BuildRequires:  automake
45 BuildRequires:  bison
46 # just headers
47 BuildRequires:  bluez-libs-devel
48 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
49 %{?with_apidocs:BuildRequires:  doxygen}
50 %{?with_espeak:BuildRequires:   espeak-devel}
51 %{?with_espeak_ng:BuildRequires:        espeak-ng-devel}
52 BuildRequires:  expat-devel
53 %{?with_flite:BuildRequires:    flite-devel}
54 BuildRequires:  gettext-tools
55 %{?with_gpm:BuildRequires:      gpm-devel}
56 %{?with_java:BuildRequires:     jdk}
57 %{?with_java:BuildRequires:     jpackage-utils}
58 %{?with_libbraille:BuildRequires:       libbraille-devel}
59 BuildRequires:  libicu-devel
60 %{?with_liblouis:BuildRequires: liblouis-devel}
61 BuildRequires:  ncurses-devel
62 %{?with_ocaml:BuildRequires:    ocaml}
63 BuildRequires:  pkgconfig
64 BuildRequires:  polkit-devel
65 %{?with_python:BuildRequires:   python-Cython}
66 %{?with_python3:BuildRequires:  python3-Cython}
67 %{?with_java:BuildRequires:     rpm-javaprov}
68 %{?with_python:BuildRequires:   rpm-pythonprov}
69 BuildRequires:  rpmbuild(macros) >= 1.710
70 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
71 BuildRequires:  systemd-devel
72 BuildRequires:  tar >= 1:1.22
73 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
74 %if %{with x}
75 BuildRequires:  xorg-lib-libX11-devel
76 BuildRequires:  xorg-lib-libXaw-devel
77 BuildRequires:  xorg-lib-libXext-devel
78 BuildRequires:  xorg-lib-libXt-devel
79 BuildRequires:  xorg-lib-libXtst-devel
80 %endif
81 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
82 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
83 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
84 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
85 BuildRequires:  xz
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %description
89 BRLTTY is a background process (daemon) which provides access to the
90 Linux/Unix console (when in text mode) for a blind person using a
91 refreshable Braille display. It drives the Braille display, and
92 provides complete screen review functionality. Some speech capability
93 has also been incorporated.
94
95 %description -l pl.UTF-8
96 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
97 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
98 odświeżaniem (refreshable Braille display). BRLTTY steruje
99 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
100 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
101 mowy.
102
103 %package -n brlapi
104 Summary:        Application Programming Interface for BRLTTY
105 Summary(pl.UTF-8):      API do BRLTTY
106 License:        LGPL v2.1+
107 Group:          Libraries
108
109 %description -n brlapi
110 This package provides the run-time support for the Application
111 Programming Interface to BRLTTY.
112
113 Install this package if you have an application which directly
114 accesses a refreshable Braille display.
115
116 %description -n brlapi -l pl.UTF-8
117 Ten pakiet zawiera środowisko uruchomieniowe dla programów
118 korzystających z API BRLTTY.
119
120 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
121 wyświetlacza Braille'a z odświeżaniem.
122
123 %package -n brlapi-devel
124 Summary:        Headers and documentation for BrlAPI
125 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
126 License:        LGPL v2.1+
127 Group:          Development/Libraries
128 Requires:       brlapi = %{version}-%{release}
129
130 %description -n brlapi-devel
131 This package provides the header files, shared object linker
132 reference, and reference documentation for BrlAPI (the Application
133 Programming Interface to BRLTTY). It enables the implementation of
134 applications which take direct advantage of a refreshable Braille
135 display in order to present information in ways which are more
136 appropriate for blind users and/or to provide user interfaces which
137 are more specifically atuned to their needs.
138
139 Install this package if you're developing or maintaining an
140 application which directly accesses a refreshable Braille display.
141
142 %description -n brlapi-devel -l pl.UTF-8
143 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
144 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
145 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
146 bardziej przystosowany dla osób niewidomych.
147
148 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
149 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
150
151 %package -n brlapi-static
152 Summary:        Static BrlAPI library
153 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
154 License:        LGPL v2.1+
155 Group:          Development/Libraries
156 Requires:       brlapi-devel = %{version}-%{release}
157
158 %description -n brlapi-static
159 This is package with static BrlAPI library.
160
161 %description -n brlapi-static -l pl.UTF-8
162 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
163
164 %package -n brlapi-apidocs
165 Summary:        BrlAPI documentation
166 Summary(pl.UTF-8):      Documentacja BrlAPI
167 Group:          Documentation
168 %if "%{_rpmversion}" >= "5"
169 BuildArch:      noarch
170 %endif
171
172 %description -n brlapi-apidocs
173 Documentation for BrlAPI in HTML format generated from brltty sources
174 by doxygen.
175
176 %description -n brlapi-apidocs -l pl.UTF-8
177 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
178 doxygen.
179
180 %package -n java-brlapi
181 Summary:        BrlAPI library for Java
182 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
183 License:        LGPL v2.1+
184 Group:          Libraries
185 Requires:       brlapi = %{version}-%{release}
186
187 %description -n java-brlapi
188 BrlAPI library for Java.
189
190 %description -n java-brlapi -l pl.UTF-8
191 Biblioteka BrlAPI dla Javy.
192
193 %package -n ocaml-brlapi
194 Summary:        OCaml binding for BrlAPI
195 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
196 License:        LGPL v2.1+
197 Group:          Libraries
198 Requires:       brlapi = %{version}-%{release}
199 %requires_eq    ocaml-runtime
200
201 %description -n ocaml-brlapi
202 OCaml binding for BrlAPI.
203
204 %description -n ocaml-brlapi -l pl.UTF-8
205 Wiązania OCamla do BrlAPI.
206
207 %package -n ocaml-brlapi-devel
208 Summary:        OCaml binding for BrlAPI - development files
209 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
210 License:        LGPL v2.1+
211 Group:          Libraries
212 Requires:       ocaml-brlapi = %{version}-%{release}
213 %requires_eq    ocaml
214
215 %description -n ocaml-brlapi-devel
216 OCaml binding for BrlAPI - development files.
217
218 %description -n ocaml-brlapi-devel -l pl.UTF-8
219 Wiązania OCamla do BrlAPI - pliki programistyczne.
220
221 %package -n python-brlapi
222 Summary:        Python 2.x interface to BrlAPI
223 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
224 License:        LGPL v2.1+
225 Group:          Libraries
226 Requires:       brlapi = %{version}-%{release}
227
228 %description -n python-brlapi
229 Python 2.x interface to BrlAPI.
230
231 %description -n python-brlapi -l pl.UTF-8
232 Interfejs Pythona 2.x do BrlAPI.
233
234 %package -n python3-brlapi
235 Summary:        Python 3.x interface to BrlAPI
236 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
237 License:        LGPL v2.1+
238 Group:          Libraries
239 Requires:       brlapi = %{version}-%{release}
240
241 %description -n python3-brlapi
242 Python 3.x interface to BrlAPI.
243
244 %description -n python3-brlapi -l pl.UTF-8
245 Interfejs Pythona 3.x do BrlAPI.
246
247 %package -n brlapi-tcl
248 Summary:        BrlAPI library for Tcl
249 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
250 License:        LGPL v2.1+
251 Group:          Libraries
252 Requires:       brlapi = %{version}-%{release}
253
254 %description -n brlapi-tcl
255 BrlAPI library for Tcl.
256
257 %description -n brlapi-tcl -l pl.UTF-8
258 Biblioteka BrlAPI dla Tcl.
259
260 %prep
261 %setup -q
262 %patch1 -p1
263 %patch2 -p1
264 %patch4 -p1
265
266 %build
267 %{__autoconf}
268 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
269 %configure \
270         %{?with_java:JAVA_HOME=%{java_home}} \
271         --with-install-root="$RPM_BUILD_ROOT" \
272         %{!?with_libbraille:--without-libbraille} \
273         %{!?with_espeak:--without-espeak} \
274         %{!?with_espeak_ng:--without-espeak_ng} \
275         %{!?with_flite:--without-flite} \
276         %{!?with_speech_dispatcher:--without-speechd} \
277         %{!?with_ocaml:--disable-caml-bindings} \
278         %{!?with_gpm:--disable-gpm} \
279         %{!?with_java:--disable-java-bindings} \
280         %{!?with_liblouis:--disable-liblouis} \
281         --enable-lisp-bindings \
282         %{!?with_python:--disable-python-bindings} \
283         %{!?with_tcl:--disable-tcl-bindings} \
284         %{!?with_x:--disable-x} \
285         --enable-api
286
287 %{__make} -j1
288
289 %if %{with python}
290 cd Bindings/Python
291 %py_build
292 cd ../..
293 %endif
294
295 %if %{with python3}
296 cd Bindings/Python
297 %py3_build
298 cd ../..
299 %endif
300
301 %install
302 rm -rf $RPM_BUILD_ROOT
303
304 %{__make} -j1 install install-appstream \
305         OCAML_INSTALL_TARGET=install-without-findlib
306
307 # findlib-specific, useless in rpm
308 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
309
310 %if %{with python}
311 cd Bindings/Python
312 %py_install
313 cd ../..
314 %endif
315
316 %if %{with python3}
317 cd Bindings/Python
318 %py3_install
319 cd ../..
320 %endif
321
322 %if %{_lib} != "lib"
323         # Fix java plugin install path on 64-bit archs
324         install -d $RPM_BUILD_ROOT%{_libdir}/java
325         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
326 %endif
327
328 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
329
330 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
331 cat >$RPM_BUILD_ROOT%{systemdtmpfilesdir}/brltty.conf <<EOF
332 d /var/run/brltty 0755 root root -
333 EOF
334
335 # no sign in source wheter it is zh_CN or zh_TW
336 # but seems to contain Traditional Chinese characters
337 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_TW}
338
339 %find_lang %{name}
340
341 %clean
342 rm -rf $RPM_BUILD_ROOT
343
344 %pre
345 # The pre-install scriptlet.
346
347 # If a configuration file already exists then rpm installs the new one as
348 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
349 # already exists.
350
351 # There's no explicit way to tell if a configuration file has been installed
352 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
353 # erasing the .rpmnew file now so that we can see if it gets created later.
354 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
355
356 %post
357 # The post-install scriptlet.
358
359 # If BRLTTY's boot parameter has been specified then update the just installed
360 # configuration file template to reflect the options supplied thereby.
361
362 # First, we need to determine which file to update. If there's a .rpmnew file
363 # then update it since a previous configuration file must already have existed.
364 file="%{_sysconfdir}/brltty.conf"
365 new="${file}.rpmnew"
366 [ -f "${new}" ] && file="${new}"
367
368 # Update the configuration file template via the Bootdisks/bp2cf script.
369 # Include it right within this scriptlet so that it needn't be installed.
370 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
371 (
372         # First, set bp2cf's command line arguments.
373         set -- -u -f "${file}"
374
375 #!/bin/sh
376 ###############################################################################
377 # BRLTTY - A background process providing access to the Linux console (when in
378 #          text mode) for a blind person using a refreshable Braille display.
379 #
380 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
381 #
382 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
383 #
384 # This is free software, placed under the terms of the
385 # GNU General Public License, as published by the Free Software
386 # Foundation.  Please see the file COPYING for details.
387 #
388 # Web Page: http://mielke.cc/brltty/
389 #
390 # This software is maintained by Dave Mielke <dave@mielke.cc>.
391 ###############################################################################
392
393 # Convert the boot parameter to configuration file directives.
394 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
395 # If /proc is not mounted then use the brltty environment variable.
396 # Invoke with -h for usage information.
397
398 programName="${0##*/}"
399 programMessage()
400 {
401         echo 2>&1 "${programName}: ${1}"
402 }
403 syntaxError()
404 {
405         programMessage "${1}"
406         exit 2
407 }
408 internalError()
409 {
410         programMessage "${1}"
411         exit 3
412 }
413
414 configurationFile=""
415 requestedAction=create
416 deviceTranslation=none
417 requestedParameter=""
418 OPTIND=1
419 while getopts ":f:cundop:h" option
420 do
421         case "${option}" in
422             f) configurationFile="${OPTARG}";;
423             c) requestedAction=create;;
424             u) requestedAction=update;;
425             n) deviceTranslation=none;;
426             d) deviceTranslation=devfs;;
427             o) deviceTranslation=old;;
428             p) requestedParameter="${OPTARG}";;
429             h)
430                 cat <<EOF
431 Usage: ${programName} [option ...]
432 -f file  The configuration file to create/update.
433 -c       Create the configuration file (write to stdout if no -f).
434 -u       Update the configuration file (copying from stdin to stdout if no -f).
435 -n       Do not translate device paths.
436 -d       Do old-style to devfs device path translation.
437 -o       Do devfs to old-style device path translation.
438 -p [driver][,[device][,[table]]]
439          Explicitly specify the boot parameter.
440 -h       Display this usage summary.
441 EOF
442                 exit 0
443                 ;;
444             \?) syntaxError "unknown option: -${OPTARG}";;
445             :) syntaxError "missing value: -${OPTARG}";;
446             *) internalError "unimplemented option: -${option}";;
447         esac
448 done
449 shift "`expr $OPTIND - 1`"
450 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
451
452 case "${requestedAction}" in
453     create)
454         putConfigurationLine()
455         {
456                 echo "${1}" || exit 4
457         }
458         startConfigurationFile()
459         {
460                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
461                 putConfigurationLine "`makeHeaderLine Created`"
462                 putConfigurationLine "`makeParameterLine`"
463                 putConfigurationLine ""
464         }
465         putConfigurationDirective()
466         {
467                 putConfigurationLine "${1} ${2}"
468         }
469         finalizeConfigurationFile()
470         {
471                 :
472         }
473         ;;
474     update)
475         putSedCommand()
476         {
477                 sedScript="${sedScript}
478 ${1}"
479         }
480         startConfigurationFile()
481         {
482                 if [ -n "${configurationFile}" ]; then
483                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
484                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
485                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
486                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
487                         outputFile="${configurationFile}.new"
488                         exec <"${configurationFile}" >"${outputFile}"
489                 fi
490                 sedScript=""
491                 putSedCommand "1i\\
492 `makeHeaderLine Updated`\\
493 `makeParameterLine`\\
494 "
495         }
496         putConfigurationDirective()
497         {
498                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
499                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
500                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
501         }
502         finalizeConfigurationFile()
503         {
504                 sed -e "${sedScript}"
505                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
506         }
507         ;;
508     *) internalError "unimplemented action: ${requestedAction}";;
509 esac
510
511 translateDevice_none()
512 {
513         :
514 }
515 translateDevice_devfs()
516 {
517         minor="${device#ttyS}"
518         if [ "${minor}" != "${device}" ]; then
519                 device="tts/${minor}"
520                 return 0
521         fi
522         minor="${device#lp}"
523         if [ "${minor}" != "${device}" ]; then
524                 device="printers/${minor}"
525                 return 0
526         fi
527         programMessage "unsupported old-style device: ${device}"
528 }
529 translateDevice_old()
530 {
531         major="${device%%/*}"
532         if [ "${major}" != "${device}" ]; then
533                 minor="${device#*/}"
534                 case "${major}" in
535                     tts) devfs="ttyS${minor}";;
536                     printers) devfs="lp${minor}";;
537                 esac
538         fi
539         if [ -n "${devfs}" ]; then
540                 device="${devfs}"
541         else
542                 programMessage "unsupported devfs device: ${device}"
543         fi
544 }
545
546 makeHeaderLine()
547 {
548         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
549 }
550 makeParameterLine()
551 {
552         echo "# Boot Parameter:${bootParameter}"
553 }
554 putConfigurationFile()
555 {
556         startConfigurationFile
557         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
558         [ -n "${brailleDevice}" ] && {
559         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
560         if [ "${device#/}" = "${device}" ]; then
561                 translateDevice_${deviceTranslation}
562         fi
563         putConfigurationDirective "braille-device" "${device}"
564         }
565         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
566         finalizeConfigurationFile
567 }
568 parseBootParameter()
569 {
570         bootParameter="${bootParameter} ${1}"
571         number=1
572         while [ "${number}" -le 3 ]; do
573                 cut="cut -d, -f${number}"
574                 [ "${number}" -gt 1 ] && cut="${cut} -s"
575                 operand="`echo ${1} | ${cut}`"
576                 if [ -n "${operand}" ]; then
577                         case "${number}" in
578                             1) brailleDriver="${operand}";;
579                             2) brailleDevice="${operand}";;
580                             3) textTable="${operand}";;
581                         esac
582                 fi
583                 number="`expr ${number} + 1`"
584         done
585 }
586 putBootParameter()
587 {
588         parseBootParameter "${1}"
589         putConfigurationFile
590 }
591 parseBootCommand()
592 {
593         found=false
594         while [ "${#}" -gt 0 ]; do
595                 case "${1}" in
596                     "brltty="*)
597                         found=true
598                         parseBootParameter "${1#*=}"
599                         ;;
600                 esac
601                 shift
602         done
603         "${found}" && putConfigurationFile
604 }
605
606 brailleDriver=""
607 brailleDevice=""
608 textTable=""
609 bootCommandFile="/proc/cmdline"
610 if [ -n "${requestedParameter}" ]; then
611         putBootParameter "${requestedParameter}"
612 elif [ -f "${bootCommandFile}" ]; then
613         parseBootCommand `cat "${bootCommandFile}"`
614 elif [ -n "${brltty}" ]; then
615         putBootParameter "${brltty}"
616 fi
617 exit 0
618 )
619
620 %post   -n brlapi -p /sbin/ldconfig
621 %postun -n brlapi -p /sbin/ldconfig
622
623 %files -f %{name}.lang
624 %defattr(644,root,root,755)
625 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
626 %attr(755,root,root) %{_bindir}/brltty
627 %attr(755,root,root) %{_bindir}/brltty-atb
628 %attr(755,root,root) %{_bindir}/brltty-config
629 %attr(755,root,root) %{_bindir}/brltty-cldr
630 %attr(755,root,root) %{_bindir}/brltty-ctb
631 %attr(755,root,root) %{_bindir}/brltty-ktb
632 %attr(755,root,root) %{_bindir}/brltty-lscmds
633 %attr(755,root,root) %{_bindir}/brltty-lsinc
634 %attr(755,root,root) %{_bindir}/brltty-morse
635 %attr(755,root,root) %{_bindir}/brltty-trtxt
636 %attr(755,root,root) %{_bindir}/brltty-ttb
637 %attr(755,root,root) %{_bindir}/brltty-tune
638 %attr(755,root,root) %{_bindir}/eutp
639 %attr(755,root,root) %{_bindir}/vstp
640 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
641 %dir %{_libdir}/brltty
642 # Braille drivers
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybic.so
662 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
663 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
667 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
671 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
672 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
673 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
674 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
676 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
677 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
678 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
679 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
680 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
681 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
682 # speech synthesizer drivers
683 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
684 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
685 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
686 %{?with_espeak_ng:%attr(755,root,root) %{_libdir}/brltty/libbrlttysen.so}
687 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
688 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
689 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
690 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
691 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
692 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
693 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
694 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
695 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
696 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
697 # screen drivers
698 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
699 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
700 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
701 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
702 %{_sysconfdir}/brltty
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
704 %{systemdtmpfilesdir}/brltty.conf
705 %dir /var/lib/BrlAPI
706 %dir /var/run/brltty
707 %{_mandir}/man1/brltty.1*
708 %{_mandir}/man1/eutp.1*
709 %{_mandir}/man1/vstp.1*
710 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
711
712 %if %{with x}
713 # gdm autostart - subpackage?
714 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
715 #/etc/X11/Xsession.d/60xbrlapi
716 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
717 %endif
718 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
719
720 %files -n brlapi
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
723 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.7
724
725 %files -n brlapi-devel
726 %defattr(644,root,root,755)
727 %doc Documents/Manual-BrlAPI/English/BrlAPI*
728 %attr(755,root,root) %{_libdir}/libbrlapi.so
729 %{_includedir}/brltty
730 %{_includedir}/brlapi*.h
731 %{_mandir}/man3/brlapi_*.3*
732
733 %files -n brlapi-static
734 %defattr(644,root,root,755)
735 %{_libdir}/libbrlapi.a
736
737 %if %{with apidocs}
738 %files -n brlapi-apidocs
739 %defattr(644,root,root,755)
740 %doc Documents/BrlAPIref/html/*
741 %endif
742
743 %if %{with java}
744 %files -n java-brlapi
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
747 %{_javadir}/brlapi.jar
748 %endif
749
750 %if %{with ocaml}
751 %files -n ocaml-brlapi
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
754
755 %files -n ocaml-brlapi-devel
756 %defattr(644,root,root,755)
757 %dir %{_libdir}/ocaml/brlapi
758 %{_libdir}/ocaml/brlapi/META
759 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
760 %{_libdir}/ocaml/brlapi/brlapi.mli
761 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
762 %endif
763
764 %if %{with python}
765 %files -n python-brlapi
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{py_sitedir}/brlapi.so
768 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
769
770 %if %{with python3}
771 %files -n python3-brlapi
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
774 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
775 %endif
776 %endif
777
778 %if %{with tcl}
779 %files -n brlapi-tcl
780 %defattr(644,root,root,755)
781 %dir %{_libdir}/brlapi-%{brlapi_ver}
782 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
783 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
784 %endif
This page took 0.143035 seconds and 3 git commands to generate.