]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
4ccbe756cce7a2b36c1abf2fa151d5d0503e26b8
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  liblouis                # liblouis in-line contracted Braille support
15 %bcond_without  espeak                  # eSpeak synthesizer driver
16 %bcond_without  espeak_ng               # eSpeak-NG synthesizer driver
17 %bcond_without  flite                   # Flite synthesizer driver
18 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
19 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
20 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
21 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
22 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
23 %bcond_with     at_spi                  # AtSpi screen driver
24 %bcond_without  at_spi2                 # AtSpi2 screen driver
25
26 %define         brlapi_ver      0.7.0
27 Summary:        Braille display driver for Linux/Unix
28 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
29 Name:           brltty
30 Version:        6.0
31 Release:        4
32 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
33 Group:          Daemons
34 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
35 # Source0-md5:  feca8c2f22b13a4c67b1366191033c0e
36 Patch1:         %{name}-speech-dispatcher.patch
37 Patch2:         %{name}-python.patch
38 Patch4:         %{name}-glibc25.patch
39 URL:            http://mielke.cc/brltty/
40 BuildRequires:  alsa-lib-devel
41 %{?with_at_spi:BuildRequires:   at-spi-devel}
42 BuildRequires:  autoconf >= 2.64
43 BuildRequires:  automake
44 BuildRequires:  bison
45 # just headers
46 BuildRequires:  bluez-libs-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 %{?with_espeak:BuildRequires:   espeak-devel}
50 %{?with_espeak_ng:BuildRequires:        espeak-ng-devel}
51 BuildRequires:  expat-devel
52 %{?with_flite:BuildRequires:    flite-devel}
53 BuildRequires:  gettext-tools
54 %{?with_gpm:BuildRequires:      gpm-devel}
55 %{?with_java:BuildRequires:     jdk}
56 %{?with_java:BuildRequires:     jpackage-utils}
57 %{?with_libbraille:BuildRequires:       libbraille-devel}
58 BuildRequires:  libicu-devel
59 %{?with_liblouis:BuildRequires: liblouis-devel}
60 BuildRequires:  ncurses-devel
61 %{?with_ocaml:BuildRequires:    ocaml}
62 BuildRequires:  pkgconfig
63 BuildRequires:  polkit-devel
64 %{?with_python:BuildRequires:   python-Cython}
65 %{?with_python3:BuildRequires:  python3-Cython}
66 %{?with_java:BuildRequires:     rpm-javaprov}
67 %{?with_python:BuildRequires:   rpm-pythonprov}
68 BuildRequires:  rpmbuild(macros) >= 1.710
69 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
70 BuildRequires:  systemd-devel
71 BuildRequires:  tar >= 1:1.22
72 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
73 %if %{with x}
74 BuildRequires:  xorg-lib-libX11-devel
75 BuildRequires:  xorg-lib-libXaw-devel
76 BuildRequires:  xorg-lib-libXext-devel
77 BuildRequires:  xorg-lib-libXt-devel
78 BuildRequires:  xorg-lib-libXtst-devel
79 %endif
80 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
81 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
82 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
83 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
84 BuildRequires:  xz
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88 BRLTTY is a background process (daemon) which provides access to the
89 Linux/Unix console (when in text mode) for a blind person using a
90 refreshable Braille display. It drives the Braille display, and
91 provides complete screen review functionality. Some speech capability
92 has also been incorporated.
93
94 %description -l pl.UTF-8
95 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
96 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
97 odświeżaniem (refreshable Braille display). BRLTTY steruje
98 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
99 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
100 mowy.
101
102 %package -n brlapi
103 Summary:        Application Programming Interface for BRLTTY
104 Summary(pl.UTF-8):      API do BRLTTY
105 License:        LGPL v2.1+
106 Group:          Libraries
107
108 %description -n brlapi
109 This package provides the run-time support for the Application
110 Programming Interface to BRLTTY.
111
112 Install this package if you have an application which directly
113 accesses a refreshable Braille display.
114
115 %description -n brlapi -l pl.UTF-8
116 Ten pakiet zawiera środowisko uruchomieniowe dla programów
117 korzystających z API BRLTTY.
118
119 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
120 wyświetlacza Braille'a z odświeżaniem.
121
122 %package -n brlapi-devel
123 Summary:        Headers and documentation for BrlAPI
124 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
125 License:        LGPL v2.1+
126 Group:          Development/Libraries
127 Requires:       brlapi = %{version}-%{release}
128
129 %description -n brlapi-devel
130 This package provides the header files, shared object linker
131 reference, and reference documentation for BrlAPI (the Application
132 Programming Interface to BRLTTY). It enables the implementation of
133 applications which take direct advantage of a refreshable Braille
134 display in order to present information in ways which are more
135 appropriate for blind users and/or to provide user interfaces which
136 are more specifically atuned to their needs.
137
138 Install this package if you're developing or maintaining an
139 application which directly accesses a refreshable Braille display.
140
141 %description -n brlapi-devel -l pl.UTF-8
142 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
143 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
144 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
145 bardziej przystosowany dla osób niewidomych.
146
147 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
148 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
149
150 %package -n brlapi-static
151 Summary:        Static BrlAPI library
152 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
153 License:        LGPL v2.1+
154 Group:          Development/Libraries
155 Requires:       brlapi-devel = %{version}-%{release}
156
157 %description -n brlapi-static
158 This is package with static BrlAPI library.
159
160 %description -n brlapi-static -l pl.UTF-8
161 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
162
163 %package -n brlapi-apidocs
164 Summary:        BrlAPI documentation
165 Summary(pl.UTF-8):      Documentacja BrlAPI
166 Group:          Documentation
167 %if "%{_rpmversion}" >= "5"
168 BuildArch:      noarch
169 %endif
170
171 %description -n brlapi-apidocs
172 Documentation for BrlAPI in HTML format generated from brltty sources
173 by doxygen.
174
175 %description -n brlapi-apidocs -l pl.UTF-8
176 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
177 doxygen.
178
179 %package -n java-brlapi
180 Summary:        BrlAPI library for Java
181 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
182 License:        LGPL v2.1+
183 Group:          Libraries
184 Requires:       brlapi = %{version}-%{release}
185
186 %description -n java-brlapi
187 BrlAPI library for Java.
188
189 %description -n java-brlapi -l pl.UTF-8
190 Biblioteka BrlAPI dla Javy.
191
192 %package -n ocaml-brlapi
193 Summary:        OCaml binding for BrlAPI
194 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
195 License:        LGPL v2.1+
196 Group:          Libraries
197 Requires:       brlapi = %{version}-%{release}
198 %requires_eq    ocaml-runtime
199
200 %description -n ocaml-brlapi
201 OCaml binding for BrlAPI.
202
203 %description -n ocaml-brlapi -l pl.UTF-8
204 Wiązania OCamla do BrlAPI.
205
206 %package -n ocaml-brlapi-devel
207 Summary:        OCaml binding for BrlAPI - development files
208 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
209 License:        LGPL v2.1+
210 Group:          Libraries
211 Requires:       ocaml-brlapi = %{version}-%{release}
212 %requires_eq    ocaml
213
214 %description -n ocaml-brlapi-devel
215 OCaml binding for BrlAPI - development files.
216
217 %description -n ocaml-brlapi-devel -l pl.UTF-8
218 Wiązania OCamla do BrlAPI - pliki programistyczne.
219
220 %package -n python-brlapi
221 Summary:        Python 2.x interface to BrlAPI
222 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
223 License:        LGPL v2.1+
224 Group:          Libraries
225 Requires:       brlapi = %{version}-%{release}
226
227 %description -n python-brlapi
228 Python 2.x interface to BrlAPI.
229
230 %description -n python-brlapi -l pl.UTF-8
231 Interfejs Pythona 2.x do BrlAPI.
232
233 %package -n python3-brlapi
234 Summary:        Python 3.x interface to BrlAPI
235 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
236 License:        LGPL v2.1+
237 Group:          Libraries
238 Requires:       brlapi = %{version}-%{release}
239
240 %description -n python3-brlapi
241 Python 3.x interface to BrlAPI.
242
243 %description -n python3-brlapi -l pl.UTF-8
244 Interfejs Pythona 3.x do BrlAPI.
245
246 %package -n brlapi-tcl
247 Summary:        BrlAPI library for Tcl
248 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
249 License:        LGPL v2.1+
250 Group:          Libraries
251 Requires:       brlapi = %{version}-%{release}
252
253 %description -n brlapi-tcl
254 BrlAPI library for Tcl.
255
256 %description -n brlapi-tcl -l pl.UTF-8
257 Biblioteka BrlAPI dla Tcl.
258
259 %prep
260 %setup -q
261 %patch1 -p1
262 %patch2 -p1
263 %patch4 -p1
264
265 %build
266 %{__autoconf}
267 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
268 %configure \
269         %{?with_java:JAVA_HOME=%{java_home}} \
270         --with-install-root="$RPM_BUILD_ROOT" \
271         %{!?with_libbraille:--without-libbraille} \
272         %{!?with_espeak:--without-espeak} \
273         %{!?with_espeak_ng:--without-espeak_ng} \
274         %{!?with_flite:--without-flite} \
275         %{!?with_speech_dispatcher:--without-speechd} \
276         %{!?with_ocaml:--disable-caml-bindings} \
277         %{!?with_gpm:--disable-gpm} \
278         %{!?with_java:--disable-java-bindings} \
279         %{!?with_liblouis:--disable-liblouis} \
280         --enable-lisp-bindings \
281         %{!?with_python:--disable-python-bindings} \
282         %{!?with_tcl:--disable-tcl-bindings} \
283         %{!?with_x:--disable-x} \
284         --enable-api
285
286 %{__make} -j1
287
288 %if %{with python}
289 cd Bindings/Python
290 %py_build
291 cd ../..
292 %endif
293
294 %if %{with python3}
295 cd Bindings/Python
296 %py3_build
297 cd ../..
298 %endif
299
300 %install
301 rm -rf $RPM_BUILD_ROOT
302
303 %{__make} -j1 install install-appstream \
304         OCAML_INSTALL_TARGET=install-without-findlib
305
306 # findlib-specific, useless in rpm
307 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
308
309 %if %{with python}
310 cd Bindings/Python
311 %py_install
312 cd ../..
313 %endif
314
315 %if %{with python3}
316 cd Bindings/Python
317 %py3_install
318 cd ../..
319 %endif
320
321 %if %{_lib} != "lib"
322         # Fix java plugin install path on 64-bit archs
323         install -d $RPM_BUILD_ROOT%{_libdir}/java
324         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
325 %endif
326
327 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
328
329 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
330 cat >$RPM_BUILD_ROOT%{systemdtmpfilesdir}/brltty.conf <<EOF
331 d /var/run/brltty 0755 root root -
332 EOF
333
334 # no sign in source wheter it is zh_CN or zh_TW
335 # but seems to contain Traditional Chinese characters
336 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_TW}
337
338 %find_lang %{name}
339
340 %clean
341 rm -rf $RPM_BUILD_ROOT
342
343 %pre
344 # The pre-install scriptlet.
345
346 # If a configuration file already exists then rpm installs the new one as
347 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
348 # already exists.
349
350 # There's no explicit way to tell if a configuration file has been installed
351 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
352 # erasing the .rpmnew file now so that we can see if it gets created later.
353 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
354
355 %post
356 # The post-install scriptlet.
357
358 # If BRLTTY's boot parameter has been specified then update the just installed
359 # configuration file template to reflect the options supplied thereby.
360
361 # First, we need to determine which file to update. If there's a .rpmnew file
362 # then update it since a previous configuration file must already have existed.
363 file="%{_sysconfdir}/brltty.conf"
364 new="${file}.rpmnew"
365 [ -f "${new}" ] && file="${new}"
366
367 # Update the configuration file template via the Bootdisks/bp2cf script.
368 # Include it right within this scriptlet so that it needn't be installed.
369 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
370 (
371         # First, set bp2cf's command line arguments.
372         set -- -u -f "${file}"
373
374 #!/bin/sh
375 ###############################################################################
376 # BRLTTY - A background process providing access to the Linux console (when in
377 #          text mode) for a blind person using a refreshable Braille display.
378 #
379 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
380 #
381 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
382 #
383 # This is free software, placed under the terms of the
384 # GNU General Public License, as published by the Free Software
385 # Foundation.  Please see the file COPYING for details.
386 #
387 # Web Page: http://mielke.cc/brltty/
388 #
389 # This software is maintained by Dave Mielke <dave@mielke.cc>.
390 ###############################################################################
391
392 # Convert the boot parameter to configuration file directives.
393 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
394 # If /proc is not mounted then use the brltty environment variable.
395 # Invoke with -h for usage information.
396
397 programName="${0##*/}"
398 programMessage()
399 {
400         echo 2>&1 "${programName}: ${1}"
401 }
402 syntaxError()
403 {
404         programMessage "${1}"
405         exit 2
406 }
407 internalError()
408 {
409         programMessage "${1}"
410         exit 3
411 }
412
413 configurationFile=""
414 requestedAction=create
415 deviceTranslation=none
416 requestedParameter=""
417 OPTIND=1
418 while getopts ":f:cundop:h" option
419 do
420         case "${option}" in
421             f) configurationFile="${OPTARG}";;
422             c) requestedAction=create;;
423             u) requestedAction=update;;
424             n) deviceTranslation=none;;
425             d) deviceTranslation=devfs;;
426             o) deviceTranslation=old;;
427             p) requestedParameter="${OPTARG}";;
428             h)
429                 cat <<EOF
430 Usage: ${programName} [option ...]
431 -f file  The configuration file to create/update.
432 -c       Create the configuration file (write to stdout if no -f).
433 -u       Update the configuration file (copying from stdin to stdout if no -f).
434 -n       Do not translate device paths.
435 -d       Do old-style to devfs device path translation.
436 -o       Do devfs to old-style device path translation.
437 -p [driver][,[device][,[table]]]
438          Explicitly specify the boot parameter.
439 -h       Display this usage summary.
440 EOF
441                 exit 0
442                 ;;
443             \?) syntaxError "unknown option: -${OPTARG}";;
444             :) syntaxError "missing value: -${OPTARG}";;
445             *) internalError "unimplemented option: -${option}";;
446         esac
447 done
448 shift "`expr $OPTIND - 1`"
449 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
450
451 case "${requestedAction}" in
452     create)
453         putConfigurationLine()
454         {
455                 echo "${1}" || exit 4
456         }
457         startConfigurationFile()
458         {
459                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
460                 putConfigurationLine "`makeHeaderLine Created`"
461                 putConfigurationLine "`makeParameterLine`"
462                 putConfigurationLine ""
463         }
464         putConfigurationDirective()
465         {
466                 putConfigurationLine "${1} ${2}"
467         }
468         finalizeConfigurationFile()
469         {
470                 :
471         }
472         ;;
473     update)
474         putSedCommand()
475         {
476                 sedScript="${sedScript}
477 ${1}"
478         }
479         startConfigurationFile()
480         {
481                 if [ -n "${configurationFile}" ]; then
482                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
483                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
484                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
485                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
486                         outputFile="${configurationFile}.new"
487                         exec <"${configurationFile}" >"${outputFile}"
488                 fi
489                 sedScript=""
490                 putSedCommand "1i\\
491 `makeHeaderLine Updated`\\
492 `makeParameterLine`\\
493 "
494         }
495         putConfigurationDirective()
496         {
497                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
498                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
499                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
500         }
501         finalizeConfigurationFile()
502         {
503                 sed -e "${sedScript}"
504                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
505         }
506         ;;
507     *) internalError "unimplemented action: ${requestedAction}";;
508 esac
509
510 translateDevice_none()
511 {
512         :
513 }
514 translateDevice_devfs()
515 {
516         minor="${device#ttyS}"
517         if [ "${minor}" != "${device}" ]; then
518                 device="tts/${minor}"
519                 return 0
520         fi
521         minor="${device#lp}"
522         if [ "${minor}" != "${device}" ]; then
523                 device="printers/${minor}"
524                 return 0
525         fi
526         programMessage "unsupported old-style device: ${device}"
527 }
528 translateDevice_old()
529 {
530         major="${device%%/*}"
531         if [ "${major}" != "${device}" ]; then
532                 minor="${device#*/}"
533                 case "${major}" in
534                     tts) devfs="ttyS${minor}";;
535                     printers) devfs="lp${minor}";;
536                 esac
537         fi
538         if [ -n "${devfs}" ]; then
539                 device="${devfs}"
540         else
541                 programMessage "unsupported devfs device: ${device}"
542         fi
543 }
544
545 makeHeaderLine()
546 {
547         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
548 }
549 makeParameterLine()
550 {
551         echo "# Boot Parameter:${bootParameter}"
552 }
553 putConfigurationFile()
554 {
555         startConfigurationFile
556         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
557         [ -n "${brailleDevice}" ] && {
558         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
559         if [ "${device#/}" = "${device}" ]; then
560                 translateDevice_${deviceTranslation}
561         fi
562         putConfigurationDirective "braille-device" "${device}"
563         }
564         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
565         finalizeConfigurationFile
566 }
567 parseBootParameter()
568 {
569         bootParameter="${bootParameter} ${1}"
570         number=1
571         while [ "${number}" -le 3 ]; do
572                 cut="cut -d, -f${number}"
573                 [ "${number}" -gt 1 ] && cut="${cut} -s"
574                 operand="`echo ${1} | ${cut}`"
575                 if [ -n "${operand}" ]; then
576                         case "${number}" in
577                             1) brailleDriver="${operand}";;
578                             2) brailleDevice="${operand}";;
579                             3) textTable="${operand}";;
580                         esac
581                 fi
582                 number="`expr ${number} + 1`"
583         done
584 }
585 putBootParameter()
586 {
587         parseBootParameter "${1}"
588         putConfigurationFile
589 }
590 parseBootCommand()
591 {
592         found=false
593         while [ "${#}" -gt 0 ]; do
594                 case "${1}" in
595                     "brltty="*)
596                         found=true
597                         parseBootParameter "${1#*=}"
598                         ;;
599                 esac
600                 shift
601         done
602         "${found}" && putConfigurationFile
603 }
604
605 brailleDriver=""
606 brailleDevice=""
607 textTable=""
608 bootCommandFile="/proc/cmdline"
609 if [ -n "${requestedParameter}" ]; then
610         putBootParameter "${requestedParameter}"
611 elif [ -f "${bootCommandFile}" ]; then
612         parseBootCommand `cat "${bootCommandFile}"`
613 elif [ -n "${brltty}" ]; then
614         putBootParameter "${brltty}"
615 fi
616 exit 0
617 )
618
619 %post   -n brlapi -p /sbin/ldconfig
620 %postun -n brlapi -p /sbin/ldconfig
621
622 %files -f %{name}.lang
623 %defattr(644,root,root,755)
624 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
625 %attr(755,root,root) %{_bindir}/brltty
626 %attr(755,root,root) %{_bindir}/brltty-atb
627 %attr(755,root,root) %{_bindir}/brltty-config
628 %attr(755,root,root) %{_bindir}/brltty-cldr
629 %attr(755,root,root) %{_bindir}/brltty-ctb
630 %attr(755,root,root) %{_bindir}/brltty-ktb
631 %attr(755,root,root) %{_bindir}/brltty-lscmds
632 %attr(755,root,root) %{_bindir}/brltty-lsinc
633 %attr(755,root,root) %{_bindir}/brltty-morse
634 %attr(755,root,root) %{_bindir}/brltty-trtxt
635 %attr(755,root,root) %{_bindir}/brltty-ttb
636 %attr(755,root,root) %{_bindir}/brltty-tune
637 %attr(755,root,root) %{_bindir}/eutp
638 %attr(755,root,root) %{_bindir}/vstp
639 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
640 %dir %{_libdir}/brltty
641 # Braille drivers
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybic.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
662 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
667 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
671 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
672 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
673 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
674 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
676 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
677 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
678 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
679 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
680 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
681 # speech synthesizer drivers
682 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
683 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
684 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
685 %{?with_espeak_ng:%attr(755,root,root) %{_libdir}/brltty/libbrlttysen.so}
686 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
687 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
688 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
689 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
690 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
691 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
692 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
693 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
694 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
695 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
696 # screen drivers
697 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
698 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
699 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
700 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
701 %{_sysconfdir}/brltty
702 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
703 %{systemdtmpfilesdir}/brltty.conf
704 %dir /var/lib/BrlAPI
705 %dir /var/run/brltty
706 %{_mandir}/man1/brltty.1*
707 %{_mandir}/man1/eutp.1*
708 %{_mandir}/man1/vstp.1*
709 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
710
711 %if %{with x}
712 # gdm autostart - subpackage?
713 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
714 #/etc/X11/Xsession.d/60xbrlapi
715 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
716 %endif
717 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
718
719 %files -n brlapi
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.7
723
724 %files -n brlapi-devel
725 %defattr(644,root,root,755)
726 %doc Documents/Manual-BrlAPI/English/BrlAPI*
727 %attr(755,root,root) %{_libdir}/libbrlapi.so
728 %{_includedir}/brltty
729 %{_includedir}/brlapi*.h
730 %{_mandir}/man3/brlapi_*.3*
731
732 %files -n brlapi-static
733 %defattr(644,root,root,755)
734 %{_libdir}/libbrlapi.a
735
736 %if %{with apidocs}
737 %files -n brlapi-apidocs
738 %defattr(644,root,root,755)
739 %doc Documents/BrlAPIref/html/*
740 %endif
741
742 %if %{with java}
743 %files -n java-brlapi
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
746 %{_javadir}/brlapi.jar
747 %endif
748
749 %if %{with ocaml}
750 %files -n ocaml-brlapi
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
753
754 %files -n ocaml-brlapi-devel
755 %defattr(644,root,root,755)
756 %dir %{_libdir}/ocaml/brlapi
757 %{_libdir}/ocaml/brlapi/META
758 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
759 %{_libdir}/ocaml/brlapi/brlapi.mli
760 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
761 %endif
762
763 %if %{with python}
764 %files -n python-brlapi
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{py_sitedir}/brlapi.so
767 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
768
769 %if %{with python3}
770 %files -n python3-brlapi
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
773 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
774 %endif
775 %endif
776
777 %if %{with tcl}
778 %files -n brlapi-tcl
779 %defattr(644,root,root,755)
780 %dir %{_libdir}/brlapi-%{brlapi_ver}
781 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
782 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
783 %endif
This page took 0.392353 seconds and 2 git commands to generate.