]> git.pld-linux.org Git - packages/bpython.git/blob - bpython.spec
- up to 0.9.7.1
[packages/bpython.git] / bpython.spec
1 # TODO:
2 # - check docs folder for valuable files
3 #
4 %define         pname   bpython
5 Summary:        bpython - a fancy interface to the Python interpreter
6 Name:           bpython
7 Version:        0.9.7.1
8 Release:        1
9 License:        MIT
10 Group:          Applications/Shells
11 Source0:        http://bpython-interpreter.org/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  f32ce6aa8ae6af8d2cf65e13f58859d4
13 URL:            http://bpython-interpreter.org/
14 BuildRequires:  pydoc
15 BuildRequires:  python-devel
16 BuildRequires:  python-devel-tools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 Requires:       python-%{name} = %{version}-%{release}
20 Requires:       python-distribute >= 0.6.10
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 bpython is a fancy interface to the Python interpreter for Unix-like
26 operating systems.
27
28 %package -n python-bpython
29 Summary:        bpython shell modules
30 Group:          Libraries/Python
31 Requires:       python-pygments
32 %pyrequires_eq  python-devel-tools
33 %pyrequires_eq  pydoc
34
35 %description -n python-bpython
36 bpython is a fancy interface to the Python interpreter for Unix-like
37 operating systems.
38
39 %package -n python-bpdb
40 Summary:        bpdb module
41 Group:          Libraries/Python
42 %pyrequires_eq  python-devel-tools
43 %pyrequires_eq  pydoc
44
45 %description -n python-bpdb
46 BPDB is an extension to PDB which allows you to press B in a PDB
47 session which will let you be dropped into a bpython sessions with the
48 current PDB locals()
49
50 %prep
51 %setup -q
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
57
58 %py_postclean
59 rm -rf $RPM_BUILD_ROOT%{_docdir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{_bindir}/*
67 %{_desktopdir}/bpython.desktop
68 %{_mandir}/man1/*.1*
69 %{_mandir}/man5/*.5*
70
71 %files -n python-bpython
72 %defattr(644,root,root,755)
73 %doc README
74 %{py_sitescriptdir}/%{pname}
75 %{py_sitescriptdir}/*.egg-info
76
77 %files -n python-bpdb
78 %defattr(644,root,root,755)
79 %doc README
80 %{py_sitescriptdir}/bpdb
This page took 0.126914 seconds and 4 git commands to generate.