]> git.pld-linux.org Git - packages/bond.git/blob - bond.spec
- cosmetics
[packages/bond.git] / bond.spec
1 #
2 # Conditional build:
3 #%bcond_with    tests           # build with tests
4 #%bcond_without tests           # build without tests
5 #
6 Summary:        building object network databases
7 Summary(pl):    Sieciowe obiektowe bazy danych
8 Name:           bond
9 Version:        2.0.9
10 Release:        0.1
11 License:        GPL v2
12 Group:          Development
13 Source0:        http://bond.treshna.com/%{name}-%{version}.tar.gz
14 # Source0-md5:  08b033a93d8b1a123a1be5fe112ac521
15 URL:            http://bond.treshna.com/
16 BuildRequires:  libxml2-devel >= 2.6.0
17 BuildRequires:  postgresql-devel
18 BuildRequires:  libgda-devel
19 Requires:       libxml2 >= 2.6.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Bond is a rapid application development (RAD) tool for linux that
24 allows you to create network database programs quickly and easily.
25
26 %description -l pl
27 Bond jest narzêdziem RAD dla linuksa które pozwola tworzyæ sieciowe
28 bazy danych szybko i ³atwo.
29
30 %package -n bonddb
31 Summary:        building object network databases -- database
32 Summary(pl):    Sieciowe obiektowe bazy danych -- bazadanych
33 Group:          Development
34
35 %description -n bonddb
36 DB part of Bond.
37
38 %description -n bonddb -l pl
39 Czê¶æ bazodanowa Bonda
40
41 %prep
42 %setup -q -n %{name}
43 %build
44
45 cd bonddb
46
47 %{__gettextize}
48 %{__libtoolize}
49 %{__aclocal}
50 %{__autoconf}
51 %{__autoheader}
52 %{__automake}
53 %configure --enable-mysql=yes --enable-gda=yes --with-gnu-ld --with-pic
54 %{__make}
55
56 cd ..
57
58 cd bond
59 %{__gettextize}
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure
66 %{__make}
67 cd ..
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 # create directories if necessary
72 #install -d $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
83
84 # if _sysconfdir != /etc:
85 #%%dir %{_sysconfdir}
86 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
87
88 %attr(755,root,root) %{_bindir}/*
89
90 %{_datadir}/%{name}
91
92 # initscript and its config
93 %attr(754,root,root) /etc/rc.d/init.d/%{name}
94 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
95
96 %files -n bonddb
97 %defattr(644,root,root,755)
98 #%doc extras/*.gz
99 #%{_datadir}/%{name}-ext
This page took 0.080103 seconds and 3 git commands to generate.