]> git.pld-linux.org Git - packages/bogofilter.git/blob - bogofilter.spec
20b34a4d6df56dc4e7e61eb0871c50860b75e4b1
[packages/bogofilter.git] / bogofilter.spec
1 #
2 # Conditional build:
3 %bcond_with     db3     # build with db3 support instead of db4
4 #
5 Summary:        Bayesian Spam Filter
6 Summary(pl):    Bayesjañski Filtr Antyspamowy
7 Name:           bogofilter
8 Version:        0.16.0
9 Release:        1
10 License:        GPL
11 Group:          Applications/Mail
12 Vendor:         Eric S. Raymond <esr@thyrsus.com>
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  6c039fae3d481c6b89d4f39ed7a70a23
15 Patch0:         %{name}-home_etc.patch
16 Patch1:         %{name}-dummy.patch
17 URL:            http://bogofilter.sourceforge.net/
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 %{!?with_db3:BuildRequires:     db-devel}
21 %{?with_db3:BuildRequires:      db3-devel}
22 BuildRequires:  flex
23 BuildRequires:  gsl-devel
24 BuildRequires:  judy-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         specflags_ia32  -fomit-frame-pointer
28
29 %description
30 Bogofilter is a Bayesian spam filter. In its normal mode of operation,
31 it takes an email message or other text on standard input, does a
32 statistical check against lists of "good" and "bad" words, and returns
33 a status code indicating whether or not the message is spam.
34 Bogofilter is designed with fast algorithms (including Berkeley DB
35 system), coded directly in C, and tuned for speed, so it can be used
36 for production by sites that process a lot of mail.
37
38 %description -l pl
39 Bogofilter jest bayesjañskim filtrem antyspamowym. W podstawowym
40 trybie dzia³ania na emailu lub innym tek¶cie odczytanym na wej¶ciu
41 wykonuje statystyczne testy na wystêpowanie "dobrych" i "z³ych" s³ów i
42 zwraca kod powrotu wskazuj±cy czy wiadomo¶æ jest spamem, czy te¿ nie.
43 Bogofilter jest zaprojektowany z u¿yciem szybkich algorytmów
44 (w³±czaj±c w to Berkeley DB), napisany w czystym C i "podkrêcony" pod
45 k±tem szybko¶ci, a wiêc mo¿e byæ u¿ywany na systemach "produkcyjnych",
46 które przetwarzaj± du¿e ilo¶ci poczty.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p0
52
53 %build
54 rm -f missing
55 %{__aclocal}
56 %{__autoconf}
57 %{__autoheader}
58 %{__automake}
59 %configure
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install DESTDIR=$RPM_BUILD_ROOT
66
67 cp $RPM_BUILD_ROOT%{_sysconfdir}/bogofilter.cf.example $RPM_BUILD_ROOT%{_sysconfdir}/bogofilter.cf
68
69 rm -f $RPM_BUILD_ROOT%{_bindir}/lexertest
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc AUTHORS METHODS NEWS README RELEASE.NOTES-0.16 TODO
77 %config(noreplace,missingok) %{_sysconfdir}/bogofilter.cf
78 %attr(755,root,root) %{_bindir}/*
79 %attr(644,root,root) %{_mandir}/man1/*
This page took 0.058159 seconds and 2 git commands to generate.