]> git.pld-linux.org Git - packages/bogl.git/blob - bogl.spec
- release 9 (by relup.sh)
[packages/bogl.git] / bogl.spec
1 # TODO
2 # - optflags
3 Summary:        A terminal program for displaying Unicode on the console
4 Summary(pl.UTF-8):      Program terminalowy do wyświetlania Unikodu na konsoli
5 Name:           bogl
6 Version:        0.1.18
7 Release:        9
8 Epoch:          0
9 License:        GPL
10 Group:          Libraries
11 Source0:        %{name}_%{version}-1.tar.gz
12 # Source0-md5:  9658700ed196eb1789c12aca0a095cb5
13 Source1:        wlite-0.8.1.tar.gz
14 # Source1-md5:  03a2faa33978e88ea2b9ff4679b8f2df
15 Source2:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts.tar.gz
16 # Source2-md5:  cca6a3cb6cfbde5f3ebb24278a9022a4
17 Source3:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts-asian.tar.gz
18 # Source3-md5:  d3184f182c6eebfcf156d08a65696496
19 Source4:        14x14cjk.bdf.gz
20 # Source4-md5:  c08ab351a43a91632127f509aadc6797
21 Patch0:         %{name}-0.1.18-rh.patch
22 Patch1:         %{name}-0.1.9-fpic.patch
23 Patch3:         %{name}-0.1.9-2.6fbdev.patch
24 Patch4:         %{name}-0.1.18-gcc.patch
25 Patch5:         %{name}-0.1.18-noexecstack.patch
26 Patch6:         %{name}-page_mask.patch
27 Patch7:         %{name}-shared.patch
28 URL:            http://www.stanford.edu/~blp/projects.html
29 BuildRequires:  gd-devel
30 BuildRequires:  libpng-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 BOGL stands for Ben's Own Graphics Library. It is a small graphics
35 library for Linux kernel framebuffers. It supports only very simple
36 graphics.
37
38 %description -l pl.UTF-8
39 BOGL oznacza Ben's Own Graphics Library (bibliotekę graficzną Bena).
40 Jest to mała biblioteka dla framebufferów jądra Linuksa. Obsługuje
41 tylko bardzo prostą grafikę.
42
43 %package devel
44 Summary:        Development files required to build BOGL applications
45 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do budowania aplikacji BOGL
46 Group:          Development/Libraries
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48
49 %description devel
50 The bogl-devel package contains the header files for writing BOGL
51 applications.
52
53 %description devel -l pl.UTF-8
54 Ten pakiet zawiera pliki nagłówkowe do pisania aplikacji BOGL.
55
56 %package static
57 Summary:        Static BOGL libraries
58 Summary(pl.UTF-8):      Statyczne biblioteki BOGL
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
61
62 %description static
63 Static BOGL libraries.
64
65 %description static -l pl.UTF-8
66 Statyczne biblioteki BOGL.
67
68 %package bterm
69 Summary:        A Unicode capable terminal program for the Linux framebuffer
70 Summary(pl.UTF-8):      Obsługujący Unikod program terminalowy dla linuksowego framebuffera
71 Group:          Applications/System
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73
74 %description bterm
75 The bterm application is a terminal emulator that displays to a Linux
76 framebuffer. It is able to display Unicode text on the console.
77
78 %description bterm -l pl.UTF-8
79 Aplikacja bterm to emulator terminala wyświetlający obraz na
80 linuksowym framebufferze. Potrafi wyświetlać tekst unikodowy na
81 konsoli.
82
83 %prep
84 %setup -q -n %{name} -a 1
85 %patch0 -p1
86 %patch1 -p1
87 %patch3 -p1
88 %patch4 -p1
89 %patch5 -p1
90 %patch6 -p1
91 %patch7 -p1
92
93 mkdir -p fonts
94 cd fonts
95 tar zxf %{SOURCE2}
96 tar zxf %{SOURCE3}
97
98 %build
99 %{__make} -j1 \
100         CFLAGS="%{rpmcflags} -fPIC"
101 #./mergebdf fonts/9x18.bdf fonts/18x18ja.bdf > font.bdf
102 gunzip -c %{SOURCE4} > font.bdf
103 ./bdftobogl -b font.bdf > font.bgf
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         libdir=%{_libdir}
111
112 %{__make} -C wlite install \
113         prefix=$RPM_BUILD_ROOT%{_prefix} \
114         libdir=$RPM_BUILD_ROOT%{_libdir}
115
116 if [ -f wlite/libwlitediet.a ]; then
117         install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT%{_libdir}
118 fi
119 install -d $RPM_BUILD_ROOT%{_libdir}/bogl
120 install font.bgf $RPM_BUILD_ROOT%{_libdir}/bogl
121 install font.bdf $RPM_BUILD_ROOT%{_libdir}/bogl
122 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bdf
123 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bgf
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc README
134 %attr(755,root,root) %{_libdir}/libbogl.so.*.*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/bdftobogl
139 %attr(755,root,root) %{_bindir}/mergebdf
140 %attr(755,root,root) %{_bindir}/pngtobogl
141 %attr(755,root,root) %{_bindir}/reduce-font
142 %attr(755,root,root) %{_libdir}/libbogl.so
143 %{_libdir}/libbterm.a
144 %{_libdir}/libwlite.a
145 %{_includedir}/bogl
146 %{_includedir}/wlite*.h
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libbogl.a
151
152 %files bterm
153 %defattr(644,root,root,755)
154 %doc README.BOGL-bterm
155 %attr(755,root,root) %{_bindir}/bterm
156 # XXX: dir duplicated with terminfo package
157 %dir %{_datadir}/terminfo/b
158 %{_datadir}/terminfo/b/bterm
159 %{_libdir}/bogl
This page took 0.129796 seconds and 4 git commands to generate.