]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
upstream fix for gas regression; rel 3
[packages/binutils.git] / binutils.spec
1 # TODO: PR/26302 <https://sourceware.org/bugzilla/show_bug.cgi?id=26302> (breaks kernel-tools build)
2 #
3 # Conditional build:
4 %bcond_with     allarchs        # enable all targets
5 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
6                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
7 %bcond_with     pax             # without PaX flags (for upstream bugreports)
8 %bcond_without  gold            # don't build gold (no C++ dependencies)
9 %bcond_without  default_bfd     # default ld.bfd instead of gold
10 %bcond_without  debuginfod      # debuginfo lokups with debuginfod
11 %bcond_with     gasp            # gasp
12 %bcond_without  gprofng         # gprofng
13 %bcond_without  jansson         # Package Metadata embedding support
14 %bcond_without  msgpack         # msgpack support
15 %bcond_with     tests           # check target
16
17 %ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
18 %undefine       with_gold
19 %endif
20 %ifarch %{arm}
21 %undefine       with_gasp
22 %endif
23 %ifnarch %{ix86} %{x8664} aarch64
24 %undefine       with_gprofng    1
25 %endif
26
27 Summary:        GNU Binary Utility Development Utilities
28 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
29 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
30 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
31 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
32 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
33 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
34 Summary(tr.UTF-8):      GNU geliştirme araçları
35 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
36 Name:           binutils
37 Version:        2.39
38 Release:        3
39 Epoch:          4
40 License:        GPL v3+
41 Group:          Development/Tools
42 Source0:        https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
43 # Source0-md5:  061a1460a09cc71e51886c008be55d44
44 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
46 Patch0:         %{name}-gasp.patch
47 Patch1:         %{name}-info.patch
48 Patch2:         %{name}-libtool-relink.patch
49 Patch3:         %{name}-pt_pax_flags.patch
50
51 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
52 Patch7:         %{name}-libtool-m.patch
53 Patch9:         %{name}-tooldir.patch
54 Patch10:        %{name}-sanity-check.patch
55 Patch11:        pr29451.patch
56 URL:            http://www.sourceware.org/binutils/
57 BuildRequires:  autoconf >= 2.69
58 BuildRequires:  automake >= 1:1.11
59 BuildRequires:  bison
60 %{?with_debuginfod:BuildRequires:       elfutils-debuginfod-devel >= 0.179}
61 BuildRequires:  flex
62 BuildRequires:  gettext-tools
63 %{?with_jansson:BuildRequires:  jansson-devel}
64 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
65 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
66 BuildRequires:  lzip
67 %{?with_msgpack:BuildRequires:  msgpack-devel}
68 BuildRequires:  perl-tools-pod
69 BuildRequires:  pkgconfig
70 BuildRequires:  rpmbuild(macros) >= 1.527
71 %ifarch sparc sparc32
72 BuildRequires:  sparc32
73 %endif
74 BuildRequires:  tar >= 1:1.22
75 BuildRequires:  texinfo >= 4.2
76 BuildRequires:  zlib-devel
77 %{?with_tests:BuildRequires:    zlib-static}
78 %{?with_debuginfod:Requires:    elfutils-debuginfod-libs >= 0.179}
79 Conflicts:      gcc-c++ < 5:3.3
80 Conflicts:      modutils < 2.4.17
81 Conflicts:      rpmbuild(macros) < 1.660
82 Obsoletes:      binutils-gold
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %description
86 Binutils is a collection of binary utilities, including:
87 - ar - create, modify and extract from archives,
88 - nm - lists symbols from object files,
89 - objcopy - copy and translate object files,
90 - objdump - display information from object files,
91 - ranlib - generate an index for the contents of an archive,
92 - size - list the section sizes of an object or archive file,
93 - strings - list printable strings from files,
94 - strip - discard symbols,
95 - addr2line - convert addresses to file and line.
96
97 %description -l es.UTF-8
98 Binutils es una colección de utilitarios necesarios para compilar
99 programas. Incluye assembler y linker, así como varios otros programas
100 para trabajar con formatos que se puedan ejecutar.
101
102 %description -l pl.UTF-8
103 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
104 programów. Znajdują się tutaj między innymi assembler, konsolidator
105 (linker), a także inne narzędzia do manipulowania binarnymi plikami
106 programów i bibliotek.
107
108 %description -l pt_BR.UTF-8
109 binutils é uma coletânea de utilitários necessários para compilar
110 programas. Inclui assembler e linker, assim como vários outros
111 programas para trabalhar com formatos executáveis.
112
113 %description -l ru.UTF-8
114 binutils - это набор инструментов, необходимых для компилляции
115 программ. Включает ассемблер, компоновщик и набор других программ для
116 работы с исполняемыми файлами разнообразных форматов.
117
118 %description -l uk.UTF-8
119 binutils - це набір інструментів, необхідних для компіляції програм.
120 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
121 виконуваними файлами різних форматів.
122
123 %package libs
124 Summary:        GNU binutils shared libraries
125 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
126 Group:          Libraries
127 Conflicts:      binutils < 3:2.17.50.0.8-3
128
129 %description libs
130 GNU binutils shared libraries (libbfd, libopcodes).
131
132 %description libs -l pl.UTF-8
133 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
134
135 %package devel
136 Summary:        Development files for GNU binutils libraries
137 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
138 Group:          Development/Libraries
139 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
140
141 %description devel
142 Development files for GNU binutils libraries (libbfd, libopcodes) and
143 static libiberty library.
144
145 %description devel -l pl.UTF-8
146 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
147 statyczna biblioteka libiberty.
148
149 %package static
150 Summary:        GNU binutils static libraries
151 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
154 #Requires:      zlib-static
155
156 %description static
157 Static GNU binutils libraries (libbfd, libopcodes).
158
159 %description static -l pl.UTF-8
160 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
161
162 %package gasp
163 Summary:        GASP - old preprocessor for assembly programs
164 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
165 Group:          Development/Tools
166 Requires:       %{name} = %{epoch}:%{version}-%{release}
167
168 %description gasp
169 GASP - old preprocessor for assembly programs. It's officially
170 obsoleted, but it's still needed to build some packages.
171
172 %description gasp -l pl.UTF-8
173 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
174 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
175 niektórych pakietów.
176
177 %prep
178 %setup -q
179 %{?with_gasp:%patch0 -p1}
180 %patch1 -p1
181 %patch2 -p1
182 %{?with_pax:%patch3 -p1}
183
184 %patch6 -p1
185 %patch7 -p1
186 %patch9 -p1
187 %patch10 -p1
188 %patch11 -p1
189
190 %{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
191
192 # file contains hacks for ac 2.69 only
193 %{__rm} config/override.m4
194
195 %build
196 %{__aclocal}
197 %{__autoconf}
198
199 # non-standard regeneration (needed because of gasp patch)
200 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
201 for dir in gas bfd; do
202         cd $dir || exit 1
203         %{__aclocal} -I .. -I ../config -I ../bfd
204         %{__automake} Makefile
205         test -f doc/Makefile.am && %{__automake} doc/Makefile
206         %{__autoconf}
207         cd ..
208 done
209
210 # More targets
211 TARGETS=
212 %ifarch ia64
213 TARGETS=i686-linux
214 %endif
215 # uhm?
216 %ifarch %{ix86}
217 TARGETS=x86_64-linux
218 %endif
219 %ifarch sparc
220 TARGETS=sparc64-linux
221 %endif
222 %ifarch %{x8664}
223 TARGETS="x86_64-pep"
224 %endif
225 %ifarch x32
226 TARGETS="x86_64-linux,x86_64-pep"
227 %endif
228 %{?addtargets:TARGETS="%{addtargets}"}
229
230 cp -f /usr/share/automake/config.* .
231 CFLAGS="%{rpmcflags}"; export CFLAGS
232 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
233 CC="%{__cc}"; export CC
234 CXX="%{__cxx}"; export CXX
235 %ifarch sparc
236 sparc32 \
237 %endif
238 ./configure %{_target_platform} \
239         --prefix=%{_prefix} \
240         --libdir=%{_libdir} \
241         --infodir=%{_infodir} \
242         --mandir=%{_mandir} \
243         --sysconfdir=%{_sysconfdir} \
244         --disable-debug \
245         --disable-silent-rules \
246         --disable-werror \
247 %ifarch sparc
248         --enable-64-bit-bfd \
249 %else
250         %{?with_allarchs:--enable-64-bit-bfd} \
251 %endif
252         --enable-build-warnings=,-Wno-missing-prototypes \
253         --enable-install-libiberty \
254         --enable-lto \
255         --enable-plugins \
256         --enable-shared \
257         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
258         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
259         --with-tooldir=%{_prefix} \
260         --with-zlib \
261 %if %{with gold}
262         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
263 %endif
264         %{__enable_disable msgpack} \
265         %{__enable_disable jansson} \
266         %{__with_without debuginfod}
267
268 %{__make}
269
270 %{?with_tests:%{__make} -j1 check}
271
272 %install
273 rm -rf $RPM_BUILD_ROOT
274 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
275
276 %{__make} -j1 install \
277         DESTDIR=$RPM_BUILD_ROOT
278
279 # remove these man pages unless we cross-build for win*/netware platforms.
280 # however, this should be done in Makefiles.
281 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
282
283 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
284
285 # overwrite libiberty.a with PIC version
286 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
287
288 # remove evil -L pointing inside builder's home
289 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
290
291 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
292
293 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
294
295 %if %{with gold}
296 install -d gold-doc
297 cp -p gold/{README,ChangeLog,TODO} gold-doc
298 %endif
299
300 %find_lang bfd
301 %find_lang binutils
302 %find_lang gas
303 %find_lang gprof
304 touch ld.lang gold.lang
305 %find_lang ld
306 %if %{with gold}
307 %find_lang gold
308 %endif
309 %find_lang opcodes
310 cat bfd.lang opcodes.lang > %{name}-libs.lang
311 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
312
313 %clean
314 rm -rf $RPM_BUILD_ROOT
315
316 %post   -p /sbin/postshell
317 -/usr/sbin/fix-info-dir -c %{_infodir}
318
319 %postun -p /sbin/postshell
320 -/usr/sbin/fix-info-dir -c %{_infodir}
321
322 %post   libs -p /sbin/ldconfig
323 %postun libs -p /sbin/ldconfig
324
325 %post   devel -p /sbin/postshell
326 -/usr/sbin/fix-info-dir -c %{_infodir}
327
328 %postun devel -p /sbin/postshell
329 -/usr/sbin/fix-info-dir -c %{_infodir}
330
331 %post   gasp -p /sbin/postshell
332 -/usr/sbin/fix-info-dir -c %{_infodir}
333
334 %postun gasp -p /sbin/postshell
335 -/usr/sbin/fix-info-dir -c %{_infodir}
336
337 %files -f %{name}.lang
338 %defattr(644,root,root,755)
339 %doc README
340 %{?with_gold:%doc gold-doc}
341 %{?with_gprofng:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gprofng.rc}
342 %attr(755,root,root) %{_bindir}/addr2line
343 %attr(755,root,root) %{_bindir}/ar
344 %attr(755,root,root) %{_bindir}/as
345 %attr(755,root,root) %{_bindir}/c++filt
346 %attr(755,root,root) %{_bindir}/elfedit
347 %if %{with gprofng}
348 %attr(755,root,root) %{_bindir}/gp-archive
349 %attr(755,root,root) %{_bindir}/gp-collect-app
350 %attr(755,root,root) %{_bindir}/gp-display-html
351 %attr(755,root,root) %{_bindir}/gp-display-src
352 %attr(755,root,root) %{_bindir}/gp-display-text
353 %attr(755,root,root) %{_bindir}/gprofng
354 %endif
355 %attr(755,root,root) %{_bindir}/gprof
356 %attr(755,root,root) %{_bindir}/ld
357 %attr(755,root,root) %{_bindir}/ld.bfd
358 %if %{with gold}
359 %attr(755,root,root) %{_bindir}/ld.gold
360 %attr(755,root,root) %{_bindir}/dwp
361 %endif
362 %attr(755,root,root) %{_bindir}/nm
363 %attr(755,root,root) %{_bindir}/objcopy
364 %attr(755,root,root) %{_bindir}/objdump
365 %attr(755,root,root) %{_bindir}/ranlib
366 %attr(755,root,root) %{_bindir}/readelf
367 %attr(755,root,root) %{_bindir}/size
368 %attr(755,root,root) %{_bindir}/strings
369 %attr(755,root,root) %{_bindir}/strip
370 %if %{with gprofng}
371 %dir %{_libdir}/gprofng
372 %attr(755,root,root) %{_libdir}/gprofng/libgp-collector.so
373 %attr(755,root,root) %{_libdir}/gprofng/libgp-collectorAPI.so
374 %attr(755,root,root) %{_libdir}/gprofng/libgp-heap.so
375 %attr(755,root,root) %{_libdir}/gprofng/libgp-iotrace.so
376 %attr(755,root,root) %{_libdir}/gprofng/libgp-sync.so
377 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.*.*.*
378 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.0
379 %endif
380 %{_prefix}/lib/ldscripts
381 %{_infodir}/as.info*
382 %{_infodir}/binutils.info*
383 %{_infodir}/ctf-spec.info*
384 %{_infodir}/gprof.info*
385 %{?with_gprofng:%{_infodir}/gprofng.info*}
386 %{_infodir}/ld.info*
387 %{_mandir}/man1/addr2line.1*
388 %{_mandir}/man1/ar.1*
389 %{_mandir}/man1/as.1*
390 %{_mandir}/man1/c++filt.1*
391 %{_mandir}/man1/elfedit.1*
392 %if %{with gprofng}
393 %{_mandir}/man1/gp-archive.*
394 %{_mandir}/man1/gp-collect-app.*
395 %{_mandir}/man1/gp-display-html.*
396 %{_mandir}/man1/gp-display-src.*
397 %{_mandir}/man1/gp-display-text.*
398 %{_mandir}/man1/gprofng.1*
399 %endif
400 %{_mandir}/man1/gprof.1*
401 %{_mandir}/man1/ld.1*
402 %{_mandir}/man1/nm.1*
403 %{_mandir}/man1/objcopy.1*
404 %{_mandir}/man1/objdump.1*
405 %{_mandir}/man1/ranlib.1*
406 %{_mandir}/man1/readelf.1*
407 %{_mandir}/man1/size.1*
408 %{_mandir}/man1/strings.1*
409 %{_mandir}/man1/strip.1*
410 %lang(cs) %{_mandir}/cs/man1/*
411 %lang(de) %{_mandir}/de/man1/*
412 %lang(es) %{_mandir}/es/man1/*
413 %lang(fi) %{_mandir}/fi/man1/*
414 %lang(fr) %{_mandir}/fr/man1/*
415 %lang(hu) %{_mandir}/hu/man1/*
416 %lang(ja) %{_mandir}/ja/man1/*
417 %lang(pl) %{_mandir}/pl/man1/*
418
419 %files libs -f %{name}-libs.lang
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
422 %attr(755,root,root) %{_libdir}/libctf.so.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libctf.so.0
424 %attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
425 %attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
426 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
427 %dir %{_libdir}/bfd-plugins
428 %attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
429
430 %files devel
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/libbfd.so
433 %attr(755,root,root) %{_libdir}/libctf.so
434 %attr(755,root,root) %{_libdir}/libctf-nobfd.so
435 %attr(755,root,root) %{_libdir}/libopcodes.so
436 %{?with_gprofng:%attr(755,root,root) %{_libdir}/gprofng/libgprofng.so}
437 %{_libdir}/libbfd.la
438 %{_libdir}/libctf.la
439 %{_libdir}/libctf-nobfd.la
440 %{_libdir}/libopcodes.la
441 %{_libdir}/libiberty.a
442 %{_includedir}/ansidecl.h
443 %{_includedir}/bfd.h
444 %{_includedir}/bfdlink.h
445 %{_includedir}/ctf-api.h
446 %{_includedir}/ctf.h
447 %{_includedir}/diagnostics.h
448 %{_includedir}/dis-asm.h
449 %{_includedir}/plugin-api.h
450 %{_includedir}/symcat.h
451 %{_includedir}/libiberty
452 %if %{with gprofng}
453 %{_includedir}/collectorAPI.h
454 %{_includedir}/libcollector.h
455 %{_includedir}/libfcollector.h
456 %endif
457 %{_infodir}/bfd.info*
458
459 %files static
460 %defattr(644,root,root,755)
461 %{_libdir}/libbfd.a
462 %{_libdir}/libctf.a
463 %{_libdir}/libctf-nobfd.a
464 %{_libdir}/libopcodes.a
465
466 %if %{with gasp}
467 %files gasp
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_bindir}/gasp
470 %{_infodir}/gasp.info*
471 %endif
This page took 0.856915 seconds and 3 git commands to generate.