]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
82d5d41f914c46032db771e00d7310eef3c655cc
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     hip             # build with HIP RR support
13 %if "%{pld_release}" == "ac"
14 %bcond_with             epoll           # enable epoll support
15 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
16 %ifarch %{x8664}
17 %define         with_epoll      1
18 %endif
19 %else
20 %bcond_without  epoll           # disable epoll support
21 %endif
22
23 %define         ver     9.8.5
24 %if 1
25 %define         pverdot .P2
26 %define         pverdir -P2
27 %else
28 %define         pverdot %{nil}
29 %define         pverdir %{nil}
30 %endif
31 Summary:        BIND - DNS name server
32 Summary(de.UTF-8):      BIND - DNS-Namenserver
33 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
34 Summary(fr.UTF-8):      BIND - serveur de noms DNS
35 Summary(pl.UTF-8):      BIND - serwer nazw DNS
36 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
37 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
38 Summary(tr.UTF-8):      DNS alan adı sunucusu
39 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
40 Summary(zh_CN.UTF-8):   Internet 域名服务器
41 Name:           bind
42 Version:        %{ver}%{pverdot}
43 Release:        1
44 Epoch:          7
45 License:        BSD-like
46 Group:          Networking/Daemons
47 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
48 # Source0-md5:  e168c691d35ae0d40fd0c21aa695b181
49 Source1:        named.init
50 Source2:        named.sysconfig
51 Source3:        named.logrotate
52 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
53 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
54 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
55 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
56 Source6:        %{name}-hip.tar.gz
57 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
58 Source7:        ftp://rs.internic.net/domain/named.root
59 # Source7-md5:  013336e29e65923682f7bce094bb3e5c
60 Source8:        %{name}-127.0.0.zone
61 Source9:        %{name}-localhost.zone
62 Source10:       %{name}-named.conf
63 Patch0:         %{name}-time.patch
64 Patch1:         %{name}-link.patch
65 Patch2:         %{name}-pmake.patch
66 Patch3:         %{name}-sdb-ldap.patch
67 URL:            https://www.isc.org/software/bind
68 BuildRequires:  autoconf
69 BuildRequires:  automake
70 BuildRequires:  bison
71 BuildRequires:  flex
72 %{?with_kerberos5:BuildRequires:        heimdal-devel}
73 BuildRequires:  idnkit-devel
74 BuildRequires:  libtool
75 %{?with_hip:BuildRequires:      libxml2-devel}
76 %{?with_sql:BuildRequires:      mysql-devel}
77 %{?with_ldap:BuildRequires:     openldap-devel}
78 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
79 %{?with_sql:BuildRequires:      postgresql-devel}
80 BuildRequires:  rpm >= 4.4.9-56
81 BuildRequires:  rpmbuild(macros) >= 1.583
82 %{?with_sql:BuildRequires:      unixODBC-devel}
83 Requires(post,preun):   /sbin/chkconfig
84 Requires(postun):       /usr/sbin/groupdel
85 Requires(postun):       /usr/sbin/userdel
86 Requires(pre):  /bin/id
87 Requires(pre):  /usr/bin/getgid
88 Requires(pre):  /usr/sbin/groupadd
89 Requires(pre):  /usr/sbin/useradd
90 Requires(pre):  fileutils
91 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
92 Requires:       psmisc >= 20.1
93 Requires:       rc-scripts >= 0.2.0
94 Requires:       uname(release) >= 2.2.18
95 Provides:       group(named)
96 Provides:       nameserver
97 Provides:       user(named)
98 Obsoletes:      caching-nameserver
99 Conflicts:      %{name}-chroot
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         schemadir       /usr/share/openldap/schema
103 # undefined sym: krb5_get_default_realm
104 %define         skip_post_check_so      libdns.so.122.0.1
105
106 %description
107 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
108 (Domain Name System) protocols. BIND includes a DNS server (named),
109 which resolves host names to IP addresses, and a resolver library
110 (routines for applications to use when interfacing with DNS). A DNS
111 server allows clients to name resources or objects and share the
112 information with other network machines. The named DNS server can be
113 used on workstations as a caching name server, but is generally only
114 needed on one machine for an entire network. Note that the
115 configuration files for making BIND act as a simple caching nameserver
116 are included in the caching-nameserver package.
117
118 Install the bind package if you need a DNS server for your network. If
119 you want bind to act a caching name server, you will also need to
120 install the caching-nameserver package.
121
122 %description -l de.UTF-8
123 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
124 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
125 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
126 Recher des Netzwerks erforderlich.
127
128 %description -l es.UTF-8
129 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
130 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
131 un servidor de nombres caché, pero generalmente sólo hace falta en una
132 máquina para toda la red.
133
134 %description -l fr.UTF-8
135 Contient le serveur de noms named, utilisé pour définir les
136 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
137 utilisé sur les stations de travail comme serveur de nom en cache mais
138 n'est souvent nécessaire que sur une machine pour un réseau entier.
139
140 %description -l pl.UTF-8
141 Pakiet ten zawiera demona named, który służy do zmieniania nazw
142 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
143 roboczych jako bufor odwołań do serwisu nazw (caching name server),
144 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
145 program na fragment sieci.
146
147 %description -l pt_BR.UTF-8
148 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
149 IP (e vice-versa). Pode ser usado em estações de trabalho como um
150 servidor de nomes cache, mas geralmente só é necessário em uma máquina
151 para toda a rede.
152
153 %description -l ru.UTF-8
154 BIND (Berkeley Internet Name Domain) является реализацией протоколов
155 DNS (Domain Name System). BIND включает DNS сервер (named) и
156 библиотеку "резолвера" (подпрограммы для приложений, через которые
157 происходят обращения к DNS). DNS сервер named может быть использован
158 на рабочих станциях как кеширующий сервер, но обычно запускается на
159 одной машине в локальной сети и используется остальными машинами (этим
160 достигается намного более эффективное кеширование).
161
162 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
163 кеширующего сервера, включены в пакет caching-nameserver.
164
165 %description -l tr.UTF-8
166 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
167 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
168 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
169 için sadece bir makina üzerinde kurulur.
170
171 %description -l uk.UTF-8
172 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
173 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
174 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
175 сервер named може бути використаний на робочих станціях як кешируючий
176 сервер, але звичайно запускається на одній машині в локальній мережі і
177 використовується іншими (цим досягається більша ефективність
178 використання кешу).
179
180 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
181 кешируючого серверу, включені в пакет caching-nameserver.
182
183 %package utils
184 Summary:        DNS utils - host, dig, dnsquery, nslookup
185 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
186 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
187 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
188 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
189 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
190 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
191 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
192 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
193 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
194 Group:          Networking/Utilities
195 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
196 Requires:       iconv
197
198 %description utils
199 Bind-utils contains a collection of utilities for querying DNS (Domain
200 Name Service) name servers to find out information about Internet
201 hosts. These tools will provide you with the IP addresses for given
202 host names, as well as other information about registered domains and
203 network addresses.
204
205 You should install bind-utils if you need to get information from DNS
206 name servers.
207
208 %description utils -l de.UTF-8
209 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
210 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
211 Informationen über registrierte Domains und Netzwerk-Adressen.
212
213 %description utils -l es.UTF-8
214 Conjunto de utilitarios para consulta a servidores de nombres. Estas
215 herramientas permiten la determinación de direcciones IP para nombres
216 de máquinas informados y busca información sobre dominios registrados
217 y direcciones de red.
218
219 %description utils -l fr.UTF-8
220 Ensemble d'utilitaires pour interroger les serveurs de noms et
221 rechercher des hôtes. Ces outils vous permettent de déterminer les
222 adresses IP pour des noms d'hôtes donnés, et trouver des informations
223 sur les noms de domaine déclarés et les adresses réseau.
224
225 %description utils -l pl.UTF-8
226 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
227 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
228 i ich adresach IP.
229
230 %description utils -l pt_BR.UTF-8
231 Conjunto de utilitários para consulta a servidores DNS. Estas
232 ferramentas permitem a determinação de endereços IP para nomes de
233 máquinas informados e busca informações sobre domínios registrados e
234 endereços de rede. Você deveria instalar este pacote se necessitar
235 obter informações de servidores DNS.
236
237 %description utils -l ru.UTF-8
238 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
239 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
240 доменному имени (и наоборот) и другую информацию о зарегистрированных
241 доменах и сетевых адресах.
242
243 %description utils -l tr.UTF-8
244 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
245 için kullanılan araçlar bulunmaktadır.
246
247 %description utils -l uk.UTF-8
248 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
249 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
250 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
251 домени та адреси.
252
253 %package libs
254 Summary:        DNS libraries
255 Summary(pl.UTF-8):      Biblioteki DNS
256 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
257 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
258 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
259 Group:          Libraries
260
261 %description libs
262 The bind-libs package contains all libraries required for running BIND
263 and bind utils.
264
265 %description libs -l pl.UTF-8
266 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
267 lub programów z pakietu bind-utils.
268
269 %description libs -l ru.UTF-8
270 Библиотеки, необходимые для работы bind.
271
272 %description libs -l uk.UTF-8
273 Бібліотеки, необхідні для роботи bind.
274
275 %package devel
276 Summary:        DNS development includes
277 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
278 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
279 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
280 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
281 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
282 Group:          Development/Libraries
283 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
284
285 %description devel
286 The bind-devel package contains all the include files and symlinks
287 required for DNS (Domain Name Service) development for BIND.
288
289 You should install bind-devel if you want to develop bind DNS
290 applications. If you install bind-devel, you'll also need to install
291 bind-libs.
292
293 %description devel -l es.UTF-8
294 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
295 para el bind.
296
297 %description devel -l pl.UTF-8
298 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
299 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
300 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
301 pakiet.
302
303 %description devel -l pt_BR.UTF-8
304 Todos os arquivos de cabeçalho e bibliotecas necessários para o
305 desenvolvimento com o bind.
306
307 %description devel -l ru.UTF-8
308 Все хедеры и библиотеки, необходимые для написания программ с
309 использованием BIND 9.x.x.
310
311 %description devel -l uk.UTF-8
312 Всі хедери та бібліотеки, необхідні для розробки програм з
313 використанням BIND 9.x.x.
314
315 %package static
316 Summary:        DNS static libs
317 Summary(pl.UTF-8):      Biblioteki statyczne DNS
318 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
319 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
320 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
321 Group:          Development/Libraries
322 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
323
324 %description static
325 Static bind libraries.
326
327 %description static -l pl.UTF-8
328 Statyczne biblioteki binda.
329
330 %description static -l pt_BR.UTF-8
331 Bibliotecas estáticas para desenvolvimento DNS.
332
333 %description static -l ru.UTF-8
334 Статические библиотеки, необходимые для написания программ с
335 использованием BIND.
336
337 %description static -l uk.UTF-8
338 Статичні бібліотеки, необхідні для розробки програм з використанням
339 BIND.
340
341 %package -n openldap-schema-bind
342 Summary:        BIND schema for openldap
343 Summary(pl.UTF-8):      Schemat BIND dla openldap
344 Group:          Development/Libraries
345 Requires(post,postun):  sed >= 4.0
346 Requires:       openldap-servers
347 Requires:       sed >= 4.0
348
349 %description -n openldap-schema-bind
350 BIND schema for openldap.
351
352 %description -n openldap-schema-bind -l pl.UTF-8
353 Schemat BIND dla openldap.
354
355 %prep
356 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
357 %patch0 -p1
358 %patch1 -p1
359 %patch2 -p1
360 %{?with_ldap:%patch3 -p1}
361 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
362
363
364 %build
365 %{__libtoolize}
366 %{__aclocal}
367 %{__autoconf}
368 cp -f /usr/share/automake/config.* .
369 %configure \
370         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
371         --with-idn \
372         --with-libtool \
373         %{?with_ssl:--with-openssl=%{_prefix}} \
374         %{?with_ipv6:--enable-ipv6} \
375         %{?with_kerberos5:--with-gssapi} \
376         %{?with_sql:--with-dlz-postgres=yes} \
377         %{?with_sql:--with-dlz-mysql=yes} \
378         --with-dlz-bdb=no \
379         --with-dlz-filesystem=yes \
380         %{?with_ldap:--with-dlz-ldap=yes} \
381         --with-dlz-odbc=no \
382         --with-dlz-stub=yes \
383         --enable-largefile \
384         %{!?with_epoll:--disable-epoll --disable-devpoll} \
385         %{!?with_static_libs:--enable-static=no} \
386         --enable-threads \
387         --enable-getifaddrs
388
389 %{__make}
390 %{?with_hip:cd bind-hip/; %{__make}}
391
392 %{?with_tests:%{__make} test}
393
394 %install
395 rm -rf $RPM_BUILD_ROOT
396 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
397         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
398         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}}
399
400 %{__make} install \
401         DESTDIR=$RPM_BUILD_ROOT
402
403 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
404 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
405 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
406
407 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
408 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
409 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
410 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
411 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
412 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
413 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
414 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
415 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
416 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
417
418 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
419 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
420 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
421 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
422
423 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
424
425 %if %{with ldap}
426 install -d $RPM_BUILD_ROOT%{schemadir}
427 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
428 %endif
429
430 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
431
432 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
433 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
434
435 # let rpm generate deps (workaround -m644 used for libs installation)
436 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
437
438 # we don't want Makefiles in documentation...
439 rm -rf _doc
440 cp -a doc _doc
441 rm -f _doc/rfc/rfc*
442 rm -f _doc/misc/Makefile*
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %pre
448 if [ -f %{_sysconfdir}/named.boot ]; then
449         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
450         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
451         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
452 fi
453 %groupadd -g 58 named
454 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
455
456 %post
457 /sbin/chkconfig --add named
458 %service named restart
459
460 %preun
461 if [ "$1" = "0" ]; then
462         %service named stop
463         /sbin/chkconfig --del named
464 fi
465
466 %postun
467 if [ "$1" = "0" ]; then
468         %userremove named
469         %groupremove named
470 fi
471
472 %post   libs -p /sbin/ldconfig
473 %postun libs -p /sbin/ldconfig
474
475 %post -n openldap-schema-bind
476 %openldap_schema_register %{schemadir}/dnszone.schema
477 %service -q ldap restart
478
479 %postun -n openldap-schema-bind
480 if [ "$1" = "0" ]; then
481         %openldap_schema_unregister %{schemadir}/dnszone.schema
482         %service -q ldap restart
483 fi
484
485 %triggerpostun -- %{name} < 7:9.4.2-2
486 /sbin/chkconfig named reset
487 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
488 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
489 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
490
491 %files
492 %defattr(644,root,root,755)
493 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
494 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
495
496 %attr(754,root,root) /etc/rc.d/init.d/named
497 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
498 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
499 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
500 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
501
502 %attr(755,root,root) %{_sbindir}/arpaname
503 %attr(755,root,root) %{_sbindir}/ddns-confgen
504 %attr(755,root,root) %{_sbindir}/dnssec-*
505 %attr(755,root,root) %{_sbindir}/genrandom
506 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
507 %attr(755,root,root) %{_sbindir}/lwresd
508 %attr(755,root,root) %{_sbindir}/named
509 %attr(755,root,root) %{_sbindir}/named-*
510 %attr(755,root,root) %{_sbindir}/nsec3hash
511 %attr(755,root,root) %{_sbindir}/rndc
512 %attr(755,root,root) %{_sbindir}/rndc-confgen
513
514 %{_mandir}/man1/arpaname.1*
515 %{_mandir}/man5/named.conf.5*
516 %{_mandir}/man5/rndc.conf.5*
517 %{_mandir}/man8/ddns-confgen.8*
518 %{_mandir}/man8/dnssec-*.8*
519 %{_mandir}/man8/genrandom.8*
520 %{_mandir}/man8/isc-hmac-fixup.8*
521 %{_mandir}/man8/lwresd.8*
522 %{_mandir}/man8/named.8*
523 %{_mandir}/man8/named-*.8*
524 %{_mandir}/man8/nsec3hash.8*
525 %{_mandir}/man8/rndc.8*
526 %{_mandir}/man8/rndc-confgen.8*
527 %lang(ja) %{_mandir}/ja/man8/named*
528
529 %attr(770,root,named) %dir %{_var}/lib/named
530 %attr(770,root,named) %dir %{_var}/lib/named/D
531 %attr(750,root,named) %dir %{_var}/lib/named/M
532 %attr(770,root,named) %dir %{_var}/lib/named/S
533 %attr(750,root,named) %dir %{_var}/lib/named/etc
534 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
535 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
536 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
537 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
538 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
539 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
540
541 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
542 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
543
544 %attr(770,root,named) %dir %{_var}/run/named
545 %attr(770,root,named) %dir %{_var}/run/lwresd
546
547 %files utils
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/dig
550 %attr(755,root,root) %{_bindir}/host
551 %attr(755,root,root) %{_bindir}/nslookup
552 %attr(755,root,root) %{_bindir}/nsupdate
553 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
554 %{_mandir}/man1/dig.1*
555 %{_mandir}/man1/host.1*
556 %{_mandir}/man1/nslookup.1*
557 %{_mandir}/man1/nsupdate.1*
558
559 %lang(fi) %{_mandir}/fi/man1/host.1*
560
561 %lang(fr) %{_mandir}/fr/man1/host.1*
562
563 %lang(hu) %{_mandir}/hu/man1/host.1*
564
565 %lang(ja) %{_mandir}/ja/man1/dig.1*
566 %lang(ja) %{_mandir}/ja/man1/host.1*
567 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
568 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
569
570 %lang(pl) %{_mandir}/pl/man1/host.1*
571
572 %files libs
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.80
576 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libdns.so.122
578 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libisc.so.84
580 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.80
582 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.82
584 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.80
586
587 %files devel
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/isc-config.sh
590 %attr(755,root,root) %{_libdir}/libbind9.so
591 %attr(755,root,root) %{_libdir}/libdns.so
592 %attr(755,root,root) %{_libdir}/libisc.so
593 %attr(755,root,root) %{_libdir}/libisccc.so
594 %attr(755,root,root) %{_libdir}/libisccfg.so
595 %attr(755,root,root) %{_libdir}/liblwres.so
596 %{_libdir}/libbind9.la
597 %{_libdir}/libdns.la
598 %{_libdir}/libisc.la
599 %{_libdir}/libisccc.la
600 %{_libdir}/libisccfg.la
601 %{_libdir}/liblwres.la
602 %{_includedir}/bind9
603 %{_includedir}/dns
604 %{_includedir}/dst
605 %{_includedir}/isc
606 %{_includedir}/isccc
607 %{_includedir}/isccfg
608 %{_includedir}/lwres
609 %{_mandir}/man1/isc-config.sh.1*
610 %{_mandir}/man3/lwres*.3*
611
612 %if %{with static_libs}
613 %files static
614 %defattr(644,root,root,755)
615 %{_libdir}/libbind9.a
616 %{_libdir}/libdns.a
617 %{_libdir}/libisc.a
618 %{_libdir}/libisccc.a
619 %{_libdir}/libisccfg.a
620 %{_libdir}/liblwres.a
621 %endif
622
623 %if %{with ldap}
624 %files -n openldap-schema-bind
625 %defattr(644,root,root,755)
626 %{_datadir}/openldap/schema/dnszone.schema
627 %endif
This page took 0.084445 seconds and 2 git commands to generate.