]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
6b9bb3eae4d0d47a7e3cb4e644b48ee9ab603af4
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_with     ldap            # LDAP DLZ support
10 %bcond_with     odbc            # ODBC DLZ support
11 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
12 %bcond_without  lmdb            # LMDB storage support for addzone zones
13 %bcond_without  static_libs     # static libraries
14 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
15 %bcond_with     tests           # unit tests
16 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
17 %bcond_with     hip             # HIP RR support
18
19 %if "%{pld_release}" == "ac"
20 %bcond_with     epoll           # enable epoll support
21 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
22 %ifarch %{x8664}
23 %define         with_epoll      1
24 %endif
25 %else
26 %bcond_without  epoll           # disable epoll support
27 %endif
28
29 %define         ver     9.16.0
30 %if 0
31 %define         pverdot .P0
32 %define         pverdir -P0
33 %else
34 %define         pverdot %{nil}
35 %define         pverdir %{nil}
36 %endif
37 Summary:        BIND - DNS name server
38 Summary(de.UTF-8):      BIND - DNS-Namenserver
39 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
40 Summary(fr.UTF-8):      BIND - serveur de noms DNS
41 Summary(pl.UTF-8):      BIND - serwer nazw DNS
42 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
43 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
44 Summary(tr.UTF-8):      DNS alan adı sunucusu
45 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
46 Summary(zh_CN.UTF-8):   Internet 域名服务器
47 Name:           bind
48 Version:        %{ver}%{pverdot}
49 Release:        1
50 Epoch:          7
51 License:        MPL 2.0
52 Group:          Networking/Daemons
53 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
54 # Source0-md5:  f973848bf32797c5f546de7d92a6fd07
55 Source1:        named.init
56 Source2:        named.sysconfig
57 Source3:        named.logrotate
58 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
59 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
60 # formerly http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt (dead URL now)
61 Source5:        dnszone-schema.txt
62 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
63 Source6:        %{name}-hip.tar.gz
64 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
65 Source7:        https://www.internic.net/domain/named.root
66 # Source7-md5:  7cee6519fca7a4a6e771633560e55d53
67 Source8:        %{name}-127.0.0.zone
68 Source9:        %{name}-localhost.zone
69 Source10:       %{name}-named.conf
70 Source11:       %{name}.tmpfiles
71 Source12:       named.service
72 Patch0:         %{name}-time.patch
73 Patch1:         %{name}-link.patch
74 Patch2:         %{name}-pmake.patch
75 Patch3:         %{name}-sdb-ldap.patch
76 Patch4:         %{name}-ac-libs.patch
77 Patch5:         %{name}-edns-client-subnet.patch
78 Patch6:         nsupdate_segfault.patch
79 URL:            https://www.isc.org/software/bind
80 BuildRequires:  autoconf >= 2.60
81 BuildRequires:  automake
82 BuildRequires:  bison
83 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
84 BuildRequires:  flex
85 %{?with_kerberos5:BuildRequires:        heimdal-devel}
86 BuildRequires:  json-c-devel >= 0.11
87 BuildRequires:  libcap-devel
88 BuildRequires:  libidn2-devel
89 # note, there is no kyua in PLD yet (work in progress)
90 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
91 BuildRequires:  libtool
92 BuildRequires:  libuv-devel >= 1.0.0
93 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
94 BuildRequires:  libxml2-devel >= 1:2.6.0
95 %{?with_lmdb:BuildRequires:     lmdb-devel}
96 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
97 %{?with_sql:BuildRequires:      mysql-devel}
98 %{?with_ldap:BuildRequires:     openldap-devel}
99 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
100 BuildRequires:  pkgconfig
101 %{?with_sql:BuildRequires:      postgresql-devel}
102 BuildRequires:  python3-devel >= 1:3.2
103 BuildRequires:  python3-ply
104 BuildRequires:  readline-devel
105 BuildRequires:  rpm >= 4.4.9-56
106 BuildRequires:  rpmbuild(macros) >= 1.647
107 %{?with_odbc:BuildRequires:     unixODBC-devel}
108 BuildRequires:  zlib-devel
109 %if %{with dnstap}
110 BuildRequires:  fstrm-devel
111 BuildRequires:  protobuf-c-devel
112 %endif
113 Requires(post,preun):   /sbin/chkconfig
114 Requires(postun):       /usr/sbin/groupdel
115 Requires(postun):       /usr/sbin/userdel
116 Requires(pre):  /bin/id
117 Requires(pre):  /usr/bin/getgid
118 Requires(pre):  /usr/sbin/groupadd
119 Requires(pre):  /usr/sbin/useradd
120 Requires(pre):  fileutils
121 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
122 # for dnssec-{checkds,coverage,keymgr}
123 Requires:       python3-isc = %{epoch}:%{version}-%{release}
124 Requires:       psmisc >= 20.1
125 Requires:       rc-scripts >= 0.2.0
126 Requires:       systemd-units >= 38
127 Requires:       uname(release) >= 2.2.18
128 Provides:       group(named)
129 Provides:       nameserver
130 Provides:       user(named)
131 Obsoletes:      caching-nameserver
132 Conflicts:      %{name}-chroot
133 Conflicts:      logrotate < 3.8.0
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %define         schemadir       /usr/share/openldap/schema
137
138 %description
139 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
140 (Domain Name System) protocols. BIND includes a DNS server (named),
141 which resolves host names to IP addresses, and a resolver library
142 (routines for applications to use when interfacing with DNS). A DNS
143 server allows clients to name resources or objects and share the
144 information with other network machines. The named DNS server can be
145 used on workstations as a caching name server, but is generally only
146 needed on one machine for an entire network. Note that the
147 configuration files for making BIND act as a simple caching nameserver
148 are included in the caching-nameserver package.
149
150 Install the bind package if you need a DNS server for your network. If
151 you want bind to act a caching name server, you will also need to
152 install the caching-nameserver package.
153
154 %description -l de.UTF-8
155 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
156 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
157 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
158 Recher des Netzwerks erforderlich.
159
160 %description -l es.UTF-8
161 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
162 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
163 un servidor de nombres caché, pero generalmente sólo hace falta en una
164 máquina para toda la red.
165
166 %description -l fr.UTF-8
167 Contient le serveur de noms named, utilisé pour définir les
168 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
169 utilisé sur les stations de travail comme serveur de nom en cache mais
170 n'est souvent nécessaire que sur une machine pour un réseau entier.
171
172 %description -l pl.UTF-8
173 Pakiet ten zawiera demona named, który służy do zmieniania nazw
174 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
175 roboczych jako bufor odwołań do serwisu nazw (caching name server),
176 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
177 program na fragment sieci.
178
179 %description -l pt_BR.UTF-8
180 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
181 IP (e vice-versa). Pode ser usado em estações de trabalho como um
182 servidor de nomes cache, mas geralmente só é necessário em uma máquina
183 para toda a rede.
184
185 %description -l ru.UTF-8
186 BIND (Berkeley Internet Name Domain) является реализацией протоколов
187 DNS (Domain Name System). BIND включает DNS сервер (named) и
188 библиотеку "резолвера" (подпрограммы для приложений, через которые
189 происходят обращения к DNS). DNS сервер named может быть использован
190 на рабочих станциях как кеширующий сервер, но обычно запускается на
191 одной машине в локальной сети и используется остальными машинами (этим
192 достигается намного более эффективное кеширование).
193
194 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
195 кеширующего сервера, включены в пакет caching-nameserver.
196
197 %description -l tr.UTF-8
198 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
199 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
200 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
201 için sadece bir makina üzerinde kurulur.
202
203 %description -l uk.UTF-8
204 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
205 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
206 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
207 сервер named може бути використаний на робочих станціях як кешируючий
208 сервер, але звичайно запускається на одній машині в локальній мережі і
209 використовується іншими (цим досягається більша ефективність
210 використання кешу).
211
212 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
213 кешируючого серверу, включені в пакет caching-nameserver.
214
215 %package utils
216 Summary:        DNS utils - host, dig, dnsquery, nslookup
217 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
218 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
219 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
220 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
221 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
222 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
223 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
224 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
225 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
226 Group:          Networking/Utilities
227 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
228 Requires:       iconv
229
230 %description utils
231 Bind-utils contains a collection of utilities for querying DNS (Domain
232 Name Service) name servers to find out information about Internet
233 hosts. These tools will provide you with the IP addresses for given
234 host names, as well as other information about registered domains and
235 network addresses.
236
237 You should install bind-utils if you need to get information from DNS
238 name servers.
239
240 %description utils -l de.UTF-8
241 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
242 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
243 Informationen über registrierte Domains und Netzwerk-Adressen.
244
245 %description utils -l es.UTF-8
246 Conjunto de utilitarios para consulta a servidores de nombres. Estas
247 herramientas permiten la determinación de direcciones IP para nombres
248 de máquinas informados y busca información sobre dominios registrados
249 y direcciones de red.
250
251 %description utils -l fr.UTF-8
252 Ensemble d'utilitaires pour interroger les serveurs de noms et
253 rechercher des hôtes. Ces outils vous permettent de déterminer les
254 adresses IP pour des noms d'hôtes donnés, et trouver des informations
255 sur les noms de domaine déclarés et les adresses réseau.
256
257 %description utils -l pl.UTF-8
258 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
259 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
260 i ich adresach IP.
261
262 %description utils -l pt_BR.UTF-8
263 Conjunto de utilitários para consulta a servidores DNS. Estas
264 ferramentas permitem a determinação de endereços IP para nomes de
265 máquinas informados e busca informações sobre domínios registrados e
266 endereços de rede. Você deveria instalar este pacote se necessitar
267 obter informações de servidores DNS.
268
269 %description utils -l ru.UTF-8
270 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
271 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
272 доменному имени (и наоборот) и другую информацию о зарегистрированных
273 доменах и сетевых адресах.
274
275 %description utils -l tr.UTF-8
276 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
277 için kullanılan araçlar bulunmaktadır.
278
279 %description utils -l uk.UTF-8
280 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
281 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
282 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
283 домени та адреси.
284
285 %package libs
286 Summary:        DNS libraries
287 Summary(pl.UTF-8):      Biblioteki DNS
288 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
289 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
290 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
291 Group:          Libraries
292 Requires:       json-c >= 0.11
293 Requires:       libuv >= 1.0.0
294 Requires:       libxml2 >= 1:2.6.0
295
296 %description libs
297 The bind-libs package contains all libraries required for running BIND
298 and bind utils.
299
300 %description libs -l pl.UTF-8
301 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
302 lub programów z pakietu bind-utils.
303
304 %description libs -l ru.UTF-8
305 Библиотеки, необходимые для работы bind.
306
307 %description libs -l uk.UTF-8
308 Бібліотеки, необхідні для роботи bind.
309
310 %package devel
311 Summary:        DNS development includes
312 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
313 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
314 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
315 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
316 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
317 Group:          Development/Libraries
318 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
319
320 %description devel
321 The bind-devel package contains all the include files and symlinks
322 required for DNS (Domain Name Service) development for BIND.
323
324 You should install bind-devel if you want to develop bind DNS
325 applications. If you install bind-devel, you'll also need to install
326 bind-libs.
327
328 %description devel -l es.UTF-8
329 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
330 para el bind.
331
332 %description devel -l pl.UTF-8
333 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
334 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
335 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
336 pakiet.
337
338 %description devel -l pt_BR.UTF-8
339 Todos os arquivos de cabeçalho e bibliotecas necessários para o
340 desenvolvimento com o bind.
341
342 %description devel -l ru.UTF-8
343 Все хедеры и библиотеки, необходимые для написания программ с
344 использованием BIND 9.x.x.
345
346 %description devel -l uk.UTF-8
347 Всі хедери та бібліотеки, необхідні для розробки програм з
348 використанням BIND 9.x.x.
349
350 %package static
351 Summary:        DNS static libs
352 Summary(pl.UTF-8):      Biblioteki statyczne DNS
353 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
354 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
355 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
356 Group:          Development/Libraries
357 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
358
359 %description static
360 Static bind libraries.
361
362 %description static -l pl.UTF-8
363 Statyczne biblioteki binda.
364
365 %description static -l pt_BR.UTF-8
366 Bibliotecas estáticas para desenvolvimento DNS.
367
368 %description static -l ru.UTF-8
369 Статические библиотеки, необходимые для написания программ с
370 использованием BIND.
371
372 %description static -l uk.UTF-8
373 Статичні бібліотеки, необхідні для розробки програм з використанням
374 BIND.
375
376 %package -n openldap-schema-bind
377 Summary:        BIND schema for openldap
378 Summary(pl.UTF-8):      Schemat BIND dla openldap
379 Group:          Development/Libraries
380 Requires(post,postun):  sed >= 4.0
381 Requires:       openldap-servers
382 Requires:       sed >= 4.0
383 %if "%{_rpmversion}" >= "5"
384 BuildArch:      noarch
385 %endif
386
387 %description -n openldap-schema-bind
388 BIND schema for openldap.
389
390 %description -n openldap-schema-bind -l pl.UTF-8
391 Schemat BIND dla openldap.
392
393 %package -n python3-isc
394 Summary:        Python 3 ISC module - functions to support BIND utilities
395 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
396 Group:          Libraries/Python
397 Requires:       python3-modules
398
399 %description -n python3-isc
400 Python 3 ISC module containing functions to support BIND utilities.
401
402 %description -n python3-isc -l pl.UTF-8
403 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
404 BIND-a.
405
406 %prep
407 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
408 %patch0 -p1
409 %patch1 -p1
410 %patch2 -p1
411 %{?with_ldap:%patch3 -p1}
412 %patch4 -p1
413 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
414 %{?with_edns_cli:%patch5 -p0}
415 %patch6 -p0
416
417 %build
418 %{__libtoolize}
419 %{__aclocal}
420 %{__autoconf}
421 cp -f /usr/share/automake/config.* .
422 %configure \
423         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
424         %{?with_dnstap:--enable-dnstap} \
425         %{!?with_epoll:--disable-epoll --disable-devpoll} \
426         --enable-full-report \
427         --enable-largefile \
428         %{!?with_static_libs:--disable-static} \
429         %{?with_kerberos5:--with-gssapi} \
430         --with-libidn2 \
431         --with-libtool \
432         %{?with_ssl:--with-openssl} \
433         %{?with_sql:--with-dlz-postgres} \
434         %{?with_sql:--with-dlz-mysql} \
435         --without-dlz-bdb \
436         --with-dlz-filesystem \
437         %{?with_ldap:--with-dlz-ldap} \
438         --with-dlz-odbc%{!?with_odbc:=no} \
439         --with-dlz-stub \
440         %{?with_geoip:--with-maxminddb} \
441         --with-lmdb%{!?with_lmdb:=no} \
442         --with-python=%{__python3}
443
444 %{__make}
445
446 %{?with_hip:%{__make} -C bind-hip}
447
448 %if %{with tests}
449 %if %{with system_tests}
450 %{__make} test-force
451 %else
452 sh unit/unittest.sh
453 %endif
454 %endif
455
456 %install
457 rm -rf $RPM_BUILD_ROOT
458 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
459         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
460         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
461         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
462
463 %{__make} install \
464         DESTDIR=$RPM_BUILD_ROOT
465
466 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
467 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
468 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
469 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
470
471 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
472 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
473 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
474 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
475 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
476 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
477 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
478 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
479 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
480
481 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
482 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
483 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
484 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
485
486 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
487
488 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
489 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
490
491 %if %{with ldap}
492 install -d $RPM_BUILD_ROOT%{schemadir}
493 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
494 %endif
495
496 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
497
498 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
499 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
500
501 # let rpm generate deps (workaround -m644 used for libs installation)
502 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
503
504 # we don't want Makefiles in documentation...
505 rm -rf _doc
506 cp -a doc _doc
507 %{__rm} _doc/misc/Makefile*
508
509 %clean
510 rm -rf $RPM_BUILD_ROOT
511
512 %pre
513 if [ -f %{_sysconfdir}/named.boot ]; then
514         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
515         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
516         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
517 fi
518 %groupadd -g 58 named
519 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
520
521 %post
522 /sbin/chkconfig --add named
523 %service named restart
524 %systemd_post named.service
525
526 %preun
527 if [ "$1" = "0" ]; then
528         %service named stop
529         /sbin/chkconfig --del named
530 fi
531 %systemd_preun named.service
532
533 %postun
534 if [ "$1" = "0" ]; then
535         %userremove named
536         %groupremove named
537 fi
538 %systemd_reload
539
540 %post   libs -p /sbin/ldconfig
541 %postun libs -p /sbin/ldconfig
542
543 %post -n openldap-schema-bind
544 %openldap_schema_register %{schemadir}/dnszone.schema
545 %service -q ldap restart
546
547 %postun -n openldap-schema-bind
548 if [ "$1" = "0" ]; then
549         %openldap_schema_unregister %{schemadir}/dnszone.schema
550         %service -q ldap restart
551 fi
552
553 %triggerpostun -- %{name} < 7:9.4.2-2
554 /sbin/chkconfig named reset
555 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
556 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
557 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
558
559 %triggerpostun -- %{name} < 7:9.9.2.P2-2
560 %systemd_trigger named.service
561
562 %files
563 %defattr(644,root,root,755)
564 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
565 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
566
567 %{systemdunitdir}/named.service
568 %attr(754,root,root) /etc/rc.d/init.d/named
569 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
570 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
571 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
572 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
573
574 %attr(755,root,root) %{_sbindir}/ddns-confgen
575 %attr(755,root,root) %{_sbindir}/dnssec-*
576 %attr(755,root,root) %{_sbindir}/named
577 %attr(755,root,root) %{_sbindir}/named-*
578 %attr(755,root,root) %{_sbindir}/nsec3hash
579 %attr(755,root,root) %{_sbindir}/rndc
580 %attr(755,root,root) %{_sbindir}/rndc-confgen
581 %attr(755,root,root) %{_sbindir}/tsig-keygen
582
583 %{_mandir}/man5/named.conf.5*
584 %{_mandir}/man5/rndc.conf.5*
585 %{_mandir}/man8/ddns-confgen.8*
586 %{_mandir}/man8/dnssec-*.8*
587 %{_mandir}/man8/named.8*
588 %{_mandir}/man8/named-*.8*
589 %{_mandir}/man8/nsec3hash.8*
590 %{_mandir}/man8/rndc.8*
591 %{_mandir}/man8/rndc-confgen.8*
592 %{_mandir}/man8/tsig-keygen.8*
593 %lang(ja) %{_mandir}/ja/man8/named*
594
595 %{systemdtmpfilesdir}/%{name}.conf
596
597 %attr(770,root,named) %dir %{_var}/lib/named
598 %attr(770,root,named) %dir %{_var}/lib/named/D
599 %attr(770,root,named) %dir %{_var}/lib/named/M
600 %attr(770,root,named) %dir %{_var}/lib/named/S
601 %attr(770,root,named) %dir %{_var}/lib/named/dev
602 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
603 %attr(750,root,named) %dir %{_var}/lib/named/etc
604 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
605 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
606 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
607 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
608 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
609 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
610
611 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
612 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
613
614 %attr(770,root,named) %dir %{_var}/run/named
615
616 %dir %{_libdir}/named
617 %attr(755,root,root) %{_libdir}/named/filter-aaaa.so
618 %{_mandir}/man8/filter-aaaa.8*
619
620 %files utils
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/arpaname
623 %attr(755,root,root) %{_bindir}/delv
624 %attr(755,root,root) %{_bindir}/dig
625 %attr(755,root,root) %{_bindir}/host
626 %attr(755,root,root) %{_bindir}/named-rrchecker
627 %attr(755,root,root) %{_bindir}/mdig
628 %attr(755,root,root) %{_bindir}/nslookup
629 %attr(755,root,root) %{_bindir}/nsupdate
630 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
631 %{_mandir}/man1/arpaname.1*
632 %{_mandir}/man1/delv.1*
633 %{_mandir}/man1/dig.1*
634 %{_mandir}/man1/host.1*
635 %{_mandir}/man1/mdig.1*
636 %{_mandir}/man1/named-rrchecker.1*
637 %{_mandir}/man1/nslookup.1*
638 %{_mandir}/man1/nsupdate.1*
639
640 %lang(fi) %{_mandir}/fi/man1/host.1*
641
642 %lang(fr) %{_mandir}/fr/man1/host.1*
643
644 %lang(hu) %{_mandir}/hu/man1/host.1*
645
646 %lang(ja) %{_mandir}/ja/man1/dig.1*
647 %lang(ja) %{_mandir}/ja/man1/host.1*
648 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
649 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
650
651 %lang(pl) %{_mandir}/pl/man1/host.1*
652
653 %files libs
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.1600
657 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libdns.so.1600
659 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libirs.so.1600
661 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libisc.so.1600
663 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.1600
665 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1600
667 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libns.so.1600
669
670 %files devel
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/libbind9.so
673 %attr(755,root,root) %{_libdir}/libdns.so
674 %attr(755,root,root) %{_libdir}/libirs.so
675 %attr(755,root,root) %{_libdir}/libisc.so
676 %attr(755,root,root) %{_libdir}/libisccc.so
677 %attr(755,root,root) %{_libdir}/libisccfg.so
678 %attr(755,root,root) %{_libdir}/libns.so
679 %{_libdir}/libbind9.la
680 %{_libdir}/libdns.la
681 %{_libdir}/libirs.la
682 %{_libdir}/libisc.la
683 %{_libdir}/libisccc.la
684 %{_libdir}/libisccfg.la
685 %{_libdir}/libns.la
686 %{_includedir}/bind9
687 %{_includedir}/dns
688 %{_includedir}/dst
689 %{_includedir}/irs
690 %{_includedir}/isc
691 %{_includedir}/isccc
692 %{_includedir}/isccfg
693 %{_includedir}/ns
694 %{_includedir}/pk11
695 %{_includedir}/pkcs11
696
697 %if %{with static_libs}
698 %files static
699 %defattr(644,root,root,755)
700 %{_libdir}/libbind9.a
701 %{_libdir}/libdns.a
702 %{_libdir}/libirs.a
703 %{_libdir}/libisc.a
704 %{_libdir}/libisccc.a
705 %{_libdir}/libisccfg.a
706 %{_libdir}/libns.a
707 %endif
708
709 %if %{with ldap}
710 %files -n openldap-schema-bind
711 %defattr(644,root,root,755)
712 %{_datadir}/openldap/schema/dnszone.schema
713 %endif
714
715 %files -n python3-isc
716 %defattr(644,root,root,755)
717 %{py3_sitedir}/isc
718 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.123014 seconds and 2 git commands to generate.