]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- drop ldap schema leftovers (removed with updated to 9.18.0)
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_with     static_libs     # static libraries
11 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
12 %bcond_with     tests           # unit tests
13 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
14 %bcond_with     hip             # HIP RR support
15
16 %if "%{pld_release}" == "ac"
17 %bcond_with     epoll           # enable epoll support
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll           # disable epoll support
24 %endif
25
26 %define         ver     9.18.1
27 %if 0
28 %define         pverdot .P0
29 %define         pverdir -P0
30 %else
31 %define         pverdot %{nil}
32 %define         pverdir %{nil}
33 %endif
34 Summary:        BIND - DNS name server
35 Summary(de.UTF-8):      BIND - DNS-Namenserver
36 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
37 Summary(fr.UTF-8):      BIND - serveur de noms DNS
38 Summary(pl.UTF-8):      BIND - serwer nazw DNS
39 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
40 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
41 Summary(tr.UTF-8):      DNS alan adı sunucusu
42 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
43 Summary(zh_CN.UTF-8):   Internet 域名服务器
44 Name:           bind
45 Version:        %{ver}%{pverdot}
46 Release:        1
47 Epoch:          7
48 License:        MPL 2.0
49 Group:          Networking/Daemons
50 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
51 # Source0-md5:  d7072b2d774077f37bff51580b3a577b
52 Source1:        named.init
53 Source2:        named.sysconfig
54 Source3:        named.logrotate
55 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        https://www.internic.net/domain/named.root
60 # Source7-md5:  544504d19e2b71c259d2a09d231533aa
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Source11:       %{name}.tmpfiles
65 Source12:       named.service
66
67 Patch3:         jemalloc.patch
68 Patch4:         %{name}-ac-libs.patch
69 Patch5:         %{name}-edns-client-subnet.patch
70 URL:            https://www.isc.org/software/bind
71 BuildRequires:  autoconf >= 2.60
72 BuildRequires:  automake
73 BuildRequires:  bison
74 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
75 BuildRequires:  flex
76 %{?with_kerberos5:BuildRequires:        heimdal-devel}
77 BuildRequires:  jemalloc-devel
78 BuildRequires:  json-c-devel >= 0.11
79 BuildRequires:  libatomic-devel
80 BuildRequires:  libcap-devel
81 BuildRequires:  libidn2-devel
82 # note, there is no kyua in PLD yet (work in progress)
83 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
84 BuildRequires:  libtool
85 BuildRequires:  libuv-devel >= 1.37.0
86 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
87 BuildRequires:  libxml2-devel >= 1:2.6.0
88 %{?with_lmdb:BuildRequires:     lmdb-devel}
89 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
90 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
91 BuildRequires:  pkgconfig
92 BuildRequires:  python3-devel >= 1:3.2
93 BuildRequires:  python3-sphinx_rtd_theme
94 BuildRequires:  readline-devel
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.647
97 BuildRequires:  sphinx-pdg
98 BuildRequires:  zlib-devel
99 %if %{with dnstap}
100 BuildRequires:  fstrm-devel
101 BuildRequires:  protobuf-c-devel
102 %endif
103 Requires(post,preun):   /sbin/chkconfig
104 Requires(postun):       /usr/sbin/groupdel
105 Requires(postun):       /usr/sbin/userdel
106 Requires(pre):  /bin/id
107 Requires(pre):  /usr/bin/getgid
108 Requires(pre):  /usr/sbin/groupadd
109 Requires(pre):  /usr/sbin/useradd
110 Requires(pre):  fileutils
111 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
112 Requires:       psmisc >= 20.1
113 Requires:       rc-scripts >= 0.2.0
114 Requires:       systemd-units >= 38
115 Requires:       uname(release) >= 2.2.18
116 Provides:       group(named)
117 Provides:       nameserver
118 Provides:       user(named)
119 Obsoletes:      caching-nameserver
120 Conflicts:      %{name}-chroot
121 Conflicts:      logrotate < 3.8.0
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %description
125 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
126 (Domain Name System) protocols. BIND includes a DNS server (named),
127 which resolves host names to IP addresses, and a resolver library
128 (routines for applications to use when interfacing with DNS). A DNS
129 server allows clients to name resources or objects and share the
130 information with other network machines. The named DNS server can be
131 used on workstations as a caching name server, but is generally only
132 needed on one machine for an entire network. Note that the
133 configuration files for making BIND act as a simple caching nameserver
134 are included in the caching-nameserver package.
135
136 Install the bind package if you need a DNS server for your network. If
137 you want bind to act a caching name server, you will also need to
138 install the caching-nameserver package.
139
140 %description -l de.UTF-8
141 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
142 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
143 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
144 Recher des Netzwerks erforderlich.
145
146 %description -l es.UTF-8
147 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
148 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
149 un servidor de nombres caché, pero generalmente sólo hace falta en una
150 máquina para toda la red.
151
152 %description -l fr.UTF-8
153 Contient le serveur de noms named, utilisé pour définir les
154 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
155 utilisé sur les stations de travail comme serveur de nom en cache mais
156 n'est souvent nécessaire que sur une machine pour un réseau entier.
157
158 %description -l pl.UTF-8
159 Pakiet ten zawiera demona named, który służy do zmieniania nazw
160 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
161 roboczych jako bufor odwołań do serwisu nazw (caching name server),
162 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
163 program na fragment sieci.
164
165 %description -l pt_BR.UTF-8
166 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
167 IP (e vice-versa). Pode ser usado em estações de trabalho como um
168 servidor de nomes cache, mas geralmente só é necessário em uma máquina
169 para toda a rede.
170
171 %description -l ru.UTF-8
172 BIND (Berkeley Internet Name Domain) является реализацией протоколов
173 DNS (Domain Name System). BIND включает DNS сервер (named) и
174 библиотеку "резолвера" (подпрограммы для приложений, через которые
175 происходят обращения к DNS). DNS сервер named может быть использован
176 на рабочих станциях как кеширующий сервер, но обычно запускается на
177 одной машине в локальной сети и используется остальными машинами (этим
178 достигается намного более эффективное кеширование).
179
180 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
181 кеширующего сервера, включены в пакет caching-nameserver.
182
183 %description -l tr.UTF-8
184 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
185 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
186 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
187 için sadece bir makina üzerinde kurulur.
188
189 %description -l uk.UTF-8
190 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
191 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
192 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
193 сервер named може бути використаний на робочих станціях як кешируючий
194 сервер, але звичайно запускається на одній машині в локальній мережі і
195 використовується іншими (цим досягається більша ефективність
196 використання кешу).
197
198 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
199 кешируючого серверу, включені в пакет caching-nameserver.
200
201 %package plugins
202 Summary:        Plugins for Bind DNS name server
203 Summary(pl.UTF-8):      Wtyczki dla serwera nazw DNS Bind
204 Group:          Networking/Utilities
205 Requires:       %{name} = %{epoch}:%{version}-%{release}
206
207 %description plugins
208 Plugins for extending of query processing functionality of Bind DNS name
209 server.
210
211 %description plugins -l pl.UTF-8
212 Wtyczki rozszerzające funkcjonalność przetwarzania zapytań przez serwer
213 nazw DNS Bind.
214
215 %package utils
216 Summary:        DNS utils - host, dig, dnsquery, nslookup
217 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
218 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
219 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
220 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
221 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
222 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
223 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
224 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
225 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
226 Group:          Networking/Utilities
227 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
228 Requires:       iconv
229
230 %description utils
231 Bind-utils contains a collection of utilities for querying DNS (Domain
232 Name Service) name servers to find out information about Internet
233 hosts. These tools will provide you with the IP addresses for given
234 host names, as well as other information about registered domains and
235 network addresses.
236
237 You should install bind-utils if you need to get information from DNS
238 name servers.
239
240 %description utils -l de.UTF-8
241 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
242 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
243 Informationen über registrierte Domains und Netzwerk-Adressen.
244
245 %description utils -l es.UTF-8
246 Conjunto de utilitarios para consulta a servidores de nombres. Estas
247 herramientas permiten la determinación de direcciones IP para nombres
248 de máquinas informados y busca información sobre dominios registrados
249 y direcciones de red.
250
251 %description utils -l fr.UTF-8
252 Ensemble d'utilitaires pour interroger les serveurs de noms et
253 rechercher des hôtes. Ces outils vous permettent de déterminer les
254 adresses IP pour des noms d'hôtes donnés, et trouver des informations
255 sur les noms de domaine déclarés et les adresses réseau.
256
257 %description utils -l pl.UTF-8
258 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
259 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
260 i ich adresach IP.
261
262 %description utils -l pt_BR.UTF-8
263 Conjunto de utilitários para consulta a servidores DNS. Estas
264 ferramentas permitem a determinação de endereços IP para nomes de
265 máquinas informados e busca informações sobre domínios registrados e
266 endereços de rede. Você deveria instalar este pacote se necessitar
267 obter informações de servidores DNS.
268
269 %description utils -l ru.UTF-8
270 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
271 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
272 доменному имени (и наоборот) и другую информацию о зарегистрированных
273 доменах и сетевых адресах.
274
275 %description utils -l tr.UTF-8
276 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
277 için kullanılan araçlar bulunmaktadır.
278
279 %description utils -l uk.UTF-8
280 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
281 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
282 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
283 домени та адреси.
284
285 %package libs
286 Summary:        DNS libraries
287 Summary(pl.UTF-8):      Biblioteki DNS
288 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
289 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
290 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
291 Group:          Libraries
292 Requires:       json-c >= 0.11
293 Requires:       libuv >= 1.37.0
294 Requires:       libxml2 >= 1:2.6.0
295
296 %description libs
297 The bind-libs package contains all libraries required for running BIND
298 and bind utils.
299
300 %description libs -l pl.UTF-8
301 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
302 lub programów z pakietu bind-utils.
303
304 %description libs -l ru.UTF-8
305 Библиотеки, необходимые для работы bind.
306
307 %description libs -l uk.UTF-8
308 Бібліотеки, необхідні для роботи bind.
309
310 %package devel
311 Summary:        DNS development includes
312 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
313 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
314 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
315 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
316 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
317 Group:          Development/Libraries
318 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
319
320 %description devel
321 The bind-devel package contains all the include files and symlinks
322 required for DNS (Domain Name Service) development for BIND.
323
324 You should install bind-devel if you want to develop bind DNS
325 applications. If you install bind-devel, you'll also need to install
326 bind-libs.
327
328 %description devel -l es.UTF-8
329 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
330 para el bind.
331
332 %description devel -l pl.UTF-8
333 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
334 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
335 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
336 pakiet.
337
338 %description devel -l pt_BR.UTF-8
339 Todos os arquivos de cabeçalho e bibliotecas necessários para o
340 desenvolvimento com o bind.
341
342 %description devel -l ru.UTF-8
343 Все хедеры и библиотеки, необходимые для написания программ с
344 использованием BIND 9.x.x.
345
346 %description devel -l uk.UTF-8
347 Всі хедери та бібліотеки, необхідні для розробки програм з
348 використанням BIND 9.x.x.
349
350 %package static
351 Summary:        DNS static libs
352 Summary(pl.UTF-8):      Biblioteki statyczne DNS
353 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
354 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
355 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
356 Group:          Development/Libraries
357 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
358
359 %description static
360 Static bind libraries.
361
362 %description static -l pl.UTF-8
363 Statyczne biblioteki binda.
364
365 %description static -l pt_BR.UTF-8
366 Bibliotecas estáticas para desenvolvimento DNS.
367
368 %description static -l ru.UTF-8
369 Статические библиотеки, необходимые для написания программ с
370 использованием BIND.
371
372 %description static -l uk.UTF-8
373 Статичні бібліотеки, необхідні для розробки програм з використанням
374 BIND.
375
376 %prep
377 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
378
379 %patch3 -p1
380 %patch4 -p1
381 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
382 %{?with_edns_cli:%patch5 -p0}
383
384 %build
385 %{__libtoolize}
386 %{__aclocal}
387 %{__autoconf}
388 %{__automake}
389 %configure \
390         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
391         LDFLAGS="%{rpmldflags}" \
392         %{?with_dnstap:--enable-dnstap} \
393         %{!?with_epoll:--disable-epoll --disable-devpoll} \
394         --enable-full-report \
395         --enable-largefile \
396         %{?with_static_libs:--enable-static} \
397         %{?with_kerberos5:--with-gssapi} \
398         --with-jemalloc=yes \
399         --with-libidn2 \
400         --with-libxml2 \
401         %{?with_ssl:--with-openssl} \
402         %{?with_geoip:--with-maxminddb} \
403         --with-lmdb%{!?with_lmdb:=no} \
404         --with-tuning \
405         --disable-silent-rules
406
407 %{__make}
408 %{__make} -C doc/arm html
409
410 %{?with_hip:%{__make} -C bind-hip}
411
412 %if %{with tests}
413 %if %{with system_tests}
414 %{__make} test-force
415 %else
416 sh unit/unittest.sh
417 %endif
418 %endif
419
420 %install
421 rm -rf $RPM_BUILD_ROOT
422 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
423         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
424         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
425         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
426
427 %{__make} install \
428         DESTDIR=$RPM_BUILD_ROOT
429
430 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
431 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
432 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
433 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
434
435 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
436 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
437 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
438 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
439 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
440 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
441 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
442 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
443
444 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
445 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
446 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
447 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
448
449 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
450
451 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
452 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
453
454 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
455
456 # we don't want Makefiles in documentation...
457 rm -rf _doc
458 cp -a doc _doc
459 %{__rm} _doc/misc/Makefile*
460
461 %clean
462 rm -rf $RPM_BUILD_ROOT
463
464 %pre
465 if [ -f %{_sysconfdir}/named.boot ]; then
466         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
467         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
468         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
469 fi
470 %groupadd -g 58 named
471 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
472
473 %post
474 /sbin/chkconfig --add named
475 %service named restart
476 %systemd_post named.service
477
478 %preun
479 if [ "$1" = "0" ]; then
480         %service named stop
481         /sbin/chkconfig --del named
482 fi
483 %systemd_preun named.service
484
485 %postun
486 if [ "$1" = "0" ]; then
487         %userremove named
488         %groupremove named
489 fi
490 %systemd_reload
491
492 %post   libs -p /sbin/ldconfig
493 %postun libs -p /sbin/ldconfig
494
495 %triggerpostun -- %{name} < 7:9.9.2.P2-2
496 %systemd_trigger named.service
497
498 %files
499 %defattr(644,root,root,755)
500 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
501 %doc _doc/misc/* _doc/arm/_build/html/*.html
502
503 %{systemdunitdir}/named.service
504 %attr(754,root,root) /etc/rc.d/init.d/named
505 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
506 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
507 %{_sysconfdir}/named.conf
508 %{_sysconfdir}/bind.keys
509
510 %attr(755,root,root) %{_bindir}/dnssec-*
511 %attr(755,root,root) %{_bindir}/named-*
512 %attr(755,root,root) %{_bindir}/nsec3hash
513 %attr(755,root,root) %{_sbindir}/ddns-confgen
514 %attr(755,root,root) %{_sbindir}/named
515 %attr(755,root,root) %{_sbindir}/rndc
516 %attr(755,root,root) %{_sbindir}/rndc-confgen
517 %attr(755,root,root) %{_sbindir}/tsig-keygen
518
519 %{_mandir}/man1/dnssec-*.1*
520 %{_mandir}/man1/named-*.1*
521 %{_mandir}/man1/nsec3hash.1*
522 %{_mandir}/man5/named.conf.5*
523 %{_mandir}/man5/rndc.conf.5*
524 %{_mandir}/man8/ddns-confgen.8*
525 %{_mandir}/man8/named.8*
526 %{_mandir}/man8/rndc.8*
527 %{_mandir}/man8/rndc-confgen.8*
528 %{_mandir}/man8/tsig-keygen.8*
529 %lang(ja) %{_mandir}/ja/man8/named*
530
531 %{systemdtmpfilesdir}/%{name}.conf
532
533 %attr(770,root,named) %dir %{_var}/lib/named
534 %attr(770,root,named) %dir %{_var}/lib/named/D
535 %attr(770,root,named) %dir %{_var}/lib/named/M
536 %attr(770,root,named) %dir %{_var}/lib/named/S
537 %attr(770,root,named) %dir %{_var}/lib/named/dev
538 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
539 %attr(750,root,named) %dir %{_var}/lib/named/etc
540 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
541 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
542 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
543 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
544 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
545 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
546
547 %config(noreplace,missingok) %{_var}/log/named
548 %config(noreplace,missingok) %{_var}/log/named.stats
549
550 %attr(770,root,named) %dir %{_var}/run/named
551
552 %files plugins
553 %defattr(644,root,root,755)
554 %dir %{_libdir}/bind
555 %attr(755,root,root) %{_libdir}/bind/filter-a.so
556 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
557 %{_mandir}/man8/filter-a.8*
558 %{_mandir}/man8/filter-aaaa.8*
559
560 %files utils
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_bindir}/arpaname
563 %attr(755,root,root) %{_bindir}/delv
564 %attr(755,root,root) %{_bindir}/dig
565 %attr(755,root,root) %{_bindir}/host
566 %attr(755,root,root) %{_bindir}/named-rrchecker
567 %attr(755,root,root) %{_bindir}/mdig
568 %attr(755,root,root) %{_bindir}/nslookup
569 %attr(755,root,root) %{_bindir}/nsupdate
570 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
571 %{_mandir}/man1/arpaname.1*
572 %{_mandir}/man1/delv.1*
573 %{_mandir}/man1/dig.1*
574 %{_mandir}/man1/host.1*
575 %{_mandir}/man1/mdig.1*
576 %{_mandir}/man1/named-rrchecker.1*
577 %{_mandir}/man1/nslookup.1*
578 %{_mandir}/man1/nsupdate.1*
579
580 %lang(fi) %{_mandir}/fi/man1/host.1*
581
582 %lang(fr) %{_mandir}/fr/man1/host.1*
583
584 %lang(hu) %{_mandir}/hu/man1/host.1*
585
586 %lang(ja) %{_mandir}/ja/man1/dig.1*
587 %lang(ja) %{_mandir}/ja/man1/host.1*
588 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
589 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
590
591 %lang(pl) %{_mandir}/pl/man1/host.1*
592
593 %files libs
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
596 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
597 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
598 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
599 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
600 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
601 %attr(755,root,root) %{_libdir}/libns-%{version}.so
602
603 %files devel
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/libbind9.so
606 %attr(755,root,root) %{_libdir}/libdns.so
607 %attr(755,root,root) %{_libdir}/libirs.so
608 %attr(755,root,root) %{_libdir}/libisc.so
609 %attr(755,root,root) %{_libdir}/libisccc.so
610 %attr(755,root,root) %{_libdir}/libisccfg.so
611 %attr(755,root,root) %{_libdir}/libns.so
612 %{_libdir}/libbind9.la
613 %{_libdir}/libdns.la
614 %{_libdir}/libirs.la
615 %{_libdir}/libisc.la
616 %{_libdir}/libisccc.la
617 %{_libdir}/libisccfg.la
618 %{_libdir}/libns.la
619 %{_includedir}/bind9
620 %{_includedir}/dns
621 %{_includedir}/dst
622 %{_includedir}/irs
623 %{_includedir}/isc
624 %{_includedir}/isccc
625 %{_includedir}/isccfg
626 %{_includedir}/ns
627
628 %if %{with static_libs}
629 %files static
630 %defattr(644,root,root,755)
631 %{_libdir}/libbind9.a
632 %{_libdir}/libdns.a
633 %{_libdir}/libirs.a
634 %{_libdir}/libisc.a
635 %{_libdir}/libisccc.a
636 %{_libdir}/libisccfg.a
637 %{_libdir}/libns.a
638 %endif
This page took 0.13858 seconds and 3 git commands to generate.