]> git.pld-linux.org Git - packages/belle-sip.git/blob - belle-sip.spec
d87a0867a4df6d4b0a4b946ec9cf53a3650bd55b
[packages/belle-sip.git] / belle-sip.spec
1 # TODO: tunnel? (BR: pkgconfig(tunnel) or TunnelConfig.cmake)
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # static library
5 %bcond_with     tests           # enable tests
6 #
7 Summary:        SIP (RFC3261) object-oriented implementation in C
8 Summary(pl.UTF-8):      Implementacja SIP (RFC3261) w C
9 Name:           belle-sip
10 Version:        1.6.3
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        https://linphone.org/releases/sources/belle-sip/%{name}-%{version}.tar.gz
15 # Source0-md5:  90c40812d98671ad2f40621542500bc6
16 Patch0:         antlr_jar.patch
17 Patch1:         build.patch
18 URL:            http://www.linphone.org/
19 %{?with_tests:BuildRequires:    CUnit >= 2.0}
20 BuildRequires:  autoconf >= 2.63
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  bctoolbox-devel >= 0.5.0
23 BuildRequires:  java-antlr3 >= 3.2
24 BuildRequires:  jre
25 BuildRequires:  libantlr3c-devel >= 3.4
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  pkgconfig
29 BuildRequires:  zlib-devel >= 1.2.3
30 Requires:       bctoolbox >= 0.5.0
31 Requires:       libantlr3c >= 3.4
32 Requires:       zlib >= 1.2.3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Belle-sip is a SIP (RFC3261) implementation written in C, with an
37 object oriented API.
38
39 %description -l pl.UTF-8
40 Belle-sip to implementacja SIP (RFC3261) napisana w C z API
41 zorientowanym obiektowo.
42
43 %package devel
44 Summary:        Header files for %{name} library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       bctoolbox-devel >= 0.5.0
49 Requires:       libantlr3c-devel >= 3.4
50
51 %description devel
52 Header files for %{name} library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki %{name}.
56
57 %package static
58 Summary:        Static %{name} library
59 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static %{name} library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka %{name}.
68
69 %prep
70 %setup -q -n %{name}-%{version}-0
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 %{__libtoolize}
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 WARNFLAGS="-Wno-error=pragmas -Wno-error=array-bounds"
81 %if "%{cc_version}" >= "7"
82 WARNFLAGS="$WARNFLAGS -Wno-implicit-fallthrough -Wno-error=cast-function-type"
83 %endif
84 %configure \
85         CFLAGS="%{rpmcflags} $WARNFLAGS" \
86         --disable-silent-rules \
87         %{!?with_static_libs:--disable-static}
88
89 %{__make}
90
91 %{?with_tests:%{__make} test}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbellesip.la
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS NEWS README.md
110 %attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libbellesip.so
116 %{_includedir}/belle-sip
117 %{_pkgconfigdir}/belle-sip.pc
118
119 %if %{with static_libs}
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libbellesip.a
123 %endif
This page took 0.044329 seconds and 2 git commands to generate.