]> git.pld-linux.org Git - packages/belcard.git/blob - belcard.spec
99410cbc81ad0fab642637b90e66d0d64b796f0a
[packages/belcard.git] / belcard.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Belledonne Communications' vCard 4 parsing library
6 Summary(pl.UTF-8):      Biblioteka Belledonne Communications do analizy formatu vCard 4
7 Name:           belcard
8 Version:        4.5.20
9 Release:        1
10 License:        GPL v2+
11 Group:          Libraries
12 #Source0Download: https://gitlab.linphone.org/BC/public/belcard/-/tags
13 Source0:        https://gitlab.linphone.org/BC/public/belcard/-/archive/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  6c0ebca77e42cc8591bc2c895458e3ef
15 Patch0:         %{name}-pc.patch
16 URL:            https://linphone.org/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  bctoolbox-devel >= 0.0.3
20 BuildRequires:  bcunit-devel
21 BuildRequires:  belr-devel
22 BuildRequires:  libstdc++-devel >= 6:4.7
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  pkgconfig
25 BuildRequires:  xxd
26 Requires:       bctoolbox >= 0.0.3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Belcard is a C++ library to manipulate VCard standard format.
31
32 %description -l pl.UTF-8
33 Belcard to biblioteka C++ do operacji na danych w standardzie VCard.
34
35 %package devel
36 Summary:        Header files for BelCard library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BelCard
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       bctoolbox-devel >= 0.0.3
41 Requires:       belr-devel
42 Requires:       libstdc++-devel >= 6:4.7
43
44 %description devel
45 Header files for BelCard library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki BelCard.
49
50 %package static
51 Summary:        Static BelCard library
52 Summary(pl.UTF-8):      Statyczna biblioteka BelCard
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static BelCard library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka BelCard.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal} -I m4
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         --disable-silent-rules \
74         %{?with_static_libs:--enable-static}
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # obsoleted by pkg-config
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbelcard.la
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc CHANGELOG.md README.md
95 %attr(755,root,root) %{_bindir}/belcard-folder
96 %attr(755,root,root) %{_bindir}/belcard-parser
97 %attr(755,root,root) %{_bindir}/belcard-unfolder
98 %attr(755,root,root) %{_libdir}/libbelcard.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libbelcard.so.0
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libbelcard.so
104 %{_includedir}/belcard
105 %{_pkgconfigdir}/belcard.pc
106
107 %if %{with static_libs}
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libbelcard.a
111 %endif
This page took 0.118837 seconds and 2 git commands to generate.