]> git.pld-linux.org Git - packages/bcunit.git/blob - bcunit.spec
- up to 3.0.2
[packages/bcunit.git] / bcunit.spec
1 Summary:        Provide C programmers basic testing functionality
2 Name:           bcunit
3 Version:        3.0.2
4 Release:        1
5 License:        GPL v2+
6 Group:          Libraries
7 Source0:        https://linphone.org/releases/sources/bcunit/%{name}-%{version}.tar.gz
8 # Source0-md5:  3c197563b790131da8ad1be6a23f9c91
9 Patch0:         lib.patch
10 URL:            https://linphone.org/
11 BuildRequires:  cmake
12 BuildRequires:  ncurses-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 BCUnit is a unit testing framework for C, derived from CUnit. (B)CUnit
17 provides various interfaces to the framework, some of which are
18 platform dependent (e.g. curses on *nix). The framework complies with
19 the conventional structure of test cases bundled into suites which are
20 registered with the framework for running.
21
22 %package devel
23 Summary:        Header files and develpment documentation for bcunit
24 Group:          Development/Libraries
25 Requires:       %{name} = %{epoch}:%{version}-%{release}
26
27 %description devel
28 Header files and develpment documentation for bcunit.
29
30 %package static
31 Summary:        Static bcunit library
32 Group:          Development/Libraries
33 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
34
35 %description static
36 Static bcunit library.
37
38 %prep
39 %setup -q -n BCunit-%{version}-Source
40 %patch0 -p1
41
42 %build
43 install -d build
44 cd build
45 %{cmake} \
46         -DENABLE_STATIC=OFF \
47         -DENABLE_AUTOMATED=ON \
48         -DENABLE_BASIC=ON \
49         -DENABLE_CONSOLE=ON \
50         -DENABLE_CURSES=ON \
51         -DENABLE_EXAMPLES=ON \
52         ..
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog NEWS README TODO
71 %attr(755,root,root) %{_libdir}/libbcunit.so.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libbcunit.so.1
73
74 %files devel
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_libdir}/libbcunit.so
77 %{_includedir}/BCUnit
78 %{_pkgconfigdir}/bcunit.pc
79 %{_datadir}/BCunit
This page took 0.045179 seconds and 3 git commands to generate.