]> git.pld-linux.org Git - packages/bcg729.git/blob - bcg729.spec
- updated to 1.1.1, mediastreamer plugin no longer included here
[packages/bcg729.git] / bcg729.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        ITU G729 Annex A speech codec library
6 Summary(pl.UTF-8):      Biblioteka kodeka mowy ITU G729 Annex A
7 Name:           bcg729
8 Version:        1.1.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 #Source0Download: https://gitlab.linphone.org/BC/public/bcg729/tags
13 Source0:        https://gitlab.linphone.org/BC/public/bcg729/-/archive/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  23b0c28422df3251adbc81e596ef9861
15 URL:            http://www.linphone.org/technical-corner/bcg729
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 2:2
19 BuildRequires:  pkgconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 bcg729 is an opensource implementation of both encoder and decoder of
24 the ITU G729 Annex A speech codec. The library written in C99 is fully
25 portable and can be executed on many platforms including both ARM
26 processor and x86. libbcg729 supports concurrent channels
27 encoding/decoding for multi call application such conferencing. This
28 project was initially developed as part of Mediastreamer2, the
29 Linphone's media processing engine. So there is also available the
30 glue to be integrated in Linphone/Mediastreamer2.
31
32 %description -l pl.UTF-8
33 bcg729 to implementacja o otwartych źródłach kodera oraz dekorera
34 kodeka mowy ITU G729 Annex A. Biblioteka napisana w dialekcie C99 jest
35 w pełni przenośna i może być uruchamiana na wielu platformach, w tym
36 procesorach ARM i x86. libbcg729 obsługuje jednoczesne
37 kodowanie/dekodowanie wielu kanałów dla zastosowań z wieloma
38 rozmowami,takich jak konferencje. Ten projekt początkowo był częścią
39 Mediastreamera2 - silnika przetwarzania multimediów programu Linphone.
40 Dlatego jest też dostępny kod łączący z Linphonem/Mediastreamerem2.
41
42 %package devel
43 Summary:        Header files for bcg729 library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki bcg729
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for bcg729 library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki bcg729.
53
54 %package static
55 Summary:        Static bcg729 library
56 Summary(pl.UTF-8):      Statyczna biblioteka bcg729
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static bcg729 library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka bcg729.
65
66 %prep
67 %setup -q
68
69 # required by configure
70 touch bcg729.spec.in
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure \
79         --disable-silent-rules \
80         %{!?with_static_libs:--disable-static}
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # obsoleted by pkg-config
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbcg729.la
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS.md CHANGELOG.md README.md
102 %attr(755,root,root) %{_libdir}/libbcg729.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libbcg729.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libbcg729.so
108 %{_includedir}/bcg729
109 %{_pkgconfigdir}/libbcg729.pc
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libbcg729.a
115 %endif
This page took 0.06715 seconds and 3 git commands to generate.