]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- first problems noticed (lost commit from Oct 29)
[packages/bash.git] / bash.spec
1 # TODO:
2 # - patch 001 (ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-001)
3 # - broken octal mode in echo if first digit is non-zero (e.g. \137, breaks mc on dirs containing '_')
4 #
5 # Conditional build:
6 %bcond_without  static          # don't build static version
7 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
8 %bcond_without  tests   # do not perform "make test"
9 ##
10 %define         _ver            3.2
11 %define         _patchlevel     000
12 #
13 Summary:        GNU Bourne Again Shell (bash)
14 Summary(fr):    Le shell Bourne Again de GNU
15 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
16 Name:           bash
17 Version:        %{_ver}
18 #.%{_patchlevel}
19 Release:        1%{?with_bash_history:inv}
20 License:        GPL
21 Group:          Applications/Shells
22 Source0:        ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
23 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
24 Source1:        %{name}rc
25 Source2:        %{name}-skel-.%{name}_logout
26 Source3:        %{name}-skel-.%{name}_profile
27 Source4:        %{name}-skel-.%{name}rc
28 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
29 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
30 Patch0:         %{name}-paths.patch
31 Patch1:         %{name}-security.patch
32 Patch2:         %{name}-autoconf.patch
33 Patch3:         %{name}-info.patch
34 Patch4:         %{name}-profile.patch
35 Patch5:         %{name}-requires.patch
36 Patch6:         %{name}-compat.patch
37 Patch8:         %{name}-sighup.patch
38 Patch9:         %{name}-backup_history.patch
39 Patch10:        %{name}-po.patch
40 Patch11:        %{name}-act_like_sh.patch
41 URL:            http://www.gnu.org/software/bash/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  bison
45 BuildRequires:  ncurses-devel >= 5.2
46 BuildRequires:  readline-devel >= 5.2
47 BuildRequires:  texinfo
48 %if %{with static}
49 # Require static library only for static build
50 BuildRequires:  glibc-static >= 2.2
51 BuildRequires:  ncurses-static >= 5.2
52 BuildRequires:  readline-static >= 5.2
53 %endif
54 Requires(post,preun):   grep
55 Requires(preun):        fileutils
56 Requires:       grep
57 Requires:       readline >= 5.2
58 Requires:       setup >= 2.4.6-2
59 Obsoletes:      bash-doc
60 Obsoletes:      bash2
61 Obsoletes:      bash2-doc
62 Obsoletes:      etcskel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Bash is a GNU project sh-compatible shell or command language
67 interpreter. Bash (Bourne Again shell) incorporates useful features
68 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
69 be run by bash without modification. Bash offers several improvements
70 over sh, including command line editing, unlimited size command
71 history, job control, shell functions and aliases, indexed arrays of
72 unlimited size and integer arithmetic in any base from two to 64. Bash
73 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
74 Shell and Tools standard. Bash is the default shell for Linux
75 Mandrake. You should install bash because of its popularity and power.
76 You'll probably end up using it.
77
78 %description -l es
79 Bash es un interpretador de comandos compatible con sh, que ejecuta
80 comandos leídos de la entrada padrón o de un archivo. Bash también
81 incorpora características útiles de las shells Korn y C (ksh y csh).
82 Bash ha sido desarrollado para ser una adición compatible con la
83 especificación IEEE Posix para shells y herramientas (IEEE Working
84 Group 1003.2).
85
86 %description -l de
87 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
88 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
89 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
90 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
91 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
92 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
93 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
94 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
95 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
96 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
97 Mandrake.
98
99 %description -l fr
100 Bash est un shell (interpréteur de commande) du projet GNU, compatible
101 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
102 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
103 plupart des scripts sh sont exécutables sans modifications. Bash
104 comprend nombre d'améliorations par rapport à sh : édition de la ligne
105 de commande, historique illimité, contrôle des processus
106 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
107 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
108 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
109 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
110 l'installer du fait de sa puissance et de sa popularité. Vous finirez
111 probablement par l'utiliser.
112
113 %description -l pl
114 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
115 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
116 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
117 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
118 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
119 historii poleceñ, funkcje i aliasy, indeksowane tablice
120 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
121 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
122 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
123
124 %description -l pt_BR
125 Bash é um interpretador de comandos compatível com sh, que executa
126 comandos lidos da entrada padrão ou de um arquivo. Bash também
127 incorpora características úteis das shells Korn e C (ksh e csh). Bash
128 tem sido desenvolvido para ser uma implementação compatível com a
129 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
130 1003.2).
131
132 %description -l ru
133 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
134 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
135 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
136 (ksh É csh).
137
138 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
139 Tools specification (IEEE Working Group 1003.2).
140
141 %description -l tr
142 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
143 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
144 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
145 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
146 uyumlu bir uygulama olarak tasarlanmýþtýr.
147
148 %description -l uk
149 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
150 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
151 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
152
153 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
154 Tools specification (IEEE Working Group 1003.2).
155
156 %package static
157 Summary:        Statically linked GNU Bourne Again Shell (bash)
158 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
159 Group:          Applications/Shells
160 Requires(post,preun):   grep
161 Requires(preun):        fileutils
162 Requires:       %{name} = %{version}-%{release}
163
164 %description static
165 Bash is a GNU project sh-compatible shell or command language
166 interpreter. Bash (Bourne Again shell) incorporates useful features
167 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
168 be run by bash without modification. Bash offers several improvements
169 over sh, including command line editing, unlimited size command
170 history, job control, shell functions and aliases, indexed arrays of
171 unlimited size and integer arithmetic in any base from two to 64. Bash
172 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
173 Shell and Tools standard. Bash is the default shell for Linux
174 Mandrake. You should install bash because of its popularity and power.
175 You'll probably end up using it. This package contains statically
176 linked version of bash.
177
178 %description static -l pl
179 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
180 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
181 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
182 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
183 tym pakiecie jest wersja basha skonsolidowana statycznie.
184
185 %prep
186 %setup -q -n %{name}-%{_ver} -a5
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p1
192 %patch5 -p1
193 %patch6 -p1
194 %patch8 -p1
195 %{?with_bash_history:%patch9 -p1}
196 %patch10 -p1
197 %patch11 -p1
198
199 %build
200 cp -f /usr/share/automake/config.* support
201 %{__autoconf}
202 for mode in %{?with_static:static} shared; do
203 %configure \
204         --enable-alias \
205         --enable-help-builtin \
206         --enable-history \
207         --enable-job-control \
208         --enable-restricted \
209         --enable-readline \
210         --with-curses \
211         --enable-extended-glob \
212         --enable-dparen-arithmetic \
213         --enable-separate-helpfiles \
214         --without-bash-malloc \
215         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
216         --with-installed-readline
217
218 %{__make} \
219         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
220
221 [ "$mode" = "static" ] && mv -f bash bash.static || :
222 done
223
224 %{?with_tests:%{__make} tests}
225
226 %install
227 rm -rf $RPM_BUILD_ROOT
228 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
229 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
230
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
235 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
236
237 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
238 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
239
240 for d in es fr it ja ko nl pl ; do
241         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
242         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
243         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
244 done
245
246 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
247
248 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
249 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
250 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
251 rm -f $RPM_BUILD_ROOT/usr/share/info/dir
252
253 %find_lang %{name}
254
255 %clean
256 rm -rf $RPM_BUILD_ROOT
257
258 %post
259 umask 022
260 if [ ! -f /etc/shells ]; then
261         echo "/bin/bash" > /etc/shells
262         echo "/bin/rbash" >> /etc/shells
263 else
264         if ! grep -q '^/bin/bash$' /etc/shells; then
265                 echo "/bin/bash" >> /etc/shells
266         fi
267         if ! grep -q '^/bin/rbash$' /etc/shells; then
268                 echo "/bin/rbash" >> /etc/shells
269         fi
270 fi
271
272 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
273
274 %preun
275 if [ "$1" = "0" ]; then
276         umask 022
277         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
278         mv -f /etc/shells.new /etc/shells
279 fi
280
281 %post static
282 umask 022
283 if [ ! -f /etc/shells ]; then
284         echo "/bin/bash.static" > /etc/shells
285 else
286         if ! grep -q '^/bin/bash.static$' /etc/shells; then
287                 echo "/bin/bash.static" >> /etc/shells
288         fi
289 fi
290
291 %preun static
292 if [ "$1" = "0" ]; then
293         umask 022
294         grep -v /bin/bash.static /etc/shells > /etc/shells.new
295         mv -f /etc/shells.new /etc/shells
296 fi
297
298 %postun
299 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
300
301 %files -f %{name}.lang
302 %defattr(644,root,root,755)
303 %doc CHANGES NEWS README doc/{FAQ,INTRO}
304
305 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
306 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
307 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
308 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
309
310 %attr(755,root,root) /bin/bash
311 %attr(755,root,root) /bin/rbash
312 %attr(755,root,root) %{_bindir}/bashbug
313
314 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
315 %{_infodir}/bash.info*
316 %{_mandir}/man1/*
317 %lang(es) %{_mandir}/es/man1/*
318 %lang(fr) %{_mandir}/fr/man1/*
319 %lang(it) %{_mandir}/it/man1/*
320 %lang(ja) %{_mandir}/ja/man1/*
321 %lang(ko) %{_mandir}/ko/man1/*
322 %lang(nl) %{_mandir}/nl/man1/*
323 %lang(pl) %{_mandir}/pl/man1/*
324 %{_datadir}/%{name}
325
326 %if %{with static}
327 %files static
328 %defattr(644,root,root,755)
329 %attr(755,root,root) /bin/bash.static
330 %endif
This page took 0.059068 seconds and 4 git commands to generate.