]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
note about sources file
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6
7 # NOTE: when updating patchleve, do not forget to update 'sources' file!
8 %define         ver             4.3
9 %define         patchlevel      11
10 %define         rel             1
11 Summary:        GNU Bourne Again Shell (bash)
12 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
13 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
14 Name:           bash
15 Version:        %{ver}%{?patchlevel:.%{patchlevel}}
16 Release:        %{rel}%{?with_bash_history:inv}
17 License:        GPL
18 Group:          Applications/Shells
19 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
20 # Source0-md5:  81348932d5da294953e15d4814c74dd1
21 Source1:        %{name}rc
22 Source2:        %{name}-skel-.bash_logout
23 Source3:        %{name}-skel-.bash_profile
24 Source4:        %{name}-skel-.bashrc
25 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
26 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
27 Patch0:         %{name}-paths.patch
28 Patch1:         %{name}-security.patch
29 Patch2:         %{name}-autoconf.patch
30 Patch3:         %{name}-info.patch
31 Patch4:         %{name}-profile.patch
32 Patch5:         %{name}-requires.patch
33 Patch6:         %{name}-compat.patch
34 Patch8:         %{name}-sighup.patch
35 Patch9:         %{name}-backup_history.patch
36 Patch10:        %{name}-act_like_sh.patch
37 Patch11:        %{name}-elinks_cont.patch
38 Patch12:        %{name}-pl.po-update.patch
39 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
40 URL:            http://www.gnu.org/software/bash/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  bison
44 BuildRequires:  ncurses-devel >= 5.2
45 BuildRequires:  readline-devel >= 6.3
46 BuildRequires:  rpmbuild(macros) >= 1.462
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  texinfo
49 %if %{with static}
50 # Require static library only for static build
51 BuildRequires:  glibc-static >= 2.2
52 BuildRequires:  ncurses-static >= 5.2
53 BuildRequires:  readline-static >= 6.3
54 %endif
55 Requires:       readline >= 6.3
56 Requires:       setup >= 2.4.6-2
57 Obsoletes:      bash-doc
58 Obsoletes:      bash2
59 Obsoletes:      bash2-doc
60 Obsoletes:      etcskel
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Bash is a GNU project sh-compatible shell or command language
65 interpreter. Bash (Bourne Again shell) incorporates useful features
66 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
67 be run by bash without modification. Bash offers several improvements
68 over sh, including command line editing, unlimited size command
69 history, job control, shell functions and aliases, indexed arrays of
70 unlimited size and integer arithmetic in any base from two to 64. Bash
71 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
72 Shell and Tools standard. Bash is the default shell for Linux
73 Mandrake. You should install bash because of its popularity and power.
74 You'll probably end up using it.
75
76 %description -l es.UTF-8
77 Bash es un interpretador de comandos compatible con sh, que ejecuta
78 comandos leídos de la entrada padrón o de un archivo. Bash también
79 incorpora características útiles de las shells Korn y C (ksh y csh).
80 Bash ha sido desarrollado para ser una adición compatible con la
81 especificación IEEE Posix para shells y herramientas (IEEE Working
82 Group 1003.2).
83
84 %description -l de.UTF-8
85 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
86 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
87 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
88 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
89 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
90 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
91 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
92 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
93 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
94 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
95 Mandrake.
96
97 %description -l fr.UTF-8
98 Bash est un shell (interpréteur de commande) du projet GNU, compatible
99 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
100 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
101 plupart des scripts sh sont exécutables sans modifications. Bash
102 comprend nombre d'améliorations par rapport à sh : édition de la ligne
103 de commande, historique illimité, contrôle des processus
104 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
105 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
106 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
107 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
108 l'installer du fait de sa puissance et de sa popularité. Vous finirez
109 probablement par l'utiliser.
110
111 %description -l pl.UTF-8
112 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
113 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
114 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
115 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
116 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
117 historii poleceń, funkcje i aliasy, indeksowane tablice
118 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
119 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
120 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
121
122 %description -l pt_BR.UTF-8
123 Bash é um interpretador de comandos compatível com sh, que executa
124 comandos lidos da entrada padrão ou de um arquivo. Bash também
125 incorpora características úteis das shells Korn e C (ksh e csh). Bash
126 tem sido desenvolvido para ser uma implementação compatível com a
127 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
128 1003.2).
129
130 %description -l ru.UTF-8
131 Bash - это sh-совместимый интерпретатор командного языка (shell),
132 исполняющий команды, поступающие со стандартного ввода или из файла.
133 Bash включает полезные расширения из интерпретаторов Korn и C shell
134 (ksh и csh).
135
136 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
137 Tools specification (IEEE Working Group 1003.2).
138
139 %description -l tr.UTF-8
140 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
141 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
142 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
143 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
144 uyumlu bir uygulama olarak tasarlanmıştır.
145
146 %description -l uk.UTF-8
147 Bash - це sh-сумістний інтерпретатор командної мови (shell),
148 виконуючий команди зі стандартного вводу або з файла. Bash містить
149 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
150
151 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
152 Tools specification (IEEE Working Group 1003.2).
153
154 %package static
155 Summary:        Statically linked GNU Bourne Again Shell (bash)
156 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
157 Group:          Applications/Shells
158 Requires:       %{name} = %{version}-%{release}
159
160 %description static
161 Bash is a GNU project sh-compatible shell or command language
162 interpreter. Bash (Bourne Again shell) incorporates useful features
163 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
164 be run by bash without modification. Bash offers several improvements
165 over sh, including command line editing, unlimited size command
166 history, job control, shell functions and aliases, indexed arrays of
167 unlimited size and integer arithmetic in any base from two to 64. Bash
168 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
169 Shell and Tools standard. Bash is the default shell for Linux
170 Mandrake. You should install bash because of its popularity and power.
171 You'll probably end up using it. This package contains statically
172 linked version of bash.
173
174 %description static -l pl.UTF-8
175 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
176 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
177 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
178 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
179 tym pakiecie jest wersja basha skonsolidowana statycznie.
180
181 %prep
182 %setup -q -n %{name}-%{ver} -a5
183 # official patches
184 %{?patchlevel:%patchset_patch 1 %{patchlevel}}
185 %patch0 -p1
186 %patch1 -p1
187 %patch2 -p1
188 %patch3 -p1
189 %patch4 -p1
190 %patch5 -p1
191 %patch6 -p1
192 %patch8 -p1
193 %{?with_bash_history:%patch9 -p1}
194 %patch10 -p1
195 %patch11 -p1
196 %patch12 -p1
197
198 %build
199 cp -f /usr/share/automake/config.* support
200 %{__autoconf}
201 for mode in %{?with_static:static} shared; do
202 %configure \
203         --enable-alias \
204         --enable-help-builtin \
205         --enable-history \
206         --enable-job-control \
207         --enable-restricted \
208         --enable-readline \
209         --with-curses \
210         --enable-extended-glob \
211         --enable-dparen-arithmetic \
212         --enable-separate-helpfiles \
213         --without-bash-malloc \
214         $([ "$mode" = "static" ] && echo "--enable-static-link") \
215         --with-installed-readline
216
217 %{__make} \
218         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
219
220 [ "$mode" = "static" ] && mv -f bash bash.static
221 done
222
223 %{?with_tests:%{__make} tests}
224
225 %install
226 rm -rf $RPM_BUILD_ROOT
227 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
228 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
229
230 %{__make} install \
231         DESTDIR=$RPM_BUILD_ROOT
232
233 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
234 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
235
236 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
237 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
238
239 for d in es fr it ja ko nl pl ; do
240         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
241         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
242         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
243 done
244
245 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
246
247 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
248 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
249 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
250 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
251
252 # use our bugtracker, upstream will ignore reports from this anyway
253 rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
254
255 %find_lang %{name}
256
257 %clean
258 rm -rf $RPM_BUILD_ROOT
259
260 %post   -p <lua>
261 %lua_add_etc_shells /bin/bash /bin/rbash
262 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
263
264 %preun  -p <lua>
265 if arg[2] == 0 then
266         %lua_remove_etc_shells /bin/bash /bin/rbash
267 end
268
269 %postun -p      /sbin/postshell
270 -/usr/sbin/fix-info-dir -c %{_infodir}
271
272 %post static -p <lua>
273 %lua_add_etc_shells /bin/bash.static
274
275 %preun static -p <lua>
276 if arg[2] == 0 then
277         %lua_remove_etc_shells /bin/bash.static
278 end
279
280 %files -f %{name}.lang
281 %defattr(644,root,root,755)
282 %doc CHANGES NEWS README doc/{FAQ,INTRO}
283
284 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
285 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
286 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
287 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
288
289 %attr(755,root,root) /bin/bash
290 %attr(755,root,root) /bin/rbash
291
292 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
293 %{_infodir}/bash.info*
294 %{_mandir}/man1/*
295 %lang(es) %{_mandir}/es/man1/*
296 %lang(fr) %{_mandir}/fr/man1/*
297 %lang(it) %{_mandir}/it/man1/*
298 %lang(ja) %{_mandir}/ja/man1/*
299 %lang(ko) %{_mandir}/ko/man1/*
300 %lang(nl) %{_mandir}/nl/man1/*
301 %lang(pl) %{_mandir}/pl/man1/*
302 %dir %{_datadir}/%{name}
303 %doc %{_datadir}/%{name}/*
304
305 %if %{with static}
306 %files static
307 %defattr(644,root,root,755)
308 %attr(755,root,root) /bin/bash.static
309 %endif
This page took 0.067807 seconds and 4 git commands to generate.