]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- many small fixes, inspired by kloczek
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 # _without_static - don't build static version
4 # _with_bash_history - build with additional history in /var/log/hist ;)
5 #
6 Summary:        GNU Bourne Again Shell (bash)
7 Summary(es):    GNU Bourne Again Shell (bash)
8 Summary(fr):    Le shell Bourne Again de GNU
9 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
10 Summary(pt_BR): GNU Bourne Again Shell (bash)
11 Summary(ru):    GNU Bourne Again Shell (bash)
12 Summary(uk):    GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        2.05b
15 Release:        9%{?_with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/pub/gnu/bash/%{name}-%{version}.tar.gz
19 # Source0-md5: 5238251b4926d778dfe162f6ce729733
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5: d2aacf89c4a444c5da648da69afdb01a
26 Patch0:         %{name}-paths.patch
27 Patch1:         %{name}-security.patch
28 Patch2:         %{name}-autoconf.patch
29 Patch3:         %{name}-info.patch
30 Patch4:         %{name}-profile.patch
31 Patch5:         %{name}-requires.patch
32 Patch6:         %{name}-compat.patch
33 Patch7:         %{name}-shellfunc.patch
34 Patch8:         %{name}-DESTDIR.patch
35 Patch9:         %{name}-rlimit_locks.patch
36 Patch10:        %{name}-sighup.patch
37 %{?_with_bash_history:Patch11:bash-backup_history.patch}
38 Patch12:        ftp://ftp.gnu.org/pub/gnu/bash/bash-2.05b-patches/bash205b-001
39 Patch13:        ftp://ftp.gnu.org/pub/gnu/bash/bash-2.05b-patches/bash205b-002
40 Patch14:        ftp://ftp.gnu.org/pub/gnu/bash/bash-2.05b-patches/bash205b-003
41 Patch15:        ftp://ftp.gnu.org/pub/gnu/bash/bash-2.05b-patches/bash205b-004
42 Patch16:        %{name}-pmake.patch
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  bison
46 BuildRequires:  glibc-devel >= 2.2
47 BuildRequires:  ncurses-devel >= 5.2
48 BuildRequires:  readline-devel >= 4.2
49 BuildRequires:  texinfo
50 %if %{!?_without_static:1}%{?_without_static:0}
51 # Require static library only for static build
52 BuildRequires:  glibc-static >= 2.2
53 BuildRequires:  ncurses-static >= 5.2
54 BuildRequires:  readline-static >= 4.3
55 %endif
56 Requires(post,preun):   grep
57 Requires(preun):        fileutils
58 Requires:       readline >= 4.3
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60 Obsoletes:      bash-doc
61 Obsoletes:      bash2
62 Obsoletes:      bash2-doc
63 Obsoletes:      etcskel
64
65 %description
66 Bash is a GNU project sh-compatible shell or command language
67 interpreter. Bash (Bourne Again shell) incorporates useful features
68 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
69 be run by bash without modification. Bash offers several improvements
70 over sh, including command line editing, unlimited size command
71 history, job control, shell functions and aliases, indexed arrays of
72 unlimited size and integer arithmetic in any base from two to 64. Bash
73 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
74 Shell and Tools standard. Bash is the default shell for Linux
75 Mandrake. You should install bash because of its popularity and power.
76 You'll probably end up using it.
77
78 %description -l es
79 Bash es un interpretador de comandos compatible con sh, que ejecuta
80 comandos leídos de la entrada padrón o de un archivo. Bash también
81 incorpora características útiles de las shells Korn y C (ksh y csh).
82 Bash ha sido desarrollado para ser una adición compatible con la
83 especificación IEEE Posix para shells y herramientas (IEEE Working
84 Group 1003.2).
85
86 %description -l de
87 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
88 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
89 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
90 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
91 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
92 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
93 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
94 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
95 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
96 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
97 Mandrake.
98
99 %description -l fr
100 Bash est un shell (interpréteur de commande) du projet GNU, compatible
101 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
102 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
103 plupart des scripts sh sont exécutables sans modifications. Bash
104 comprend nombre d'améliorations par rapport à sh : édition de la ligne
105 de commande, historique illimité, contrôle des processus
106 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
107 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
108 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
109 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
110 l'installer du fait de sa puissance et de sa popularité. Vous finirez
111 probablement par l'utiliser.
112
113 %description -l pl
114 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
115 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
116 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
117 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
118 stusunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
119 historii poleceñ, funkcje i aliasy, indeksowane tablice
120 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
121 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
122 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
123
124 %description -l pt_BR
125 Bash é um interpretador de comandos compatível com sh, que executa
126 comandos lidos da entrada padrão ou de um arquivo. Bash também
127 incorpora características úteis das shells Korn e C (ksh e csh). Bash
128 tem sido desenvolvido para ser uma implementação compatível com a
129 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
130 1003.2).
131
132 %description -l ru
133 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
134 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
135 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
136 (ksh É csh).
137
138 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
139 Tools specification (IEEE Working Group 1003.2).
140
141 %description -l tr
142 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
143 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
144 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
145 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
146 uyumlu bir uygulama olarak tasarlanmýþtýr.
147
148 %description -l uk
149 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
150 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
151 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
152
153 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
154 Tools specification (IEEE Working Group 1003.2).
155
156 %package static
157 Summary:        Statically linked GNU Bourne Again Shell (bash)
158 Summary(pl):    Statycznie zlinkowany GNU Bourne Again Shell (bash)
159 Group:          Applications/Shells
160 Requires:       %{name}
161 Requires(post,preun):   grep
162 Requires(preun):        fileutils
163
164 %description static
165 Bash is a GNU project sh-compatible shell or command language
166 interpreter. Bash (Bourne Again shell) incorporates useful features
167 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
168 be run by bash without modification. Bash offers several improvements
169 over sh, including command line editing, unlimited size command
170 history, job control, shell functions and aliases, indexed arrays of
171 unlimited size and integer arithmetic in any base from two to 64. Bash
172 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
173 Shell and Tools standard. Bash is the default shell for Linux
174 Mandrake. You should install bash because of its popularity and power.
175 You'll probably end up using it. This package contains statically
176 linked version of bash.
177
178 %description static -l pl
179 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
180 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
181 Korn i C (ksh i csh). Bash ma równie¿ zaimplementowany IEEE Posix
182 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
183 tym pakiecie jest statycznie zlinkowany bash.
184
185 %prep
186 %setup -q -a5
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p1
192 %patch5 -p1
193 %patch6 -p1
194 %patch7 -p1
195 %patch8 -p1
196 %patch9 -p1
197 %patch10 -p1
198 %{?_with_bash_history:%patch11 -p1}
199 %patch12 -p0
200 %patch13 -p0
201 %patch14 -p0
202 %patch15 -p0
203 %patch16 -p1
204
205 echo %{version} > _distribution
206 echo %{release} > _patchlevel
207
208 %build
209 %{__autoconf}
210 cp -f /usr/share/automake/config.* support/
211 for mode in %{!?_without_static:static} shared; do
212 %configure \
213         --enable-alias \
214         --enable-help-builtin \
215         --enable-history \
216         --enable-job-control \
217         --enable-restricted \
218         --enable-readline \
219         --with-curses \
220         --enable-extended-glob \
221         --enable-dparen-arithmetic \
222         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
223         --with-installed-readline
224
225 %{__make} DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
226
227 [ "$mode" = "static" ] && mv -f bash bash.static || :
228 done
229
230 %install
231 rm -rf $RPM_BUILD_ROOT
232 install -d $RPM_BUILD_ROOT/{bin,etc/skel}
233 %{?_with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
239 %{?_without_static:#}install    bash.static $RPM_BUILD_ROOT/bin
240
241 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
242 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
243
244 for d in es fr it ja ko nl pl ; do
245         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
246         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
247         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
248 done
249
250 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
251
252 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
253 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
254 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
255
256 %clean
257 rm -rf $RPM_BUILD_ROOT
258
259 %post
260 umask 022
261 if [ ! -f /etc/shells ]; then
262         echo "/bin/bash" > /etc/shells
263         echo "/bin/rbash" >> /etc/shells
264 else
265         if ! grep -q '^/bin/bash$' /etc/shells; then
266                 echo "/bin/bash" >> /etc/shells
267         fi
268         if ! grep -q '^/bin/rbash$' /etc/shells; then
269                 echo "/bin/rbash" >> /etc/shells
270         fi
271 fi
272
273 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
274
275 %preun
276 if [ "$1" = "0" ]; then
277         umask 022
278         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
279         mv -f /etc/shells.new /etc/shells
280 fi
281
282 %post static
283 umask 022
284 if [ ! -f /etc/shells ]; then
285         echo "/bin/bash.static" > /etc/shells
286 else
287         if ! grep -q '^/bin/bash.static$' /etc/shells; then
288                 echo "/bin/bash.static" >> /etc/shells
289         fi
290 fi
291
292 %preun static
293 if [ "$1" = "0" ]; then
294         umask 022
295         grep -v /bin/bash.static /etc/shells > /etc/shells.new
296         mv -f /etc/shells.new /etc/shells
297 fi
298
299 %postun
300 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
301
302 %files
303 %defattr(644,root,root,755)
304 %doc NEWS README doc/{FAQ,INTRO}
305
306 %config %verify(not md5 size mtime) %{_sysconfdir}/bashrc
307 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bash_logout
308 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bash_profile
309 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bashrc
310
311 %attr(755,root,root) /bin/bash
312 %attr(755,root,root) /bin/rbash
313 %attr(755,root,root) %{_bindir}/bashbug
314
315 %{?_with_bash_history:%attr(751,root,root) %dir /var/log/bash_hist}
316 %{_infodir}/bash.info*
317 %{_mandir}/man1/*
318 %lang(es) %{_mandir}/es/man1/*
319 %lang(fr) %{_mandir}/fr/man1/*
320 %lang(it) %{_mandir}/it/man1/*
321 %lang(ja) %{_mandir}/ja/man1/*
322 %lang(ko) %{_mandir}/ko/man1/*
323 %lang(nl) %{_mandir}/nl/man1/*
324 %lang(pl) %{_mandir}/pl/man1/*
325
326 %{?_without_static:#}%files static
327 %{?_without_static:#}%defattr(644,root,root,755)
328 %{?_without_static:#}%attr(755,root,root) /bin/bash.static
This page took 0.076248 seconds and 4 git commands to generate.