]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
d3bcaf7fc18e189f8fc262c53f329902575fdda8
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %define         _ver            3.2
8 %define         _patchlevel     9
9 %define         _rel    1
10 Summary:        GNU Bourne Again Shell (bash)
11 Summary(fr):    Le shell Bourne Again de GNU
12 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        %{_ver}.%{_patchlevel}
15 Release:        %{_rel}%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
19 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 Patch0:         %{name}-paths.patch
27 Patch1:         %{name}-security.patch
28 Patch2:         %{name}-autoconf.patch
29 Patch3:         %{name}-info.patch
30 Patch4:         %{name}-profile.patch
31 Patch5:         %{name}-requires.patch
32 Patch6:         %{name}-compat.patch
33 Patch8:         %{name}-sighup.patch
34 Patch9:         %{name}-backup_history.patch
35 Patch10:        %{name}-act_like_sh.patch
36 %patchset_source -f ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{_patchlevel}
37 URL:            http://www.gnu.org/software/bash/
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  bison
41 BuildRequires:  ncurses-devel >= 5.2
42 BuildRequires:  readline-devel >= 5.2
43 BuildRequires:  rpmbuild(macros) >= 1.353
44 BuildRequires:  texinfo
45 %if %{with static}
46 # Require static library only for static build
47 BuildRequires:  glibc-static >= 2.2
48 BuildRequires:  ncurses-static >= 5.2
49 BuildRequires:  readline-static >= 5.2
50 %endif
51 Requires(post,preun):   grep
52 Requires(preun):        fileutils
53 Requires:       grep
54 Requires:       readline >= 5.2
55 Requires:       setup >= 2.4.6-2
56 Obsoletes:      bash-doc
57 Obsoletes:      bash2
58 Obsoletes:      bash2-doc
59 Obsoletes:      etcskel
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Bash is a GNU project sh-compatible shell or command language
64 interpreter. Bash (Bourne Again shell) incorporates useful features
65 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
66 be run by bash without modification. Bash offers several improvements
67 over sh, including command line editing, unlimited size command
68 history, job control, shell functions and aliases, indexed arrays of
69 unlimited size and integer arithmetic in any base from two to 64. Bash
70 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
71 Shell and Tools standard. Bash is the default shell for Linux
72 Mandrake. You should install bash because of its popularity and power.
73 You'll probably end up using it.
74
75 %description -l es
76 Bash es un interpretador de comandos compatible con sh, que ejecuta
77 comandos leídos de la entrada padrón o de un archivo. Bash también
78 incorpora características útiles de las shells Korn y C (ksh y csh).
79 Bash ha sido desarrollado para ser una adición compatible con la
80 especificación IEEE Posix para shells y herramientas (IEEE Working
81 Group 1003.2).
82
83 %description -l de
84 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
85 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
86 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
87 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
88 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
89 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
90 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
91 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
92 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
93 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
94 Mandrake.
95
96 %description -l fr
97 Bash est un shell (interpréteur de commande) du projet GNU, compatible
98 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
99 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
100 plupart des scripts sh sont exécutables sans modifications. Bash
101 comprend nombre d'améliorations par rapport à sh : édition de la ligne
102 de commande, historique illimité, contrôle des processus
103 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
104 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
105 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
106 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
107 l'installer du fait de sa puissance et de sa popularité. Vous finirez
108 probablement par l'utiliser.
109
110 %description -l pl
111 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
112 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
113 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
114 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
115 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
116 historii poleceñ, funkcje i aliasy, indeksowane tablice
117 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
118 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
119 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
120
121 %description -l pt_BR
122 Bash é um interpretador de comandos compatível com sh, que executa
123 comandos lidos da entrada padrão ou de um arquivo. Bash também
124 incorpora características úteis das shells Korn e C (ksh e csh). Bash
125 tem sido desenvolvido para ser uma implementação compatível com a
126 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
127 1003.2).
128
129 %description -l ru
130 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
131 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
132 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
133 (ksh É csh).
134
135 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
136 Tools specification (IEEE Working Group 1003.2).
137
138 %description -l tr
139 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
140 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
141 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
142 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
143 uyumlu bir uygulama olarak tasarlanmýþtýr.
144
145 %description -l uk
146 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
147 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
148 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
149
150 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
151 Tools specification (IEEE Working Group 1003.2).
152
153 %package static
154 Summary:        Statically linked GNU Bourne Again Shell (bash)
155 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
156 Group:          Applications/Shells
157 Requires(post,preun):   grep
158 Requires(preun):        fileutils
159 Requires:       %{name} = %{version}-%{release}
160
161 %description static
162 Bash is a GNU project sh-compatible shell or command language
163 interpreter. Bash (Bourne Again shell) incorporates useful features
164 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
165 be run by bash without modification. Bash offers several improvements
166 over sh, including command line editing, unlimited size command
167 history, job control, shell functions and aliases, indexed arrays of
168 unlimited size and integer arithmetic in any base from two to 64. Bash
169 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
170 Shell and Tools standard. Bash is the default shell for Linux
171 Mandrake. You should install bash because of its popularity and power.
172 You'll probably end up using it. This package contains statically
173 linked version of bash.
174
175 %description static -l pl
176 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
177 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
178 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
179 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
180 tym pakiecie jest wersja basha skonsolidowana statycznie.
181
182 %prep
183 %setup -q -n %{name}-%{_ver} -a5
184 # official patches
185 %patchset_patch 1 %{_patchlevel}
186 %patch0 -p1
187 %patch1 -p1
188 %patch2 -p1
189 %patch3 -p1
190 %patch4 -p1
191 %patch5 -p1
192 %patch6 -p1
193 %patch8 -p1
194 %{?with_bash_history:%patch9 -p1}
195 %patch10 -p1
196
197 %build
198 cp -f /usr/share/automake/config.* support
199 %{__autoconf}
200 for mode in %{?with_static:static} shared; do
201 %configure \
202         --enable-alias \
203         --enable-help-builtin \
204         --enable-history \
205         --enable-job-control \
206         --enable-restricted \
207         --enable-readline \
208         --with-curses \
209         --enable-extended-glob \
210         --enable-dparen-arithmetic \
211         --enable-separate-helpfiles \
212         --without-bash-malloc \
213         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
214         --with-installed-readline
215
216 %{__make} \
217         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
218
219 [ "$mode" = "static" ] && mv -f bash bash.static || :
220 done
221
222 %{?with_tests:%{__make} tests}
223
224 %install
225 rm -rf $RPM_BUILD_ROOT
226 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
227 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
228
229 %{__make} install \
230         DESTDIR=$RPM_BUILD_ROOT
231
232 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
233 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
234
235 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
236 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
237
238 for d in es fr it ja ko nl pl ; do
239         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
240         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
241         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
242 done
243
244 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
245
246 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
247 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
248 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
249 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
250
251 %find_lang %{name}
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %post
257 umask 022
258 if [ ! -f /etc/shells ]; then
259         echo "/bin/bash" > /etc/shells
260         echo "/bin/rbash" >> /etc/shells
261 else
262         if ! grep -q '^/bin/bash$' /etc/shells; then
263                 echo "/bin/bash" >> /etc/shells
264         fi
265         if ! grep -q '^/bin/rbash$' /etc/shells; then
266                 echo "/bin/rbash" >> /etc/shells
267         fi
268 fi
269
270 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
271
272 %preun
273 if [ "$1" = "0" ]; then
274         umask 022
275         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
276         mv -f /etc/shells.new /etc/shells
277 fi
278
279 %post static
280 umask 022
281 if [ ! -f /etc/shells ]; then
282         echo "/bin/bash.static" > /etc/shells
283 else
284         if ! grep -q '^/bin/bash.static$' /etc/shells; then
285                 echo "/bin/bash.static" >> /etc/shells
286         fi
287 fi
288
289 %preun static
290 if [ "$1" = "0" ]; then
291         umask 022
292         grep -v /bin/bash.static /etc/shells > /etc/shells.new
293         mv -f /etc/shells.new /etc/shells
294 fi
295
296 %postun
297 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
298
299 %files -f %{name}.lang
300 %defattr(644,root,root,755)
301 %doc CHANGES NEWS README doc/{FAQ,INTRO}
302
303 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
304 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
305 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
306 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
307
308 %attr(755,root,root) /bin/bash
309 %attr(755,root,root) /bin/rbash
310 %attr(755,root,root) %{_bindir}/bashbug
311
312 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
313 %{_infodir}/bash.info*
314 %{_mandir}/man1/*
315 %lang(es) %{_mandir}/es/man1/*
316 %lang(fr) %{_mandir}/fr/man1/*
317 %lang(it) %{_mandir}/it/man1/*
318 %lang(ja) %{_mandir}/ja/man1/*
319 %lang(ko) %{_mandir}/ko/man1/*
320 %lang(nl) %{_mandir}/nl/man1/*
321 %lang(pl) %{_mandir}/pl/man1/*
322 %{_datadir}/%{name}
323
324 %if %{with static}
325 %files static
326 %defattr(644,root,root,755)
327 %attr(755,root,root) /bin/bash.static
328 %endif
This page took 0.058667 seconds and 2 git commands to generate.