]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
7b2c6832fa527d24352f513b11d06cff2f3ce13d
[packages/bash.git] / bash.spec
1 # NOTE: when updating patchlevel, do not forget to update 'sources' file:
2 # $ md5sum bash44-??? > sources
3 #
4 # Conditional build:
5 %bcond_without  static          # don't build static version
6 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
7 %bcond_without  tests   # do not perform "make test"
8
9 %define         ver             5.1
10 %define         patchlevel      0
11 %define         rel             1
12 %define         min_readline    8.1
13 Summary:        GNU Bourne Again Shell (bash)
14 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
15 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
16 Name:           bash
17 Version:        %{ver}%{?patchlevel:.%{patchlevel}}
18 Release:        %{rel}%{?with_bash_history:inv}
19 License:        GPL v3+
20 Group:          Applications/Shells
21 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
22 # Source0-md5:  bb91a17fd6c9032c26d0b2b78b50aff5
23 Source1:        %{name}rc
24 Source2:        %{name}-skel-.bash_logout
25 Source3:        %{name}-skel-.bash_profile
26 Source4:        %{name}-skel-.bashrc
27 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
28 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
29 Patch0:         %{name}-paths.patch
30 Patch1:         %{name}-security.patch
31 Patch2:         %{name}-autoconf.patch
32 Patch3:         %{name}-info.patch
33 Patch4:         %{name}-profile.patch
34 Patch5:         %{name}-requires.patch
35 Patch6:         %{name}-compat.patch
36 Patch7:         %{name}-loadables.patch
37 Patch8:         %{name}-sighup.patch
38 Patch9:         %{name}-backup_history.patch
39 Patch10:        %{name}-act_like_sh.patch
40 Patch11:        %{name}-elinks_cont.patch
41 Patch12:        bash-5.1-parallel_make.patch
42 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-%03g 1 %{patchlevel}
43 URL:            http://www.gnu.org/software/bash/
44 BuildRequires:  autoconf >= 2.61
45 BuildRequires:  automake
46 BuildRequires:  bison
47 BuildRequires:  ncurses-devel >= 5.2
48 BuildRequires:  readline-devel >= %{min_readline}
49 BuildRequires:  rpmbuild(macros) >= 1.462
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  texinfo
52 %if %{with static}
53 # Require static library only for static build
54 BuildRequires:  glibc-static >= 2.2
55 BuildRequires:  ncurses-static >= 5.2
56 BuildRequires:  readline-static >= %{min_readline}
57 %endif
58 Requires:       readline >= %{min_readline}
59 Requires:       setup >= 2.4.6-2
60 Obsoletes:      bash-doc
61 Obsoletes:      bash2
62 Obsoletes:      bash2-doc
63 Obsoletes:      etcskel
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Bash is a GNU project sh-compatible shell or command language
68 interpreter. Bash (Bourne Again shell) incorporates useful features
69 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
70 be run by bash without modification. Bash offers several improvements
71 over sh, including command line editing, unlimited size command
72 history, job control, shell functions and aliases, indexed arrays of
73 unlimited size and integer arithmetic in any base from two to 64. Bash
74 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
75 Shell and Tools standard. Bash is the default shell for Linux
76 Mandrake. You should install bash because of its popularity and power.
77 You'll probably end up using it.
78
79 %description -l es.UTF-8
80 Bash es un interpretador de comandos compatible con sh, que ejecuta
81 comandos leídos de la entrada padrón o de un archivo. Bash también
82 incorpora características útiles de las shells Korn y C (ksh y csh).
83 Bash ha sido desarrollado para ser una adición compatible con la
84 especificación IEEE Posix para shells y herramientas (IEEE Working
85 Group 1003.2).
86
87 %description -l de.UTF-8
88 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
89 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
90 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
91 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
92 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
93 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
94 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
95 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
96 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
97 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
98 Mandrake.
99
100 %description -l fr.UTF-8
101 Bash est un shell (interpréteur de commande) du projet GNU, compatible
102 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
103 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
104 plupart des scripts sh sont exécutables sans modifications. Bash
105 comprend nombre d'améliorations par rapport à sh : édition de la ligne
106 de commande, historique illimité, contrôle des processus
107 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
108 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
109 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
110 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
111 l'installer du fait de sa puissance et de sa popularité. Vous finirez
112 probablement par l'utiliser.
113
114 %description -l pl.UTF-8
115 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
116 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
117 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
118 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
119 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
120 historii poleceń, funkcje i aliasy, indeksowane tablice
121 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
122 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
123 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
124
125 %description -l pt_BR.UTF-8
126 Bash é um interpretador de comandos compatível com sh, que executa
127 comandos lidos da entrada padrão ou de um arquivo. Bash também
128 incorpora características úteis das shells Korn e C (ksh e csh). Bash
129 tem sido desenvolvido para ser uma implementação compatível com a
130 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
131 1003.2).
132
133 %description -l ru.UTF-8
134 Bash - это sh-совместимый интерпретатор командного языка (shell),
135 исполняющий команды, поступающие со стандартного ввода или из файла.
136 Bash включает полезные расширения из интерпретаторов Korn и C shell
137 (ksh и csh).
138
139 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
140 Tools specification (IEEE Working Group 1003.2).
141
142 %description -l tr.UTF-8
143 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
144 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
145 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
146 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
147 uyumlu bir uygulama olarak tasarlanmıştır.
148
149 %description -l uk.UTF-8
150 Bash - це sh-сумістний інтерпретатор командної мови (shell),
151 виконуючий команди зі стандартного вводу або з файла. Bash містить
152 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
153
154 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
155 Tools specification (IEEE Working Group 1003.2).
156
157 %package static
158 Summary:        Statically linked GNU Bourne Again Shell (bash)
159 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
160 Group:          Applications/Shells
161 Requires:       %{name} = %{version}-%{release}
162
163 %description static
164 Bash is a GNU project sh-compatible shell or command language
165 interpreter. Bash (Bourne Again shell) incorporates useful features
166 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
167 be run by bash without modification. Bash offers several improvements
168 over sh, including command line editing, unlimited size command
169 history, job control, shell functions and aliases, indexed arrays of
170 unlimited size and integer arithmetic in any base from two to 64. Bash
171 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
172 Shell and Tools standard. Bash is the default shell for Linux
173 Mandrake. You should install bash because of its popularity and power.
174 You'll probably end up using it. This package contains statically
175 linked version of bash.
176
177 %description static -l pl.UTF-8
178 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
179 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
180 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
181 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
182 tym pakiecie jest wersja basha skonsolidowana statycznie.
183
184 %package devel
185 Summary:        Header files for bash plugins development
186 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek basha
187 Group:          Development/Libraries
188 # doesn't require base
189
190 %description devel
191 Header files for bash plugins development.
192
193 %description devel -l pl.UTF-8
194 Pliki nagłówkowe do tworzenia wtyczek basha.
195
196 %prep
197 %setup -q -n %{name}-%{ver} -a5
198 # official patches
199 %{?patchlevel:%patchset_patch 1 %{patchlevel}}
200 %patch0 -p1
201 %patch1 -p1
202 %patch2 -p1
203 %patch3 -p1
204 %patch4 -p1
205 %patch5 -p1
206 %patch6 -p1
207 %patch7 -p1
208 %patch8 -p1
209 %{?with_bash_history:%patch9 -p1}
210 %patch10 -p1
211 %patch11 -p1
212 %patch12 -p1
213
214 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
215
216 %build
217 cp -f /usr/share/automake/config.* support
218 %{__autoconf}
219 for mode in %{?with_static:static} shared; do
220 %configure \
221         --enable-alias \
222         --enable-help-builtin \
223         --enable-history \
224         --enable-job-control \
225         --enable-restricted \
226         --enable-readline \
227         --with-curses \
228         --enable-extended-glob \
229         --enable-dparen-arithmetic \
230         --enable-separate-helpfiles \
231         --without-bash-malloc \
232         $([ "$mode" = "static" ] && echo "--enable-static-link") \
233         --with-installed-readline
234
235 %{__make} \
236         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
237
238 if [ "$mode" = "static" ]; then
239         mv -f bash bash.static
240 fi
241 done
242
243 %{?with_tests:%{__make} tests}
244
245 %install
246 rm -rf $RPM_BUILD_ROOT
247 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
248 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
249
250 %{__make} install \
251         DESTDIR=$RPM_BUILD_ROOT
252
253 %{__mv} $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
254 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
255
256 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
257 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
258
259 for d in es fr it ja ko nl pl ; do
260         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
261         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
262         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
263 done
264
265 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
266
267 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
268 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
269 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
270
271 # use our bugtracker, upstream will ignore reports from this anyway
272 %{__rm} $RPM_BUILD_ROOT%{_bindir}/bashbug \
273         $RPM_BUILD_ROOT%{_mandir}/man1/bashbug.1 \
274         $RPM_BUILD_ROOT%{_mandir}/*/man1/bashbug.1
275 # packaged as %doc
276 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/bash
277
278 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
279
280 %find_lang %{name}
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %post   -p <lua>
286 %lua_add_etc_shells /bin/bash /bin/rbash
287 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
288
289 %preun  -p <lua>
290 if arg[2] == 0 then
291         %lua_remove_etc_shells /bin/bash /bin/rbash
292 end
293
294 %postun -p /sbin/postshell
295 -/usr/sbin/fix-info-dir -c %{_infodir}
296
297 %post static -p <lua>
298 %lua_add_etc_shells /bin/bash.static
299
300 %preun static -p <lua>
301 if arg[2] == 0 then
302         %lua_remove_etc_shells /bin/bash.static
303 end
304
305 %files -f %{name}.lang
306 %defattr(644,root,root,755)
307 %doc AUTHORS CHANGES COMPAT NEWS POSIX README RBASH doc/{FAQ,INTRO,bash.html,bashref.html} 
308
309 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
310 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
311 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
312 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
313
314 %attr(755,root,root) /bin/bash
315 %attr(755,root,root) /bin/rbash
316
317 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
318 %{_infodir}/bash.info*
319 %{_mandir}/man1/bash.1*
320 %{_mandir}/man1/rbash.1*
321 %lang(es) %{_mandir}/es/man1/*
322 %lang(fr) %{_mandir}/fr/man1/*
323 %lang(it) %{_mandir}/it/man1/*
324 %lang(ja) %{_mandir}/ja/man1/*
325 %lang(ko) %{_mandir}/ko/man1/*
326 %lang(nl) %{_mandir}/nl/man1/*
327 %lang(pl) %{_mandir}/pl/man1/*
328 %dir %{_datadir}/%{name}
329 %doc %{_datadir}/%{name}/*
330
331 # loadables
332 %dir %{_libdir}/%{name}
333 %attr(755,root,root) %{_libdir}/%{name}/accept
334 %attr(755,root,root) %{_libdir}/%{name}/basename
335 %attr(755,root,root) %{_libdir}/%{name}/csv
336 %attr(755,root,root) %{_libdir}/%{name}/cut
337 %attr(755,root,root) %{_libdir}/%{name}/dirname
338 %attr(755,root,root) %{_libdir}/%{name}/fdflags
339 %attr(755,root,root) %{_libdir}/%{name}/finfo
340 %attr(755,root,root) %{_libdir}/%{name}/head
341 %attr(755,root,root) %{_libdir}/%{name}/id
342 %attr(755,root,root) %{_libdir}/%{name}/ln
343 %attr(755,root,root) %{_libdir}/%{name}/logname
344 %attr(755,root,root) %{_libdir}/%{name}/mkdir
345 %attr(755,root,root) %{_libdir}/%{name}/mkfifo
346 %attr(755,root,root) %{_libdir}/%{name}/mktemp
347 %attr(755,root,root) %{_libdir}/%{name}/mypid
348 %attr(755,root,root) %{_libdir}/%{name}/pathchk
349 %attr(755,root,root) %{_libdir}/%{name}/print
350 %attr(755,root,root) %{_libdir}/%{name}/printenv
351 %attr(755,root,root) %{_libdir}/%{name}/push
352 %attr(755,root,root) %{_libdir}/%{name}/realpath
353 %attr(755,root,root) %{_libdir}/%{name}/rm
354 %attr(755,root,root) %{_libdir}/%{name}/rmdir
355 %attr(755,root,root) %{_libdir}/%{name}/seq
356 %attr(755,root,root) %{_libdir}/%{name}/setpgid
357 %attr(755,root,root) %{_libdir}/%{name}/sleep
358 %attr(755,root,root) %{_libdir}/%{name}/strftime
359 %attr(755,root,root) %{_libdir}/%{name}/sync
360 %attr(755,root,root) %{_libdir}/%{name}/tee
361 %attr(755,root,root) %{_libdir}/%{name}/truefalse
362 %attr(755,root,root) %{_libdir}/%{name}/tty
363 %attr(755,root,root) %{_libdir}/%{name}/uname
364 %attr(755,root,root) %{_libdir}/%{name}/unlink
365 %attr(755,root,root) %{_libdir}/%{name}/whoami
366
367 %if %{with static}
368 %files static
369 %defattr(644,root,root,755)
370 %attr(755,root,root) /bin/bash.static
371 %endif
372
373 %files devel
374 %defattr(644,root,root,755)
375 %{_includedir}/bash
376 %dir %{_libdir}/%{name}
377 %{_libdir}/%{name}/Makefile.inc
378 %{_libdir}/%{name}/loadables.h
379 %{_pkgconfigdir}/bash.pc
This page took 0.053315 seconds and 3 git commands to generate.