]> git.pld-linux.org Git - packages/baculafs.git/blob - baculafs.spec
new, version 0.1.7
[packages/baculafs.git] / baculafs.spec
1 %define         pypi_name       BaculaFS
2 Summary:        Exposes the Bacula catalog and storage as a Filesystem in USErspace
3 Name:           baculafs
4 Version:        0.1.7
5 Release:        1
6 License:        GPL v3+
7 Group:          Networking/Utilities
8 Source0:        https://pypi.python.org/packages/source/B/BaculaFS/%{pypi_name}-%{version}.tar.gz
9 # Source0-md5:  50dcca4d11eeaa98fe0382dfd58243db
10 URL:            https://code.google.com/p/baculafs/
11 BuildRequires:  python >= 1:2.6.6
12 BuildRequires:  python-fuse >= 0.2.1
13 BuildRequires:  python-pexpect >= 2.3
14 Requires:       attr >= 2.4.44
15 Requires:       bacula-sd
16 Requires:       libfuse >= 2.8.4
17 Requires:       python >= 1:2.6.6
18 Requires:       python-MySQLdb >= 1.2.2
19 Requires:       python-fuse >= 0.2.1
20 Requires:       python-pexpect >= 2.3-7
21 Requires:       python-psycopg2 >= 2.0.13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 BaculaFS is a tool, developed independently of Bacula, that represents
27 the Bacula catalog and backup storage media as a read-only filesystem
28 in userspace.
29
30 BaculaFS is specifically designed to cater for the following
31 use-cases:
32 - maintaining a remote snapshot of the files in the backup storage
33   using rsync or duplicity
34 - auditing the contents of backup jobs, without resorting to SQL
35   queries
36 - comparing backup jobs (using several mount points)
37
38 Note that BaculaFS is a maintenance tool - its operation may interfere
39 with the normal operation of a live Bacula setup.
40
41 %prep
42 %setup -q -n %{pypi_name}-%{version}
43
44 # Remove bundled egg-info
45 %{__rm} -r %{pypi_name}.egg-info
46
47 %build
48 %{__python} setup.py build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__python} setup.py install \
53         --skip-build \
54         --optimize=2 \
55         --root=$RPM_BUILD_ROOT
56
57 %py_postclean
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README.rst
65 %attr(755,root,root) %{_bindir}/baculafs
66 %dir %{py_sitescriptdir}/baculafs
67 %{py_sitescriptdir}/baculafs/*.py[co]
68 %{py_sitescriptdir}/BaculaFS-%{version}-py*.egg-info
This page took 0.077938 seconds and 3 git commands to generate.