]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- updated to 1.11.1
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_without  regeneration    # without full regeneration
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.11.1
18 Release:        1
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
23 # Source0-md5:  c2972c4d9b3e29c03d5f2af86249876f
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 %if %{with regeneration}
30 BuildRequires:  autoconf >= 2.60
31 BuildRequires:  automake >= 1:1.10a
32 %else
33 BuildRequires:  autoconf >= 2.63
34 %endif
35 BuildRequires:  help2man
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  texinfo >= 4.7
38 Requires(pre):  fileutils
39 Requires:       filesystem >= 3.0-2
40 Requires:       perl(File::Glob)
41 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
42 # required only if perl was built with threads
43 Requires:       perl(Thread::Queue)
44 Requires:       perl(threads)
45 %endif
46 Conflicts:      autoconf < 2.60
47 Conflicts:      libtool < 2:1.5-11
48 #BuildArch:     noarch -- autoconf doesn't allow
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Automake is an experimental Makefile generator. Automake was inspired
53 by the 4.4BSD make and include files, but aims to be portable and to
54 conform to the GNU standards for Makefile variables and targets.
55
56 %description -l de.UTF-8
57 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
58 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
59 Konformität mit den GNU-Standards für Makefile-Variable und Targets
60 abzielt.
61
62 %description -l es.UTF-8
63 Automake es un creador experimental de Makefiles. Fue inspirado en el
64 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
65 con los padrones GNU para variables y dianas de Makefile.
66
67 %description -l fr.UTF-8
68 automake est un générateur expérimental de makefiles. Il a été inspiré
69 par le make de BSD 4.4, mais se veut portable et conforme aux
70 standards GNU pour les variables et les cibles des makefiles.
71
72 %description -l pl.UTF-8
73 Automake jest eksperymentalnym generatorem plików Makefile'a.
74 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
75 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
76 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
77
78 %description -l pt_BR.UTF-8
79 Automake é um gerador experimental de Makefiles. Ele foi inspirado
80 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
81 com os padrões GNU para variáveis e alvos de Makefile.
82
83 %description -l ru.UTF-8
84 Automake - это экспериментальный генератор Makefile'ов. Идея была
85 навеяна программой make и хедерами из 4.4BSD, но automake претендует
86 на то, чтобы быть портабельной и соответствовать стандартам GNU на
87 переменные и цели Makefile'ов.
88
89 %description -l tr.UTF-8
90 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
91 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
92 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
93
94 %description -l uk.UTF-8
95 Automake - це експериментальний генератор Makefile'ів. Ідея була
96 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
97 мобільність та відповідність стандартам GNU на змінні ті цілі
98 Makefile'ів.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106
107 %if %{with regeneration}
108 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
109 mkdir m4-tmp
110 cd m4-tmp
111 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
112 %endif
113
114 %build
115 %if %{with regeneration}
116 %{__aclocal} -I m4-tmp
117 %endif
118 %{__autoconf}
119 %if %{with regeneration}
120 %{__automake}
121 %endif
122 %configure
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_mandir}/man1
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT \
131         pkgvdatadir=%{_datadir}/automake
132
133 install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
134
135 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p      /sbin/postshell
141 -/usr/sbin/fix-info-dir -c %{_infodir}
142
143 %postun -p      /sbin/postshell
144 -/usr/sbin/fix-info-dir -c %{_infodir}
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog NEWS README THANKS TODO
149 %attr(755,root,root) %{_bindir}/aclocal*
150 %attr(755,root,root) %{_bindir}/automake*
151 %{_infodir}/automake.info*
152 %{_mandir}/man1/aclocal.1*
153 %{_mandir}/man1/aclocal-1.11.1*
154 %{_mandir}/man1/automake.1*
155 %{_mandir}/man1/automake-1.11.1*
156
157 %{_datadir}/aclocal-*
158 %dir %{_datadir}/automake
159 %{_datadir}/automake/am
160 %{_datadir}/automake/Automake
161 %{_datadir}/automake/COPYING
162 %{_datadir}/automake/INSTALL
163 %{_datadir}/automake/texinfo.tex
164 %{_datadir}/automake/ansi2knr*
165 %attr(755,root,root) %{_datadir}/automake/acinstall
166 %attr(755,root,root) %{_datadir}/automake/compile
167 %attr(755,root,root) %{_datadir}/automake/config.guess
168 %attr(755,root,root) %{_datadir}/automake/config.sub
169 %attr(755,root,root) %{_datadir}/automake/config-ml.in
170 %attr(755,root,root) %{_datadir}/automake/depcomp
171 %attr(755,root,root) %{_datadir}/automake/elisp-comp
172 %attr(755,root,root) %{_datadir}/automake/install-sh
173 %attr(755,root,root) %{_datadir}/automake/mdate-sh
174 %attr(755,root,root) %{_datadir}/automake/missing
175 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
176 %attr(755,root,root) %{_datadir}/automake/py-compile
177 %attr(755,root,root) %{_datadir}/automake/symlink-tree
178 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.044889 seconds and 4 git commands to generate.