]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- threads are required only if perl was built with threads
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_without  regeneration    # without full regeneration
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.11
18 Release:        2
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
23 # Source0-md5:  4db4efe027e26b33930a7e151de19d0f
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 %if %{with regeneration}
30 BuildRequires:  autoconf >= 2.60
31 BuildRequires:  automake >= 1:1.10a
32 %else
33 BuildRequires:  autoconf >= 2.63
34 %endif
35 BuildRequires:  rpm-perlprov
36 BuildRequires:  texinfo >= 4.7
37 Requires(pre):  fileutils
38 Requires:       filesystem >= 3.0-2
39 Requires:       perl(File::Glob)
40 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
41 # required only if perl was built with threads
42 Requires:       perl(Thread::Queue)
43 Requires:       perl(threads)
44 %endif
45 Conflicts:      autoconf < 2.60
46 Conflicts:      libtool < 2:1.5-11
47 #BuildArch:     noarch -- autoconf doesn't allow
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Automake is an experimental Makefile generator. Automake was inspired
52 by the 4.4BSD make and include files, but aims to be portable and to
53 conform to the GNU standards for Makefile variables and targets.
54
55 %description -l de.UTF-8
56 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
57 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
58 Konformität mit den GNU-Standards für Makefile-Variable und Targets
59 abzielt.
60
61 %description -l es.UTF-8
62 Automake es un creador experimental de Makefiles. Fue inspirado en el
63 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
64 con los padrones GNU para variables y dianas de Makefile.
65
66 %description -l fr.UTF-8
67 automake est un générateur expérimental de makefiles. Il a été inspiré
68 par le make de BSD 4.4, mais se veut portable et conforme aux
69 standards GNU pour les variables et les cibles des makefiles.
70
71 %description -l pl.UTF-8
72 Automake jest eksperymentalnym generatorem plików Makefile'a.
73 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
74 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
75 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
76
77 %description -l pt_BR.UTF-8
78 Automake é um gerador experimental de Makefiles. Ele foi inspirado
79 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
80 com os padrões GNU para variáveis e alvos de Makefile.
81
82 %description -l ru.UTF-8
83 Automake - это экспериментальный генератор Makefile'ов. Идея была
84 навеяна программой make и хедерами из 4.4BSD, но automake претендует
85 на то, чтобы быть портабельной и соответствовать стандартам GNU на
86 переменные и цели Makefile'ов.
87
88 %description -l tr.UTF-8
89 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
90 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
91 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
92
93 %description -l uk.UTF-8
94 Automake - це експериментальний генератор Makefile'ів. Ідея була
95 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
96 мобільність та відповідність стандартам GNU на змінні ті цілі
97 Makefile'ів.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 %if %{with regeneration}
107 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
108 mkdir m4-tmp
109 cd m4-tmp
110 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
111 %endif
112
113 %build
114 %if %{with regeneration}
115 %{__aclocal} -I m4-tmp
116 %endif
117 %{__autoconf}
118 %if %{with regeneration}
119 %{__automake}
120 %endif
121 %configure
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_mandir}/man1
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         pkgvdatadir=%{_datadir}/automake
131
132 install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
133
134 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p      /sbin/postshell
140 -/usr/sbin/fix-info-dir -c %{_infodir}
141
142 %postun -p      /sbin/postshell
143 -/usr/sbin/fix-info-dir -c %{_infodir}
144
145 %files
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog NEWS README THANKS TODO
148 %attr(755,root,root) %{_bindir}/aclocal*
149 %attr(755,root,root) %{_bindir}/automake*
150 %{_infodir}/automake.info*
151 %{_mandir}/man1/aclocal.1*
152 %{_mandir}/man1/aclocal-1.11.1*
153 %{_mandir}/man1/automake.1*
154 %{_mandir}/man1/automake-1.11.1*
155
156 %{_datadir}/aclocal-*
157 %dir %{_datadir}/automake
158 %{_datadir}/automake/am
159 %{_datadir}/automake/Automake
160 %{_datadir}/automake/COPYING
161 %{_datadir}/automake/INSTALL
162 %{_datadir}/automake/texinfo.tex
163 %{_datadir}/automake/ansi2knr*
164 %attr(755,root,root) %{_datadir}/automake/acinstall
165 %attr(755,root,root) %{_datadir}/automake/compile
166 %attr(755,root,root) %{_datadir}/automake/config.guess
167 %attr(755,root,root) %{_datadir}/automake/config.sub
168 %attr(755,root,root) %{_datadir}/automake/config-ml.in
169 %attr(755,root,root) %{_datadir}/automake/depcomp
170 %attr(755,root,root) %{_datadir}/automake/elisp-comp
171 %attr(755,root,root) %{_datadir}/automake/install-sh
172 %attr(755,root,root) %{_datadir}/automake/mdate-sh
173 %attr(755,root,root) %{_datadir}/automake/missing
174 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
175 %attr(755,root,root) %{_datadir}/automake/py-compile
176 %attr(755,root,root) %{_datadir}/automake/symlink-tree
177 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.036434 seconds and 4 git commands to generate.