]> git.pld-linux.org Git - packages/autoconf-dickey.git/blob - autoconf-dickey.spec
97491e9d1e6abbf3e8f5761aa43b1b55a1c81c68
[packages/autoconf-dickey.git] / autoconf-dickey.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make check"
4
5 %define snap    20180819
6 %define rel     2
7
8 Summary:        Thomas Dickey's autoconf - source configuration tools
9 Summary(pl.UTF-8):      autoconf (wersja Thomasa Dickeya) - narzędzie do automatycznego konfigurowania źródeł
10 Name:           autoconf-dickey
11 Version:        2.52
12 Release:        0.%{snap}.%{rel}
13 License:        GPL v2+/v3+
14 Group:          Development/Building
15 # stable releases:
16 Source0:        http://ftp.debian.org:/debian/pool/main/a/autoconf-dickey/%{name}_%{version}+20180819.orig.tar.gz
17 # Source0-md5:  1f9a7b4682902cdced6fa4b1bb67bb0c
18 Patch0:         %{name}-info.patch
19 URL:            https://invisible-island.net/autoconf/
20 BuildRequires:  m4 >= 3:1.4.13
21 BuildRequires:  rpm-perlprov
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  texinfo >= 4.2
24 BuildRequires:  xz
25 BuildConflicts: m4 = 1.4o
26 Requires:       /bin/awk
27 Requires:       diffutils
28 Conflicts:      gettext < 0.10.38-3
29 Conflicts:      pkgconfig < 1:0.25-2
30 %requires_eq    m4
31 Requires:       mktemp
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %if %{_host_cpu} == "x32"
36 %define build_arch %{_target_platform}
37 %else
38 %define build_arch %{_host}
39 %endif
40
41 %define         _libdir         %{_datadir}
42
43 %description
44 Autoconf (Thomas Dickey's version) is a tool for configuring source
45 code and Makefiles. Using Autoconf, programmers can create portable
46 and configurable packages, since the person building the package is
47 allowed to specify various configuration options.
48
49 You should install Autoconf if you are developing software and you'd
50 like to use it to create shell scripts which will configure your
51 source code packages.
52
53 Note that the Autoconf package is not required for the end user who
54 may be configuring software with an Autoconf-generated script;
55 Autoconf is only required for the generation of the scripts, not their
56 use.
57
58 %description -l pl.UTF-8
59 autoconf (wersja Thomasa Dickeya) jest narzędziem wykorzystywanym do
60 automatycznego konfigurowania kodów źródłowych pakietów programów oraz
61 do generowania na podstawie automatycznie rozpoznanego środowiska
62 plików Makefile i innych zależnych od zawartości systemu, w którym ma
63 przebiegać proces kompilacji. Pomaga programiście w konfigurowaniu i
64 tworzeniu oprogramowania dającego się przenieść na różne platformy.
65 Umożliwia wybór wielu opcji podczas procesu przygotowania do
66 kompilacji.
67
68 autoconf nie jest generalnie potrzebny końcowemu użytkownikowi, a
69 tylko podczas generowania samych skryptów autokonfiguracyjnych.
70
71 %prep
72 %setup -q -n autoconf-%{version}-%{snap}
73 %patch0 -p1
74
75 %build
76 %configure \
77         --program-suffix=-dickey \
78         --datadir=%{_datadir}/autoconf-dickey \
79         --host=%{build_arch} \
80         --build=%{build_arch}
81 %{__make} -j1
82
83 %{?with_tests:%{__make} -j1 check}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} -j1 install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # no need for duplicates
92 %{__rm} $RPM_BUILD_ROOT%{_infodir}/standards*.info
93
94 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/postshell
100 -/usr/sbin/fix-info-dir -c %{_infodir}
101
102 %postun -p /sbin/postshell
103 -/usr/sbin/fix-info-dir -c %{_infodir}
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS BUGS ChangeLog ChangeLog.2 NEWS README THANKS TODO
108 %attr(755,root,root) %{_bindir}/auto*-dickey
109 %attr(755,root,root) %{_bindir}/ifnames-dickey
110 %{_libdir}/autoconf-dickey
111 %{_infodir}/autoconf-dickey.info*
112 %{_mandir}/man1/auto*-dickey.1*
113 %{_mandir}/man1/ifnames-dickey.1*
This page took 0.029914 seconds and 2 git commands to generate.