]> git.pld-linux.org Git - packages/attica.git/blob - attica.spec
8d4846070db11647b0200aab4097b747ab3e80db
[packages/attica.git] / attica.spec
1 #
2 # Conditional build:
3 #
4 %define         qt_ver          4.8.3
5
6 Summary:        Attica Library - implementation of Open Collaboration Services API for Qt
7 Summary(pl.UTF-8):      Attica Library - implementacja API Serwisów Otwartej Współpracy dla Qt
8 Name:           attica
9 Version:        0.4.2
10 Release:        1
11 License:        GPL
12 Group:          X11/Libraries
13 # svn co svn://anonsvn.kde.org/home/kde/trunk/kdesupport/attica/
14 Source0:        ftp://ftp.kde.org/pub/kde/stable/attica/%{name}-%{version}.tar.bz2
15 # Source0-md5:  d62c5c9489a68432e8d990dde7680c24
16 URL:            http://www.kde.org/
17 BuildRequires:  QtCore-devel >= %{qt_ver}
18 BuildRequires:  QtGui-devel >= %{qt_ver}
19 BuildRequires:  QtNetwork-devel >= %{qt_ver}
20 BuildRequires:  QtXml-devel >= %{qt_ver}
21 BuildRequires:  automoc4 >= 0.9.84
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  qt4-build >= %{qt_ver}
24 BuildRequires:  qt4-qmake >= %{qt_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.600
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Attica is a Qt library that implements the Open Collaboration Services
30 API. It grants easy access to the services such as querying
31 information about persons and contents.
32
33 %description -l pl.UTF-8
34 Attica jest biblioteką Qt, która implementuje API Serwisów Otwartej
35 Współpracy. Pozwala na łatwy dostęp do serwisów takich jak zapytania o
36 informacje o osobach i treściach.
37
38 %package devel
39 Summary:        Header files for attica library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki attica
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for attica library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki attica.
49
50 %prep
51 %setup -q
52
53 %build
54 install -d build
55 cd build
56 %cmake ..
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} -C build install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post   -p      /sbin/ldconfig
68 %postun -p      /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_libdir}/libattica.so.*.*.*
73 %attr(755,root,root) %ghost %{_libdir}/libattica.so.0.4
74
75 %files devel
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/libattica.so
78 %{_includedir}/attica
79 %{_pkgconfigdir}/libattica.pc
This page took 0.02393 seconds and 2 git commands to generate.