]> git.pld-linux.org Git - packages/atk.git/blob - atk.spec
f43c3b81adebb970b8a73320d034ab1d57dbcee4
[packages/atk.git] / atk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5
6 Summary:        ATK - Accessibility Toolkit
7 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów
8 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
9 Name:           atk
10 Version:        2.34.0
11 Release:        1
12 Epoch:          1
13 License:        LGPL v2+
14 Group:          X11/Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/2.34/%{name}-%{version}.tar.xz
16 # Source0-md5:  d2c1a54e332bef627cf4dde240a7254e
17 URL:            https://developer.gnome.org/atk/
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  gettext-tools >= 0.19.2
20 BuildRequires:  glib2-devel >= 1:2.38.0
21 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
22 BuildRequires:  glibc-localedb-all
23 %endif
24 BuildRequires:  gobject-introspection-devel >= 1.32.0
25 %if %{with apidocs}
26 BuildRequires:  gtk-doc >= 1.25
27 %endif
28 BuildRequires:  meson >= 0.46.0
29 BuildRequires:  ninja >= 1.5
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.728
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.38.0
35 Obsoletes:      libatk1.0_0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The ATK library provides a set of interfaces for adding accessibility
40 support to applications and graphical user interface toolkits. By
41 supporting the ATK interfaces, an application or toolkit can be used
42 as tools such as screen readers and magnifiers, and alternative input
43 devices.
44
45 %description -l pl.UTF-8
46 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
47 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
48 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
49 ATK, aplikacja lub element interfejsu może być używany z takimi
50 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
51 alternatywnymi urządzeniami wejściowymi.
52
53 %description -l pt_BR.UTF-8
54 A biblioteca ATK provê um conjunto de interfaces para adicionar
55 suporte a acessibilidade para aplicações e interfaces gráficas.
56 Suportando a interface ATK, uma aplicação ou interface gráfica pode
57 ser utilizada como ferramentas de leitura e aumento de tela,
58 dispositivos de entrada alternativos, etc.
59
60 %package devel
61 Summary:        ATK - header files
62 Summary(pl.UTF-8):      ATK - pliki nagłówkowe
63 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{epoch}:%{version}-%{release}
66 Requires:       glib2-devel >= 1:2.38.0
67 Obsoletes:      libatk1.0_0-devel
68
69 %description devel
70 ATK - header files.
71
72 %description devel -l pl.UTF-8
73 ATK - pliki nagłówkowe.
74
75 %description devel -l pt_BR.UTF-8
76 Interfaces para suporte a acessibilidade.
77
78 %package static
79 Summary:        ATK static library
80 Summary(pl.UTF-8):      Biblioteka statyczna ATK
81 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
84
85 %description static
86 ATK static library.
87
88 %description static -l pl.UTF-8
89 Biblioteka statyczna ATK.
90
91 %description static -l pt_BR.UTF-8
92 Interfaces para suporte a acessibilidade.
93
94 %package apidocs
95 Summary:        ATK API documentation
96 Summary(pl.UTF-8):      Dokumentacja API ATK
97 Group:          Documentation
98 Requires:       gtk-doc-common
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description apidocs
104 ATK API documentation.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API ATK.
108
109 %prep
110 %setup -q
111
112 %build
113 %meson build \
114         -Ddocs=%{__true_false apidocs}
115
116 %meson_build -C build
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %meson_install -C build
122
123 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/atk}
124
125 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
126
127 %find_lang atk10
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f atk10.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS MAINTAINERS NEWS README
138 %attr(755,root,root) %{_libdir}/libatk-1.0.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libatk-1.0.so.0
140 %{_libdir}/girepository-1.0/Atk-1.0.typelib
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libatk-1.0.so
145 %{_includedir}/atk-1.0
146 %{_pkgconfigdir}/atk.pc
147 %{_datadir}/gir-1.0/Atk-1.0.gir
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libatk-1.0.a
153 %endif
154
155 %if %{with apidocs}
156 %files apidocs
157 %defattr(644,root,root,755)
158 %{_gtkdocdir}/atk
159 %endif
This page took 0.050469 seconds and 2 git commands to generate.