]> git.pld-linux.org Git - packages/atk.git/blob - atk.spec
- updated to 2.38.0
[packages/atk.git] / atk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5
6 Summary:        ATK - Accessibility Toolkit
7 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów
8 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
9 Name:           atk
10 Version:        2.38.0
11 Release:        1
12 Epoch:          1
13 License:        LGPL v2+
14 Group:          X11/Libraries
15 Source0:        https://download.gnome.org/sources/atk/2.38/%{name}-%{version}.tar.xz
16 # Source0-md5:  4dcea15cbf166706c166fc4fee05e3f8
17 URL:            https://developer.gnome.org/atk/
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  gettext-tools >= 0.19.2
20 BuildRequires:  glib2-devel >= 1:2.38.0
21 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
22 BuildRequires:  glibc-localedb-all
23 %endif
24 BuildRequires:  gobject-introspection-devel >= 1.32.0
25 %if %{with apidocs}
26 BuildRequires:  gtk-doc >= 1.25
27 %endif
28 BuildRequires:  meson >= 0.46.0
29 BuildRequires:  ninja >= 1.5
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 Requires:       glib2 >= 1:2.38.0
36 Obsoletes:      libatk1.0_0 < 1:2
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The ATK library provides a set of interfaces for adding accessibility
41 support to applications and graphical user interface toolkits. By
42 supporting the ATK interfaces, an application or toolkit can be used
43 as tools such as screen readers and magnifiers, and alternative input
44 devices.
45
46 %description -l pl.UTF-8
47 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
48 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
49 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
50 ATK, aplikacja lub element interfejsu może być używany z takimi
51 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
52 alternatywnymi urządzeniami wejściowymi.
53
54 %description -l pt_BR.UTF-8
55 A biblioteca ATK provê um conjunto de interfaces para adicionar
56 suporte a acessibilidade para aplicações e interfaces gráficas.
57 Suportando a interface ATK, uma aplicação ou interface gráfica pode
58 ser utilizada como ferramentas de leitura e aumento de tela,
59 dispositivos de entrada alternativos, etc.
60
61 %package devel
62 Summary:        ATK - header files
63 Summary(pl.UTF-8):      ATK - pliki nagłówkowe
64 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
65 Group:          X11/Development/Libraries
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67 Requires:       glib2-devel >= 1:2.38.0
68 Obsoletes:      libatk1.0_0-devel < 1:2
69
70 %description devel
71 ATK - header files.
72
73 %description devel -l pl.UTF-8
74 ATK - pliki nagłówkowe.
75
76 %description devel -l pt_BR.UTF-8
77 Interfaces para suporte a acessibilidade.
78
79 %package static
80 Summary:        ATK static library
81 Summary(pl.UTF-8):      Biblioteka statyczna ATK
82 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
85
86 %description static
87 ATK static library.
88
89 %description static -l pl.UTF-8
90 Biblioteka statyczna ATK.
91
92 %description static -l pt_BR.UTF-8
93 Interfaces para suporte a acessibilidade.
94
95 %package apidocs
96 Summary:        ATK API documentation
97 Summary(pl.UTF-8):      Dokumentacja API ATK
98 Group:          Documentation
99 Requires:       gtk-doc-common
100 BuildArch:      noarch
101
102 %description apidocs
103 ATK API documentation.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API ATK.
107
108 %prep
109 %setup -q
110
111 %build
112 %meson build \
113         -Ddocs=%{__true_false apidocs}
114
115 %ninja_build -C build
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %ninja_install -C build
121
122 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/atk}
123
124 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
125
126 %find_lang atk10
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f atk10.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS MAINTAINERS NEWS README
137 %attr(755,root,root) %{_libdir}/libatk-1.0.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libatk-1.0.so.0
139 %{_libdir}/girepository-1.0/Atk-1.0.typelib
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libatk-1.0.so
144 %{_includedir}/atk-1.0
145 %{_pkgconfigdir}/atk.pc
146 %{_datadir}/gir-1.0/Atk-1.0.gir
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libatk-1.0.a
152 %endif
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %{_gtkdocdir}/atk
158 %endif
This page took 0.032759 seconds and 3 git commands to generate.