]> git.pld-linux.org Git - packages/at-spi.git/blob - at-spi.spec
- updated to 1.20.1
[packages/at-spi.git] / at-spi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Assistive Technology Service Provider Interface
6 Summary(pl.UTF-8):      Interfejs pozwalający na korzystanie z urządzeń wspomagających
7 Name:           at-spi
8 Version:        1.20.1
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.20/%{name}-%{version}.tar.bz2
13 # Source0-md5:  9dc4ce96c17452cd285d006d03574e93
14 URL:            http://developer.gnome.org/projects/gap/
15 BuildRequires:  ORBit2-devel >= 2.14.9
16 BuildRequires:  atk-devel >= 1:1.20.0
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gail-devel >= 1.20.0
20 BuildRequires:  gnome-common >= 2.20.0
21 BuildRequires:  gtk+2-devel >= 2:2.12.0
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  intltool >= 0.36.2
24 BuildRequires:  libbonobo-devel >= 2.20.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 BuildRequires:  rpm-build >= 4.1-10
29 BuildRequires:  rpmbuild(macros) >= 1.219
30 BuildRequires:  xorg-lib-libXevie-devel
31 BuildRequires:  xorg-lib-libXft-devel >= 2.1
32 BuildRequires:  xorg-lib-libXtst-devel
33 Obsoletes:      libat-spi1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 AT-SPI allows assistive technologies to access GTK-based applications.
38 Essentially it exposes the internals of applications for automation,
39 so tools such as screen readers, magnifiers, or even scripting
40 interfaces can query and interact with GUI controls.
41
42 %description -l pl.UTF-8
43 AT-SPI pozwala na korzystanie z urządzeń wspomagających w celu dostępu
44 do aplikacji bazujących na GTK. Przede wszystkim udostępnia wewnętrzne
45 interfejsy aplikacji dla automatyzacji, więc urządzenia takie jak
46 czytniki ekranu, lupy, czy nawet interfejsy skryptowe mogą odpytywać i
47 współpracować z kontrolkami interfejsu graficznego.
48
49 %package devel
50 Summary:        AT-SPI development files
51 Summary(pl.UTF-8):      Pliki programistyczne AT-SPI
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       ORBit2-devel >= 2.14.9
55 Requires:       atk-devel >= 1:1.20.0
56 Requires:       gail-devel >= 1.20.0
57 Requires:       gtk+2-devel >= 2:2.12.0
58 Requires:       libbonobo-devel >= 2.20.0
59 Obsoletes:      libat-spi1-devel
60
61 %description devel
62 AT-SPI development files.
63
64 %description devel -l pl.UTF-8
65 Pliki programistyczne AT-SPI.
66
67 %package static
68 Summary:        AT-SPI static library
69 Summary(pl.UTF-8):      Statyczna biblioteka AT-SPI
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 AT-SPI static library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka AT-SPI.
78
79 %package apidocs
80 Summary:        AT-SPI API documentation
81 Summary(pl.UTF-8):      Dokumentacja API AT-SPI
82 Group:          Documentation
83 Requires:       gtk-doc-common
84
85 %description apidocs
86 AT-SPI API documentation.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API AT-SPI.
90
91 %package -n python-pyatspi
92 Summary:        AT-SPI Python bindings
93 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona
94 Group:          Development/Languages/Python
95 Requires:       python-pyorbit
96
97 %description -n python-pyatspi
98 AT-SPI Python bindings.
99
100 %description -n python-pyatspi -l pl.UTF-8
101 Wiązania AT-SPI dla Pythona.
102
103 %prep
104 %setup -q
105
106 %build
107 %{__glib_gettextize}
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal}
111 %{__automake}
112 %{__autoconf}
113 %configure \
114         %{!?with_static_libs:--disable-static} \
115         --enable-gtk-doc \
116         --enable-static \
117         --with-html-dir=%{_gtkdocdir}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         HTML_DIR=%{_gtkdocdir}
126
127 # no static modules
128 rm -f $RPM_BUILD_ROOT%{_libdir}/{gtk-2.0/modules,orbit-2.0}/*.{la,a}
129
130 %py_postclean
131
132 %find_lang %{name}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143 %attr(755,root,root) %{_libdir}/at-spi-registryd
144 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so
145 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/lib*.so
146 %{_libdir}/bonobo/servers/*
147 %{_datadir}/idl/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %{_includedir}/*
152 %attr(755,root,root) %{_libdir}/lib*.so
153 %{_libdir}/lib*.la
154 %{_pkgconfigdir}/*
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/*.a
160 %endif
161
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/*
165 %{_docdir}/%{name}-%{version}
166
167 %files -n python-pyatspi
168 %defattr(644,root,root,755)
169 %dir %{py_sitedir}/pyatspi
170 %{py_sitedir}/pyatspi/*.py[co]
This page took 0.046395 seconds and 4 git commands to generate.