]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- release 2 for Th.
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          stable
9 %define         _kdever         3.4
10 %define         _ver            1.4.0
11
12 Summary:        aRts sound server
13 Summary(pl):    Serwer d¼wiêku
14 Summary(pt_BR): Servidor de sons usado pelo KDE
15 Name:           arts
16 Version:        %{_ver}
17 Release:        2
18 Epoch:          13
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  a155bb00f56c71bc475890249e2dcaa9
23 Patch100:       %{name}-branch.diff
24 URL:            http://www.arts-project.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.14
31 %{?with_esd:BuildRequires:      esound-devel}
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  jack-audio-connection-kit-devel
34 BuildRequires:  libmad-devel
35 BuildRequires:  libtool >= 2:1.5-2
36 BuildRequires:  libvorbis-devel
37 %{?with_nas:BuildRequires:      nas-devel}
38 BuildRequires:  pkgconfig
39 BuildRequires:  qt-devel >= 6:3.2.1-4
40 #BuildRequires: unsermake >= 040805-1
41 Obsoletes:      arts-glib
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The Analog Real-Time Synthesizer, or aRts, is a modular system for
46 synthesizing sound and music on a digital computer. Using small
47 building blocks called modules, the user can easily build complex
48 audio processing tools. Modules typically provide functions such as
49 sound waveform generators, filters, audio effects, mixing, and
50 playback of digital audio in different file formats. The artsd sound
51 server mixes audio from several sources in real time, allowing
52 multiple sound applications to transparently share access to sound
53 hardware.
54
55 %description -l pl
56 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
57 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
58 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
59 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
60 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
61 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
62 odtwarzanie d¼wiêku z wielu ¼róde³.
63
64 %description -l pt_BR
65 O aRts é um sintetizador analógico em tempo real que é completamente
66 modular. Você pode criar sons e músicas (síntese em tempo real de
67 midi) usando pequenos módulos como oscilador para criar waveforms,
68 vários filtros, mixers, faders, etc. Você pode configurar tudo através
69 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
70 design foi escolhido para permitir que outras aplicações usem o aRts
71 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
72 outros.
73
74 %package devel
75 Summary:        Sound server - header files
76 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
77 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 # not necessary for all libs (e.g. mcop), but propagated by artsflow
81 %{?with_alsa:Requires:  alsa-lib-devel}
82 Requires:       audiofile-devel
83 Requires:       esound-devel
84 Requires:       glib2-devel >= 2.0.0
85 Requires:       jack-audio-connection-kit-devel
86 Requires:       libmad-devel
87 Requires:       libvorbis-devel
88 %{?with_nas:Requires:   nas-devel}
89
90 %description devel
91 Header files required to compile programs using arts.
92
93 %description devel -l pl
94 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
95 arts.
96
97 %description devel -l pt_BR
98 Arquivos para desenvolvimento com o o aRts.
99
100 # separate from arts-devel because they are mostly independent and have very
101 # different deps
102 # there is no artsc base - it would be small and would require arts - so
103 # there is no reason to separate
104 %package -n artsc-devel
105 Summary:        Development files for artsc libraries
106 Summary(pl):    Pliki programistyczne bibliotek artsc
107 Group:          Development/Libraries
108 Requires:       %{name} = %{epoch}:%{version}-%{release}
109 Requires:       glib2-devel >= 2.0.0
110 Conflicts:      arts-devel < 12:1.2.0.031126-2
111
112 %description -n artsc-devel
113 Development files for artsc libraries (C interface to aRts sound
114 system).
115
116 %description -n artsc-devel -l pl
117 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
118 d¼wiêku aRts).
119
120 %package X11
121 Summary:        X11 dependent part of aRts
122 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
123 Group:          X11/Libraries
124 Requires:       %{name} = %{epoch}:%{version}-%{release}
125
126 %description X11
127 X11 dependent part of aRts (x11globalcomm module).
128
129 %description X11 -l pl
130 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
131
132 %package qt
133 Summary:        Qt dependend part of aRts
134 Summary(pl):    Czê¶æ aRts wymagaj±ca Qt
135 Group:          X11/Libraries
136 Requires:       %{name} = %{epoch}:%{version}-%{release}
137 Requires:       qt >= 6:3.2.1-4
138
139 %description qt
140 Qt dependend part of aRts (qtmcop library).
141
142 %description qt -l pl
143 Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
144
145 %package qt-devel
146 Summary:        Development files for qtmcop library
147 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
148 Group:          X11/Development/Libraries
149 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
150 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
151 Requires:       qt-devel >= 6:3.2.1-4
152
153 %description qt-devel
154 Development files for qtmcop library.
155
156 %description qt-devel -l pl
157 Pliki programistyczne dla biblioteki qtmcop.
158
159 %prep
160 %setup -q
161 %patch100 -p1
162
163 %build
164 cp -f /usr/share/automake/config.sub admin
165
166 #export UNSERMAKE=/usr/share/unsermake/unsermake
167
168 %{__make} -f admin/Makefile.common cvs
169
170 %configure \
171         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
172 %if "%{_lib}" == "lib64"
173         --enable-libsuffix=64 \
174 %endif
175         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
176         %{!?debug:--disable-rpath} \
177         --enable-final \
178         --with-qt-libraries=%{_libdir} \
179         --with%{!?with_alsa:out}-alsa
180
181 %{__make}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT
188
189 # Debian manpages
190 install -d $RPM_BUILD_ROOT%{_mandir}/man1
191 cd debian/man
192 for f in *.sgml ; do
193         base="$(basename $f .sgml)"
194         upper="$(echo ${base} | tr a-z A-Z)"
195         db2man $f
196         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
197 done
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %post   X11 -p /sbin/ldconfig
206 %postun X11 -p /sbin/ldconfig
207
208 %post   qt -p /sbin/ldconfig
209 %postun qt -p /sbin/ldconfig
210
211 %files
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/artscat
214 %attr(755,root,root) %{_bindir}/artsd
215 %attr(755,root,root) %{_bindir}/artsdsp
216 %attr(755,root,root) %{_bindir}/artsplay
217 %attr(755,root,root) %{_bindir}/artsrec
218 %attr(755,root,root) %{_bindir}/artsshell
219 %attr(755,root,root) %{_bindir}/artswrapper
220 # shared libraries
221 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
229 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
230 # lt_dlopened modules (*.la needed)
231 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
232 %{_libdir}/libartscbackend.la
233 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
234 %{_libdir}/libartsdsp.la
235 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
236 %{_libdir}/libartsdsp_st.la
237 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
238 %{_libdir}/libartsgslplayobject.la
239 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
240 %{_libdir}/libartswavplayobject.la
241 #
242 %{_libdir}/mcop
243 %{_mandir}/man1/artscat.1*
244 %{_mandir}/man1/artsd.1*
245 %{_mandir}/man1/artsdsp.1*
246 %{_mandir}/man1/artsplay.1*
247 %{_mandir}/man1/artsrec.1*
248 %{_mandir}/man1/artsshell.1*
249 %{_mandir}/man1/artswrapper.1*
250
251 %files devel
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/mcopidl
254 %attr(755,root,root) %{_libdir}/libartsflow.so
255 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
256 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
257 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
258 %attr(755,root,root) %{_libdir}/libgmcop.so
259 %attr(755,root,root) %{_libdir}/libkmedia2.so
260 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
261 %attr(755,root,root) %{_libdir}/libmcop.so
262 %attr(755,root,root) %{_libdir}/libmcop_mt.so
263 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
264 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
265 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
266 # shared libraries
267 %{_libdir}/libartsflow.la
268 %{_libdir}/libartsflow_idl.la
269 %{_libdir}/libgmcop.la
270 %{_libdir}/libkmedia2.la
271 %{_libdir}/libkmedia2_idl.la
272 %{_libdir}/libmcop.la
273 %{_libdir}/libmcop_mt.la
274 %{_libdir}/libsoundserver_idl.la
275 #
276 %{_includedir}/arts
277 %exclude %{_includedir}/arts/qiomanager.h
278 %{_mandir}/man1/mcopidl.1*
279
280 %files -n artsc-devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/artsc-config
283 %attr(755,root,root) %{_libdir}/libartsc.so
284 %attr(755,root,root) %{_libdir}/libartscbackend.so
285 %attr(755,root,root) %{_libdir}/libartsdsp.so
286 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
287 %{_libdir}/libartsc.la
288 %{_includedir}/artsc
289 %{_mandir}/man1/artsc-config.1*
290
291 %files X11
292 %defattr(644,root,root,755)
293 # lt_dlopened module (.la needed)
294 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
295 %{_libdir}/libx11globalcomm.la
296
297 %files qt
298 %defattr(644,root,root,755)
299 # shared library
300 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
301
302 %files qt-devel
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_libdir}/libqtmcop.so
305 %{_libdir}/libqtmcop.la
306 %{_includedir}/arts/qiomanager.h
This page took 0.085795 seconds and 4 git commands to generate.