]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- the official release is next monday, till this time please test it.
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6 %define         _state          stable
7 %define         _ver            1.2.3
8 #%%define               _snap           040110
9 %define         _kdever         3.2.3
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        0.1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 #Source0:       http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
21 Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
22 # Source0-md5:  fca8a9ec7538c4fe8e4c79767bb2a7e8
23 # http://download.kde.org/stable/3.2.1/src/arts-1.2.1.tar.bz2
24 URL:            http://www.kde.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.13-3
31 BuildRequires:  esound-devel
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  unsermake >= 040511
39 BuildRequires:  qt-devel >= 6:3.2.1-4
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 aRts sound server.
45
46 %description -l pl
47 Serwer d¼wiêku aRts.
48
49 %description -l pt_BR
50 O aRts é um sintetizador analógico em tempo real que é completamente
51 modular. Você pode criar sons e músicas (síntese em tempo real de
52 midi) usando pequenos módulos como oscilador para criar waveforms,
53 vários filtros, mixers, faders, etc. Você pode configurar tudo através
54 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
55 design foi escolhido para permitir que outras aplicações usem o aRts
56 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
57 outros.
58
59 %package devel
60 Summary:        Sound server - header files
61 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
62 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
63 Group:          Development/Libraries
64 Requires:       %{name} = %{epoch}:%{version}-%{release}
65 # not necessary for all libs (e.g. mcop), but propagated by artsflow
66 %{?with_alsa:Requires:  alsa-lib-devel}
67 Requires:       audiofile-devel
68 Requires:       esound-devel
69 Requires:       glib2-devel >= 2.0.0
70 Requires:       libmad-devel
71 Requires:       libvorbis-devel
72 %{?with_nas:Requires:   nas-devel}
73
74 %description devel
75 Header files required to compile programs using arts.
76
77 %description devel -l pl
78 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
79 arts.
80
81 %description devel -l pt_BR
82 Arquivos para desenvolvimento com o o aRts.
83
84 # separate from arts-devel because they are mostly independent and
85 # have very # different deps there is no artsc base - it would be
86 # small and would require arts - so there is no reason to separate
87 %package -n artsc-devel
88 Summary:        Development files for artsc libraries
89 Summary(pl):    Pliki programistyczne bibliotek artsc
90 Group:          Development/Libraries
91 Requires:       %{name} = %{epoch}:%{version}-%{release}
92 Requires:       glib2-devel >= 2.0.0
93 Conflicts:      arts-devel < 12:1.2.0.031126-2
94
95 %description -n artsc-devel
96 Development files for artsc libraries (C interface to aRts sound
97 system).
98
99 %description -n artsc-devel -l pl
100 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
101 d¼wiêku aRts).
102
103 %package X11
104 Summary:        X11 dependent part of aRts
105 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
106 Group:          X11/Libraries
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108
109 %description X11
110 X11 dependent part of aRts (x11globalcomm module).
111
112 %description X11 -l pl
113 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
114
115 %package qt
116 Summary:        QT dependend part of aRts
117 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
118 Group:          X11/Libraries
119 Requires:       %{name} = %{epoch}:%{version}-%{release}
120 Requires:       qt >= 6:3.2.1-4
121
122 %description qt
123 QT dependend part of aRts (qtmcop library).
124
125 %description qt -l pl
126 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
127
128 %package qt-devel
129 Summary:        Development files for qtmcop library
130 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
131 Group:          X11/Development/Libraries
132 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
133 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
134 Requires:       qt-devel >= 6:3.2.1-4
135
136 %description qt-devel
137 Development files for qtmcop library.
138
139 %description qt-devel -l pl
140 Pliki programistyczne dla biblioteki qtmcop.
141
142 %prep
143 # qboosh leave it this way, 'cause its easier to change to snap later
144 %setup -q -n %{name}-%{version}
145
146 %build
147 cp /usr/share/automake/config.sub admin
148 export UNSERMAKE=/usr/share/unsermake/unsermake
149 %{__make} -f admin/Makefile.common cvs
150
151 %configure \
152         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
153         --%{?debug:en}%{!?debug:dis}able-debug \
154         --disable-rpath \
155         --enable-final \
156         --with-qt-libraries=%{_libdir} \
157         --with%{!?with_alsa:out}-alsa
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 # Debian manpages
168 install -d $RPM_BUILD_ROOT%{_mandir}/man1
169 cd debian/man
170 for f in *.sgml ; do
171         base="$(basename $f .sgml)"
172         upper="$(echo ${base} | tr a-z A-Z)"
173         db2man $f
174         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
175 done
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %post   X11 -p /sbin/ldconfig
184 %postun X11 -p /sbin/ldconfig
185
186 %post   qt -p /sbin/ldconfig
187 %postun qt -p /sbin/ldconfig
188
189 %files
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/artscat
192 %attr(755,root,root) %{_bindir}/artsd
193 %attr(755,root,root) %{_bindir}/artsdsp
194 %attr(755,root,root) %{_bindir}/artsplay
195 %attr(755,root,root) %{_bindir}/artsrec
196 %attr(755,root,root) %{_bindir}/artsshell
197 %attr(755,root,root) %{_bindir}/artswrapper
198 # shared libraries
199 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
208 # lt_dlopened modules (*.la needed)
209 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
210 %{_libdir}/libartscbackend.la
211 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
212 %{_libdir}/libartsdsp.la
213 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
214 %{_libdir}/libartsdsp_st.la
215 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
216 %{_libdir}/libartsgslplayobject.la
217 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
218 %{_libdir}/libartswavplayobject.la
219 #
220 %{_libdir}/mcop
221 %{_mandir}/man1/artscat.1*
222 %{_mandir}/man1/artsd.1*
223 %{_mandir}/man1/artsdsp.1*
224 %{_mandir}/man1/artsplay.1*
225 %{_mandir}/man1/artsrec.1*
226 %{_mandir}/man1/artsshell.1*
227 %{_mandir}/man1/artswrapper.1*
228
229 %files devel
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/mcopidl
232 %attr(755,root,root) %{_libdir}/libartsflow.so
233 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
234 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
235 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
236 %attr(755,root,root) %{_libdir}/libgmcop.so
237 %attr(755,root,root) %{_libdir}/libkmedia2.so
238 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
239 %attr(755,root,root) %{_libdir}/libmcop.so
240 %attr(755,root,root) %{_libdir}/libmcop_mt.so
241 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
242 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
243 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
244 # shared libraries
245 %{_libdir}/libartsflow.la
246 %{_libdir}/libartsflow_idl.la
247 %{_libdir}/libgmcop.la
248 %{_libdir}/libkmedia2.la
249 %{_libdir}/libkmedia2_idl.la
250 %{_libdir}/libmcop.la
251 %{_libdir}/libmcop_mt.la
252 %{_libdir}/libsoundserver_idl.la
253 #
254 %{_includedir}/arts
255 %exclude %{_includedir}/arts/qiomanager.h
256 %{_mandir}/man1/mcopidl.1*
257
258 %files -n artsc-devel
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_bindir}/artsc-config
261 %attr(755,root,root) %{_libdir}/libartsc.so
262 %attr(755,root,root) %{_libdir}/libartscbackend.so
263 %attr(755,root,root) %{_libdir}/libartsdsp.so
264 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
265 %{_libdir}/libartsc.la
266 %{_includedir}/artsc
267 %{_mandir}/man1/artsc-config.1*
268
269 %files X11
270 %defattr(644,root,root,755)
271 # lt_dlopened module (.la needed)
272 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
273 %{_libdir}/libx11globalcomm.la
274
275 %files qt
276 %defattr(644,root,root,755)
277 # shared library
278 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
279
280 %files qt-devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/libqtmcop.so
283 %{_libdir}/libqtmcop.la
284 %{_includedir}/arts/qiomanager.h
This page took 0.070292 seconds and 4 git commands to generate.