]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- nas as bcond
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          stable
7 %define         _kdever         3.1
8
9 Summary:        aRts sound server
10 Summary(pl):    Serwer d¼wiêku
11 Summary(pt_BR): Servidor de sons usado pelo KDE
12 Name:           arts
13 Version:        1.1
14 Release:        5
15 Epoch:          12
16 License:        LGPL
17 Vendor:         The KDE Team
18 Group:          Libraries
19 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
20 %ifnarch sparc sparcv9 sparc64
21 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
22 %endif
23 BuildRequires:  audiofile-devel
24 BuildRequires:  glib2-devel >= 2.0.0
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 # not needed, only ./configure check for this
28 #BuildRequires: libvorbis-devel
29 #BuildRequires: mad-devel
30 %{?_with_nas:BuildRequires:     nas-devel}
31 BuildRequires:  pkgconfig
32 BuildRequires:  qt-devel >= 3.1
33 URL:            http://www.kde.org/
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _htmldir        /usr/share/doc/kde/HTML
37
38 %define         no_install_post_chrpath         1
39
40 %description
41 aRts sound server.
42
43 %description -l pl
44 Serwer d¼wiêku aRts.
45
46 %description -l pt_BR
47 O aRts é um sintetizador analógico em tempo real que é completamente
48 modular. Você pode criar sons e músicas (síntese em tempo real de
49 midi) usando pequenos módulos como oscilador para criar waveforms,
50 vários filtros, mixers, faders, etc. Você pode configurar tudo através
51 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
52 design foi escolhido para permitir que outras aplicações usem o aRts
53 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
54 outros.
55
56 %package X11
57 Summary:        X11 dependent part of aRts
58 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
59 Group:          X11/Libraries
60
61 %description X11
62 X11 dependent part of aRts.
63
64 %description X11 -l pl
65 Czê¶æ aRts wymagaj±ca X11.
66
67 %package qt
68 Summary:        QT dependend part of aRts
69 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
70 Group:          X11/Libraries
71 Requires:       %{name} >= %{version}
72 Requires:       qt >= 3.1
73
74 %description qt
75 QT dependend part of aRts.
76
77 %description qt -l pl
78 Czê¶æ aRts wymagaj±ca QT.
79
80 %package devel
81 Summary:        Sound server - header files
82 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
83 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
84 Group:          Development/Libraries
85 Requires:       qt-devel >= 3.1
86 Requires:       %{name} >= %{version}
87
88 %description devel
89 Header files required to compile programs using arts.
90
91 %description devel -l pl
92 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
93 arts.
94
95 %description devel -l pt_BR
96 Arquivos para desenvolvimento com o o aRts.
97
98 %package glib
99 Summary:        GLib dependend part of aRts
100 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
101 Group:          X11/Libraries
102 Requires:       glib >= 1.2.6
103
104 %description glib
105 GLib dependend part of aRts.
106
107 %description glib -l pl
108 Czê¶æ aRts wymagaj±ca GLib.
109
110 %prep
111 %setup -q
112
113 %build
114 kde_htmldir="%{_htmldir}"; export kde_htmldir
115 kde_icondir="%{_pixmapsdir}"; export kde_icondir
116
117 %configure \
118         --%{?debug:en}%{!?debug:dis}able-debug \
119         --enable-final \
120         --with-xinerama \
121         --with%{?_without_alsa:out}-alsa
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install DESTDIR=$RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post X11   -p /sbin/ldconfig
134 %postun X11 -p /sbin/ldconfig
135
136 %post qt   -p /sbin/ldconfig
137 %postun qt -p /sbin/ldconfig
138
139 %post glib   -p /sbin/ldconfig
140 %postun glib -p /sbin/ldconfig
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/artscat
148 %attr(755,root,root) %{_bindir}/artsd
149 %attr(755,root,root) %{_bindir}/artsdsp
150 %attr(755,root,root) %{_bindir}/artsplay
151 %attr(755,root,root) %{_bindir}/artsrec
152 %attr(755,root,root) %{_bindir}/artsshell
153 %attr(755,root,root) %{_bindir}/artswrapper
154 %attr(755,root,root) %{_bindir}/testdhandle
155 %{_libdir}/lib[!gqx]*.la
156 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
157 %{_libdir}/mcop
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/artsc-config
162 %attr(755,root,root) %{_bindir}/mcopidl
163 %{_libdir}/*.so
164 %{_includedir}/arts
165 %{_includedir}/artsc
166
167 %files X11
168 %defattr(644,root,root,755)
169 %{_libdir}/libx11globalcomm.la
170 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
171
172 %files glib
173 %defattr(644,root,root,755)
174 %{_libdir}/libgmcop.la
175 %attr(755,root,root) %{_libdir}/libgmcop.so.*
176
177 %files qt
178 %defattr(644,root,root,755)
179 %{_libdir}/libqtmcop.la
180 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.043846 seconds and 4 git commands to generate.