]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- rebuild with ac, rel.2
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6 %define         _state          stable
7 %define         _ver            1.2.2
8 #%%define               _snap           040110
9 %define         _kdever         3.2.2
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        2
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
21 # Source0-md5:  83ca7e7a33c55de34e12bfc360190795
22 # http://download.kde.org/stable/3.2.1/src/arts-1.2.1.tar.bz2
23 #Source0:       http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
24 URL:            http://www.kde.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.13-3
31 BuildRequires:  esound-devel
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 Obsoletes:      arts-glib
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 aRts sound server.
44
45 %description -l pl
46 Serwer d¼wiêku aRts.
47
48 %description -l pt_BR
49 O aRts é um sintetizador analógico em tempo real que é completamente
50 modular. Você pode criar sons e músicas (síntese em tempo real de
51 midi) usando pequenos módulos como oscilador para criar waveforms,
52 vários filtros, mixers, faders, etc. Você pode configurar tudo através
53 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
54 design foi escolhido para permitir que outras aplicações usem o aRts
55 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
56 outros.
57
58 %package devel
59 Summary:        Sound server - header files
60 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
61 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
62 Group:          Development/Libraries
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 # not necessary for all libs (e.g. mcop), but propagated by artsflow
65 %{?with_alsa:Requires:  alsa-lib-devel}
66 Requires:       audiofile-devel
67 Requires:       esound-devel
68 Requires:       glib2-devel >= 2.0.0
69 Requires:       libmad-devel
70 Requires:       libvorbis-devel
71 %{?with_nas:Requires:   nas-devel}
72
73 %description devel
74 Header files required to compile programs using arts.
75
76 %description devel -l pl
77 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
78 arts.
79
80 %description devel -l pt_BR
81 Arquivos para desenvolvimento com o o aRts.
82
83 # separate from arts-devel because they are mostly independent and
84 # have very # different deps  there is no artsc base - it would be
85 # small and would require arts - so there is no reason to separate
86 %package -n artsc-devel
87 Summary:        Development files for artsc libraries
88 Summary(pl):    Pliki programistyczne bibliotek artsc
89 Group:          Development/Libraries
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91 Requires:       glib2-devel >= 2.0.0
92 Conflicts:      arts-devel < 12:1.2.0.031126-2
93
94 %description -n artsc-devel
95 Development files for artsc libraries (C interface to aRts sound
96 system).
97
98 %description -n artsc-devel -l pl
99 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
100 d¼wiêku aRts).
101
102 %package X11
103 Summary:        X11 dependent part of aRts
104 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
105 Group:          X11/Libraries
106 Requires:       %{name} = %{epoch}:%{version}-%{release}
107
108 %description X11
109 X11 dependent part of aRts (x11globalcomm module).
110
111 %description X11 -l pl
112 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
113
114 %package qt
115 Summary:        QT dependend part of aRts
116 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
117 Group:          X11/Libraries
118 Requires:       %{name} = %{epoch}:%{version}-%{release}
119 Requires:       qt >= 6:3.2.1-4
120
121 %description qt
122 QT dependend part of aRts (qtmcop library).
123
124 %description qt -l pl
125 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
126
127 %package qt-devel
128 Summary:        Development files for qtmcop library
129 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
130 Group:          X11/Development/Libraries
131 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
132 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
133 Requires:       qt-devel >= 6:3.2.1-4
134
135 %description qt-devel
136 Development files for qtmcop library.
137
138 %description qt-devel -l pl
139 Pliki programistyczne dla biblioteki qtmcop.
140
141 %prep
142 # qboosh leave it this way, 'cause its easier to change to snap later
143 %setup -q -n %{name}-%{version}
144
145 %build
146 cp /usr/share/automake/config.sub admin
147 %configure \
148         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
149         --%{?debug:en}%{!?debug:dis}able-debug \
150         --disable-rpath \
151         --enable-final \
152         --with-qt-libraries=%{_libdir} \
153         --with%{!?with_alsa:out}-alsa
154
155 %{__make}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 # Debian manpages
164 install -d $RPM_BUILD_ROOT%{_mandir}/man1
165 cd debian/man
166 for f in *.sgml ; do
167         base="$(basename $f .sgml)"
168         upper="$(echo ${base} | tr a-z A-Z)"
169         db2man $f
170         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
171 done
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %post   X11 -p /sbin/ldconfig
180 %postun X11 -p /sbin/ldconfig
181
182 %post   qt -p /sbin/ldconfig
183 %postun qt -p /sbin/ldconfig
184
185 %files
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/artscat
188 %attr(755,root,root) %{_bindir}/artsd
189 %attr(755,root,root) %{_bindir}/artsdsp
190 %attr(755,root,root) %{_bindir}/artsplay
191 %attr(755,root,root) %{_bindir}/artsrec
192 %attr(755,root,root) %{_bindir}/artsshell
193 %attr(755,root,root) %{_bindir}/artswrapper
194 # shared libraries
195 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
196 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
197 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
198 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
199 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
204 # lt_dlopened modules (*.la needed)
205 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
206 %{_libdir}/libartscbackend.la
207 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
208 %{_libdir}/libartsdsp.la
209 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
210 %{_libdir}/libartsdsp_st.la
211 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
212 %{_libdir}/libartsgslplayobject.la
213 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
214 %{_libdir}/libartswavplayobject.la
215 #
216 %{_libdir}/mcop
217 %{_mandir}/man1/artscat.1*
218 %{_mandir}/man1/artsd.1*
219 %{_mandir}/man1/artsdsp.1*
220 %{_mandir}/man1/artsplay.1*
221 %{_mandir}/man1/artsrec.1*
222 %{_mandir}/man1/artsshell.1*
223 %{_mandir}/man1/artswrapper.1*
224
225 %files devel
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_bindir}/mcopidl
228 %attr(755,root,root) %{_libdir}/libartsflow.so
229 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
230 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
231 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
232 %attr(755,root,root) %{_libdir}/libgmcop.so
233 %attr(755,root,root) %{_libdir}/libkmedia2.so
234 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
235 %attr(755,root,root) %{_libdir}/libmcop.so
236 %attr(755,root,root) %{_libdir}/libmcop_mt.so
237 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
238 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
239 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
240 # shared libraries
241 %{_libdir}/libartsflow.la
242 %{_libdir}/libartsflow_idl.la
243 %{_libdir}/libgmcop.la
244 %{_libdir}/libkmedia2.la
245 %{_libdir}/libkmedia2_idl.la
246 %{_libdir}/libmcop.la
247 %{_libdir}/libmcop_mt.la
248 %{_libdir}/libsoundserver_idl.la
249 #
250 %{_includedir}/arts
251 %exclude %{_includedir}/arts/qiomanager.h
252 %{_mandir}/man1/mcopidl.1*
253
254 %files -n artsc-devel
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/artsc-config
257 %attr(755,root,root) %{_libdir}/libartsc.so
258 %attr(755,root,root) %{_libdir}/libartscbackend.so
259 %attr(755,root,root) %{_libdir}/libartsdsp.so
260 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
261 %{_libdir}/libartsc.la
262 %{_includedir}/artsc
263 %{_mandir}/man1/artsc-config.1*
264
265 %files X11
266 %defattr(644,root,root,755)
267 # lt_dlopened module (.la needed)
268 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
269 %{_libdir}/libx11globalcomm.la
270
271 %files qt
272 %defattr(644,root,root,755)
273 # shared library
274 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
275
276 %files qt-devel
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_libdir}/libqtmcop.so
279 %{_libdir}/libqtmcop.la
280 %{_includedir}/arts/qiomanager.h
This page took 0.101552 seconds and 4 git commands to generate.