]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- BR: perl-SGMLS (maHo <lukasz@mach.com.pl>)
[packages/arts.git] / arts.spec
1 #
2 # TODO: consider:
3 # - separating artsc and its -devel? (but what are artsc deps?)
4 #
5 # Conditional build:
6 %bcond_without  alsa    # disable ALSA support
7 %bcond_with     nas     # enable NAS support
8 #
9
10 %define         _state          snapshots
11 %define         _ver            1.2.0
12 %define         _snap           031204
13
14 Summary:        aRts sound server
15 Summary(pl):    Serwer d¼wiêku
16 Summary(pt_BR): Servidor de sons usado pelo KDE
17 Name:           arts
18 Version:        %{_ver}.%{_snap}
19 Release:        1
20 Epoch:          12
21 License:        LGPL
22 Group:          Libraries
23 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
24 Source0:        http://www.kernel.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
25 # Source0-md5:  ed23773940e2b97e31a6850e2334bfe5
26 URL:            http://www.kde.org/
27 %{?with_alsa:BuildRequires:     alsa-lib-devel}
28 BuildRequires:  audiofile-devel
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  docbook-dtd41-sgml
32 BuildRequires:  docbook-utils
33 BuildRequires:  esound-devel
34 BuildRequires:  glib2-devel >= 2.0.0
35 BuildRequires:  libmad-devel
36 BuildRequires:  libtool >= 2:1.5-2
37 BuildRequires:  libvorbis-devel
38 %{?with_nas:BuildRequires:      nas-devel}
39 BuildRequires:  pkgconfig
40 BuildRequires:  qt-devel >= 6:3.2.1-4
41 BuildRequires:  perl-SGMLS
42 Obsoletes:      arts-glib
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 aRts sound server.
47
48 %description -l pl
49 Serwer d¼wiêku aRts.
50
51 %description -l pt_BR
52 O aRts é um sintetizador analógico em tempo real que é completamente
53 modular. Você pode criar sons e músicas (síntese em tempo real de
54 midi) usando pequenos módulos como oscilador para criar waveforms,
55 vários filtros, mixers, faders, etc. Você pode configurar tudo através
56 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
57 design foi escolhido para permitir que outras aplicações usem o aRts
58 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
59 outros.
60
61 %package devel
62 Summary:        Sound server - header files
63 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
64 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
65 Group:          Development/Libraries
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67 # not necessary for all libs (e.g. mcop), but propagated by artsflow
68 %{?with_alsa:Requires:  alsa-lib-devel}
69 Requires:       audiofile-devel
70 Requires:       esound-devel
71 Requires:       glib2-devel >= 2.0.0
72 Requires:       libmad-devel
73 Requires:       libvorbis-devel
74 %{?with_nas:Requires:   nas-devel}
75
76 %description devel
77 Header files required to compile programs using arts.
78
79 %description devel -l pl
80 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
81 arts.
82
83 %description devel -l pt_BR
84 Arquivos para desenvolvimento com o o aRts.
85
86 # separate from arts-devel because they are mostly independent and have very
87 # different deps
88 # there is no artsc base - it would be small and would require arts - so there
89 # is no reason to separate
90 %package -n artsc-devel
91 Summary:        Development files for artsc libraries
92 Summary(pl):    Pliki programistyczne bibliotek artsc
93 Group:          Development/Libraries
94 Requires:       %{name} = %{epoch}:%{version}-%{release}
95 Requires:       glib2-devel >= 2.0.0
96 Conflicts:      arts-devel < 12:1.2.0.031126-2
97
98 %description -n artsc-devel
99 Development files for artsc libraries (C interface to aRts sound
100 system).
101
102 %description -n artsc-devel -l pl
103 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
104 d¼wiêku aRts).
105
106 %package X11
107 Summary:        X11 dependent part of aRts
108 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
109 Group:          X11/Libraries
110 Requires:       %{name} = %{epoch}:%{version}-%{release}
111
112 %description X11
113 X11 dependent part of aRts (x11globalcomm module).
114
115 %description X11 -l pl
116 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
117
118 %package qt
119 Summary:        QT dependend part of aRts
120 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
121 Group:          X11/Libraries
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123 Requires:       qt >= 6:3.2.1-4
124
125 %description qt
126 QT dependend part of aRts (qtmcop library).
127
128 %description qt -l pl
129 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
130
131 %package qt-devel
132 Summary:        Development files for qtmcop library
133 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
134 Group:          X11/Development/Libraries
135 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
136 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
137 Requires:       qt-devel >= 6:3.2.1-4
138
139 %description qt-devel
140 Development files for qtmcop library.
141
142 %description qt-devel -l pl
143 Pliki programistyczne dla biblioteki qtmcop.
144
145 %prep
146 %setup -q -n %{name}-%{_snap}
147
148 %build
149 %{__make} -f admin/Makefile.common cvs
150
151 %configure \
152         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
153         --%{?debug:en}%{!?debug:dis}able-debug \
154         --disable-rpath \
155         --enable-final \
156         --with%{!?with_alsa:out}-alsa
157
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 # Debian manpages
167 install -d $RPM_BUILD_ROOT%{_mandir}/man1
168 cd debian
169 for f in *.sgml ; do
170         base="$(basename $f .sgml)"
171         upper="$(echo ${base} | tr a-z A-Z)"
172         db2man $f
173         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
174 done
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %post   X11 -p /sbin/ldconfig
183 %postun X11 -p /sbin/ldconfig
184
185 %post   qt -p /sbin/ldconfig
186 %postun qt -p /sbin/ldconfig
187
188 %files
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/artscat
191 %attr(755,root,root) %{_bindir}/artsd
192 %attr(755,root,root) %{_bindir}/artsdsp
193 %attr(755,root,root) %{_bindir}/artsplay
194 %attr(755,root,root) %{_bindir}/artsrec
195 %attr(755,root,root) %{_bindir}/artsshell
196 %attr(755,root,root) %{_bindir}/artswrapper
197 # shared libraries
198 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
199 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
207 # lt_dlopened modules (*.la needed)
208 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
209 %{_libdir}/libartscbackend.la
210 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
211 %{_libdir}/libartsdsp.la
212 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
213 %{_libdir}/libartsdsp_st.la
214 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
215 %{_libdir}/libartsgslplayobject.la
216 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
217 %{_libdir}/libartswavplayobject.la
218 #
219 %{_libdir}/mcop
220 %{_mandir}/man1/artscat.1*
221 %{_mandir}/man1/artsd.1*
222 %{_mandir}/man1/artsdsp.1*
223 %{_mandir}/man1/artsplay.1*
224 %{_mandir}/man1/artsrec.1*
225 %{_mandir}/man1/artsshell.1*
226 %{_mandir}/man1/artswrapper.1*
227
228 %files devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_bindir}/mcopidl
231 %attr(755,root,root) %{_libdir}/libartsflow.so
232 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
233 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
234 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
235 %attr(755,root,root) %{_libdir}/libgmcop.so
236 %attr(755,root,root) %{_libdir}/libkmedia2.so
237 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
238 %attr(755,root,root) %{_libdir}/libmcop.so
239 %attr(755,root,root) %{_libdir}/libmcop_mt.so
240 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
241 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
242 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
243 # shared libraries
244 %{_libdir}/libartsflow.la
245 %{_libdir}/libartsflow_idl.la
246 %{_libdir}/libgmcop.la
247 %{_libdir}/libkmedia2.la
248 %{_libdir}/libkmedia2_idl.la
249 %{_libdir}/libmcop.la
250 %{_libdir}/libmcop_mt.la
251 %{_libdir}/libsoundserver_idl.la
252 #
253 %{_includedir}/arts
254 %exclude %{_includedir}/arts/qiomanager.h
255 %{_mandir}/man1/mcopidl.1*
256
257 %files -n artsc-devel
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_bindir}/artsc-config
260 %attr(755,root,root) %{_libdir}/libartsc.so
261 %attr(755,root,root) %{_libdir}/libartscbackend.so
262 %attr(755,root,root) %{_libdir}/libartsdsp.so
263 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
264 %{_libdir}/libartsc.la
265 %{_includedir}/artsc
266 %{_mandir}/man1/artsc-config.1*
267
268 %files X11
269 %defattr(644,root,root,755)
270 # lt_dlopened module (.la needed)
271 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
272 %{_libdir}/libx11globalcomm.la
273
274 %files qt
275 %defattr(644,root,root,755)
276 # shared library
277 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
278
279 %files qt-devel
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/libqtmcop.so
282 %{_libdir}/libqtmcop.la
283 %{_includedir}/arts/qiomanager.h
This page took 0.115179 seconds and 3 git commands to generate.