]> git.pld-linux.org Git - packages/arpack-ng.git/blob - arpack-ng.spec
4227df50dd3f56e15fa5858bbe367240c9a7390b
[packages/arpack-ng.git] / arpack-ng.spec
1 # TODO: MPI, iso_c_binding
2 #
3 # Conditional build:
4 %bcond_without  static_libs
5
6 Summary:        Subroutines for solving large scale eigenvalue problems
7 Summary(pl.UTF-8):      Rozwiązywanie zagadnienia własnego dla dużych macierzy
8 Name:           arpack-ng
9 Version:        3.9.0
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/opencollab/arpack-ng/tags
14 Source0:        https://github.com/opencollab/arpack-ng/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  e28fdbe33ee44a16e2733c180ec2a2bd
16 URL:            https://github.com/opencollab/arpack-ng
17 BuildRequires:  blas-devel
18 BuildRequires:  cmake >= 3.0
19 BuildRequires:  gcc-g77
20 BuildRequires:  lapack-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  pkgconfig
23 Provides:       arpack = %{version}-%{release}
24 Obsoletes:      arpack < 3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 ARPACK software is capable of solving large scale symmetric,
29 nonsymmetric, and generalized eigenproblems from significant
30 application areas. The software is designed to compute a few (k)
31 eigenvalues with user specified features such as those of largest real
32 part or largest magnitude. Storage requirements are on the order of
33 n*k locations. No auxiliary storage is required. A set of Schur basis
34 vectors for the desired k-dimensional eigen-space is computed which is
35 numerically orthogonal to working precision. Numerically accurate
36 eigenvectors are available on request.
37
38 %description -l pl.UTF-8
39 Rozwiązywanie zagadnienia własnego (symetrycznego, niesymetrycznego,
40 ogólnego) dla dużych macierzy. Macierz może być dowolna, przy czym
41 procedury działają szczególnie dobrze w przypadku dużych macierzy
42 rzadkich bądź macierzy ze znaną strukturą. Biblioteka służy do
43 obliczenia kilku (k) wartości własnych o zadanych z góry własnościach,
44 takich jak największa (najmniejsza) część rzeczywista albo największy
45 (najmniejszy) moduł. Wymagania pamięciowe są rzędu n*k, żadna
46 dodatkowa pamięć (np. dyskowa) nie jest wymagana.
47
48 %package devel
49 Summary:        ARPACK development files
50 Summary(pl.UTF-8):      Pliki programistyczne ARPACK
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       blas-devel
54 Requires:       lapack-devel
55 Provides:       arpack-devel = %{version}-%{release}
56 Obsoletes:      arpack-devel < 3
57
58 %description devel
59 ARPACK development files.
60
61 %description devel -l pl.UTF-8
62 Pliki programistyczne ARPACK.
63
64 %package static
65 Summary:        Static ARPACK library
66 Summary(pl.UTF-8):      Statyczna biblioteka ARPACK
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69 Provides:       arpack-static = %{version}-%{release}
70 Obsoletes:      arpack-static < 3
71
72 %description static
73 Static ARPACK library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka ARPACK.
77
78 %prep
79 %setup -q
80
81 %build
82 %if %{with static_libs}
83 install -d build-static
84 cd build-static
85 %cmake .. \
86         -DBUILD_SHARED_LIBS=OFF \
87         -DCMAKE_INSTALL_INCLUDEDIR=include \
88         -DICB=ON
89 %{__make}
90 cd ..
91 %endif
92 install -d build
93 cd build
94 %cmake .. \
95         -DICB=ON
96 %{__make}
97 cd ..
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %if %{with static_libs}
103 %{__make} -C build-static install \
104         DESTDIR=$RPM_BUILD_ROOT
105 %endif
106
107 %{__make} -C build install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # not installed by cmake
111 cp -p build/{arpackSolver,parpack}.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc CHANGES COPYING PARPACK_CHANGES README.md TODO
122 %attr(755,root,root) %{_libdir}/libarpack.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libarpack.so.2
124
125 %files devel
126 %defattr(644,root,root,755)
127 %doc DOCUMENTS/*.doc
128 %attr(755,root,root) %{_libdir}/libarpack.so
129 %{_includedir}/arpack-ng
130 %{_pkgconfigdir}/arpack.pc
131 %{_pkgconfigdir}/arpackSolver.pc
132 %{_pkgconfigdir}/parpack.pc
133 %{_libdir}/cmake/arpackng
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libarpack.a
139 %endif
This page took 0.204836 seconds and 2 git commands to generate.