]> git.pld-linux.org Git - packages/arm-trusted-firmware.git/blob - arm-trusted-firmware.spec
03fc94be8b9f1ae6880f7b15cd793a2eebd6666e
[packages/arm-trusted-firmware.git] / arm-trusted-firmware.spec
1 Summary:        ARM Trusted Firmware
2 Name:           arm-trusted-firmware
3 Version:        2.7.0
4 Release:        1
5 License:        BSD
6 Group:          Base/Kernel
7 Source0:        https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot/trusted-firmware-a-%{version}.tar.gz
8 # Source0-md5:  027614c144094b203e8e296ab7b076fe
9 URL:            https://developer.arm.com/tools-and-software/open-source-software/firmware/trusted-firmware
10 BuildRequires:  crossarm-gcc
11 BuildRequires:  dtc
12 ExclusiveArch:  aarch64
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 ARM Trusted firmware is a reference implementation of secure world
17 software for ARMv8-A including Exception Level 3 (EL3) software. It
18 provides a number of standard ARM interfaces like Power State
19 Coordination (PSCI), Trusted Board Boot Requirements (TBBR) and Secure
20 Monitor.
21
22 Note: the contents of this package are generally just consumed by
23 bootloaders such as u-boot. As such the binaries aren't of general
24 interest to users.
25
26 %package -n arm-trusted-firmware-armv8
27 Summary:        ARM Trusted Firmware for ARMv8-A
28
29 %description -n arm-trusted-firmware-armv8
30 ARM Trusted Firmware binaries for various ARMv8-A SoCs.
31
32 Note: the contents of this package are generally just consumed by
33 bootloaders such as u-boot. As such the binaries aren't of general
34 interest to users.
35
36 Note: the contents of this package are generally just consumed by
37 bootloaders such as u-boot. As such the binaries aren't of general
38 interest to users.
39
40 %prep
41 %setup -q -n trusted-firmware-a-%{version}
42
43 %build
44 for soc in rk3399; do
45 %{__make} \
46         V=1 \
47         HOSTCC="%{__cc} %{rpmcflags}" \
48         CROSS_COMPILE="" \
49         M0_CROSS_COMPILE="arm-linux-gnueabi-" \
50         PLAT="$soc" \
51         bl31
52 done
53 %{__make} -C tools/fiptool \
54         V=1 \
55         HOSTCC="%{__cc}" \
56         HOSTCCFLAGS="%{rpmcflags}" \
57         CPPFLAGS="%{rpmcppflags}"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}}
62
63 for soc in rk3399; do
64 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/$soc
65  for file in bl31/bl31.elf m0/rk3399m0.bin m0/rk3399m0.elf; do
66   if [ -f build/$soc/release/$file ]; then
67     cp -p build/$soc/release/$file $RPM_BUILD_ROOT%{_datadir}/%{name}/$soc
68   fi
69  done
70 done
71
72 cp -p tools/fiptool/fiptool $RPM_BUILD_ROOT%{_bindir}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files -n arm-trusted-firmware-armv8
78 %defattr(644,root,root,755)
79 %doc readme.rst
80 %attr(755,root,root) %{_bindir}/fiptool
81 %{_datadir}/%{name}
This page took 0.112804 seconds and 2 git commands to generate.