]> git.pld-linux.org Git - packages/argyllcms.git/blob - argyllcms.spec
fix build with gcc 10
[packages/argyllcms.git] / argyllcms.spec
1 Summary:        ICC compatible color management system
2 Summary(pl.UTF-8):      System zarządzania kolorami kompatybilny z ICC
3 Name:           argyllcms
4 Version:        1.9.2
5 Release:        1
6 License:        AGPL v3, MIT, GPL v2+, LGPL v2.1+, FDL v1.3
7 Group:          X11/Applications/Graphics
8 Source0:        https://people.freedesktop.org/~hughsient/releases/h%{name}-%{version}.tar.xz
9 # Source0-md5:  49d71597286fd1b7ab575e5b17a7e307
10 Patch0:         %{name}-link.patch
11 URL:            http://www.argyllcms.com/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  libjpeg-devel
15 BuildRequires:  libpng-devel
16 BuildRequires:  libtiff-devel
17 BuildRequires:  libtool >= 1:1.4.2
18 BuildRequires:  libusb-devel >= 1.0.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xorg-lib-libX11-devel
22 BuildRequires:  xorg-lib-libXScrnSaver-devel
23 BuildRequires:  xorg-lib-libXext-devel
24 BuildRequires:  xorg-lib-libXinerama-devel
25 BuildRequires:  xorg-lib-libXrandr-devel
26 BuildRequires:  xorg-lib-libXxf86vm-devel
27 BuildRequires:  xz
28 BuildRequires:  zlib-devel
29 Obsoletes:      udev-argyllcms
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The Argyll color management system supports accurate ICC profile
34 creation for acquisition devices, CMYK printers, film recorders and
35 calibration and profiling of displays.
36
37 Spectral sample data is supported, allowing a selection of illuminants
38 observer types, and paper fluorescent whitener additive compensation.
39 Profiles can also incorporate source specific gamut mappings for
40 perceptual and saturation intents. Gamut mapping and profile linking
41 uses the CIECAM02 appearance model, a unique gamut mapping algorithm,
42 and a wide selection of rendering intents. It also includes code for
43 the fastest portable 8 bit raster color conversion engine available
44 anywhere, as well as support for fast, fully accurate 16 bit
45 conversion. Device color gamuts can also be viewed and compared using
46 a VRML viewer.
47
48 %description -l pl.UTF-8
49 System zarządzania kolorami Argyll obsługuje tworzenie dokładnych
50 profili ICC dla urządzeń skanujących, drukarek CMYK i kamer oraz
51 kalibrację i profilowanie wyświetlaczy.
52
53 Obsługiwane są dane próbek widmowych, co pozwala na wybór typów
54 obserwatora oświetlenia oraz kompensację addytywną fluorescencyjnych
55 wybielaczy papieru. Profile mogą zawierać także zależne od źródła
56 odwzorowania podzbioru kolorów (gamut) pod kątem postrzegania i
57 nasycenia. Odwzorowanie kolorów i wiązanie profili wykorzystuje model
58 wyglądu kolorów CIECAM02, unikalny algorytm odwzorowania podzbioru
59 kolorów oraz szeroki wybór celu renderingu. Zawiera także kod
60 najszybszego dostępnego przenośnego 8-bitowego rastrowego silnika
61 konwersji kolorów, a także obsługę szybkiej, dokładniej 16-bitowej
62 konwersji. Podzbiór kolorów urządzeń można oglądać i porównywać przy
63 użyciu przeglądarki VRML.
64
65 %package doc
66 Summary:        Argyll CMS documentation
67 Summary(pl.UTF-8):      Dokumentacja systemu Argyll CMS
68 Group:          Documentation
69 # Does not really make sense without Argyll CMS itself
70 Requires:       %{name} = %{version}-%{release}
71
72 %description doc
73 The Argyll color management system supports accurate ICC profile
74 creation for acquisition devices, CMYK printers, film recorders and
75 calibration and profiling of displays.
76
77 This package contains the Argyll color management system
78 documentation.
79
80 %description doc -l pl.UTF-8
81 System zarządzania kolorami Argyll obsługuje tworzenie dokładnych
82 profili ICC dla urządzeń skanujących, drukarek CMYK i kamer oraz
83 kalibrację i profilowanie wyświetlaczy.
84
85 Ten pakiet zawiera dokumentację do systemu zarządzania kolorami
86 Argyll.
87
88 %prep
89 %setup -q -n h%{name}-%{version}
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 export CFLAGS="%{rpmcflags} -fcommon"
99 %configure \
100         --disable-static
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # they shouldn't put Makefile.am to ref_DATA
109 %{__rm} $RPM_BUILD_ROOT%{_datadir}/color/argyll/ref/Makefile.am
110
111 # no -devel package (headers not exported)
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.{so,la}
113
114 # packaged as %doc
115 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/argyll
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS Readme.txt
126 %attr(755,root,root) %{_bindir}/applycal
127 %attr(755,root,root) %{_bindir}/average
128 %attr(755,root,root) %{_bindir}/cb2ti3
129 %attr(755,root,root) %{_bindir}/cctiff
130 %attr(755,root,root) %{_bindir}/ccttest
131 %attr(755,root,root) %{_bindir}/ccxxmake
132 %attr(755,root,root) %{_bindir}/chartread
133 %attr(755,root,root) %{_bindir}/collink
134 %attr(755,root,root) %{_bindir}/colprof
135 %attr(755,root,root) %{_bindir}/colverify
136 %attr(755,root,root) %{_bindir}/dispcal
137 %attr(755,root,root) %{_bindir}/dispread
138 %attr(755,root,root) %{_bindir}/dispwin
139 %attr(755,root,root) %{_bindir}/extracticc
140 %attr(755,root,root) %{_bindir}/extractttag
141 %attr(755,root,root) %{_bindir}/fakeCMY
142 %attr(755,root,root) %{_bindir}/fakeread
143 %attr(755,root,root) %{_bindir}/greytiff
144 %attr(755,root,root) %{_bindir}/iccdump
145 %attr(755,root,root) %{_bindir}/iccgamut
146 %attr(755,root,root) %{_bindir}/icclu
147 %attr(755,root,root) %{_bindir}/icctest
148 %attr(755,root,root) %{_bindir}/illumread
149 %attr(755,root,root) %{_bindir}/invprofcheck
150 %attr(755,root,root) %{_bindir}/kodak2ti3
151 %attr(755,root,root) %{_bindir}/mppcheck
152 %attr(755,root,root) %{_bindir}/mpplu
153 %attr(755,root,root) %{_bindir}/mppprof
154 %attr(755,root,root) %{_bindir}/oeminst
155 %attr(755,root,root) %{_bindir}/pathplot
156 %attr(755,root,root) %{_bindir}/printcal
157 %attr(755,root,root) %{_bindir}/printtarg
158 %attr(755,root,root) %{_bindir}/profcheck
159 %attr(755,root,root) %{_bindir}/refine
160 %attr(755,root,root) %{_bindir}/revfix
161 %attr(755,root,root) %{_bindir}/scanin
162 %attr(755,root,root) %{_bindir}/simpprof
163 %attr(755,root,root) %{_bindir}/spec2cie
164 %attr(755,root,root) %{_bindir}/specplot
165 %attr(755,root,root) %{_bindir}/splitti3
166 %attr(755,root,root) %{_bindir}/spotread
167 %attr(755,root,root) %{_bindir}/synthcal
168 %attr(755,root,root) %{_bindir}/synthread
169 %attr(755,root,root) %{_bindir}/targen
170 %attr(755,root,root) %{_bindir}/tiffgamut
171 %attr(755,root,root) %{_bindir}/txt2ti3
172 %attr(755,root,root) %{_bindir}/viewgam
173 %attr(755,root,root) %{_bindir}/xicclu
174 %attr(755,root,root) %{_libdir}/libargyll.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libargyll.so.0
176 %attr(755,root,root) %{_libdir}/libargyllicc.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libargyllicc.so.0
178 %attr(755,root,root) %{_libdir}/libimdi.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libimdi.so.0
180 %dir %{_datadir}/color/argyll
181 %{_datadir}/color/argyll/ref
182
183 %files doc
184 %defattr(644,root,root,755)
185 %doc doc/*.html doc/*.jpg doc/*.txt
This page took 0.062679 seconds and 4 git commands to generate.