]> git.pld-linux.org Git - packages/aqdatabase.git/blob - aqdatabase.spec
- new
[packages/aqdatabase.git] / aqdatabase.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        AqDatabase - database used by AqFinance
6 Summary(pl.UTF-8):      AqDatabase - baza danych wykorzystywana przez AqFinance
7 Name:           aqdatabase
8 Version:        1.0.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 # https://www.aquamaniac.de/sites/download/packages.php
13 Source0:        https://www.aquamaniac.de/sites/download/download.php?package=14&release=200&file=01&dummy=/%{name}-%{version}.tar.gz
14 # Source0-md5:  38042ee1e62b58b2521de55672b5b483
15 Patch0:         %{name}-pc.patch
16 URL:            https://www.aquamaniac.de/sites/aqfinance/
17 #BuildRequires: autoconf >= 2.60
18 #BuildRequires: automake
19 BuildRequires:  gettext-tools
20 BuildRequires:  gmp-devel
21 BuildRequires:  gwenhywfar-devel >= 4
22 Requires:       gwenhywfar >= 4
23 #BuildRequires: libtool
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         ver_cmake       %(echo %{version} | cut -d. -f 1-2)
27
28 %description
29 AqDatabase - database used by AqFinance.
30
31 %description -l pl.UTF-8
32 AqDatabase - baza danych wykorzystywana przez AqFinance
33
34 %package devel
35 Summary:        Header files for AqDatabase library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AqDatabase
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       gwenhywfar-devel >= 4
40
41 %description devel
42 Header files for AqDatabase library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki AqDatabase.
46
47 %package static
48 Summary:        Static AqDatabase library
49 Summary(pl.UTF-8):      Statyczna biblioteka AqDatabase
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static AqDatabase library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka AqDatabase.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 # workaround to build without headers installed
64 install -d aqdatabase
65 cd aqdatabase
66 ln -sf ../src/lib/*.h .
67 ln -sf ../src/*.h .
68
69 %build
70 %configure \
71         %{!?with_static_libs:--disable-static}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 # obsoleted by pkg-config
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libaqdatabase.la
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS README
93 %attr(755,root,root) %{_libdir}/libaqdatabase.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libaqdatabase.so.1
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libaqdatabase.so
99 %{_includedir}/aqdatabase
100 %{_datadir}/aqdatabase
101 %{_pkgconfigdir}/aqdatabase.pc
102
103 %if %{with static_libs}
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/libaqdatabase.a
107 %endif
This page took 0.101717 seconds and 3 git commands to generate.