]> git.pld-linux.org Git - packages/apport.git/blob - apport.spec
- drop patch2 (RPMSourcePackage - breaks apport)
[packages/apport.git] / apport.spec
1 Summary:        Read, write, and modify problem reports
2 Name:           apport
3 Version:        0.108.2
4 Release:        1
5 License:        GPL
6 Group:          Applications/System
7 Source0:        https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
8 # Source0-md5:  b2eb9a3b1168329ae7cdeb2a988d3443
9 Source1:        %{name}.init
10 Source2:        %{name}-backend-pld.py
11 Patch0:         %{name}-pager.patch
12 Patch1:         %{name}-crashdb.patch
13 URL:            https://wiki.ubuntu.com/Apport
14 BuildRequires:  gettext
15 BuildRequires:  intltool
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 #BuildRequires: tetex-format-pdflatex
19 #BuildRequires: tetex-latex
20 Requires(post,postun):  hicolor-icon-theme
21 Requires(post,postun):  shared-mime-info
22 Requires(post,preun):   /sbin/chkconfig
23 Requires:       lsb-release
24 Requires:       python-launchpad-bugs
25 Requires:       python-rpm
26 Requires:       rc-scripts
27 Requires:       yum
28 # Need the ability to use pipes in /proc/sys/kernel/core_pattern
29 # seems only 2.6.24 allows command line params
30 Requires:       uname(release) >= 2.6.24
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 apport automatically collects data from crashed processes and compiles
36 a problem report in /var/crash/.
37
38 This package also provides apport's python libraries and a command
39 line frontend for browsing and handling the crash reports.
40
41 See <https://wiki.ubuntu.com/AutomatedProblemReports> for more
42 information.
43
44 %package gtk
45 Summary:        GTK frontend for the apport crash report system
46 Group:          Applications/System
47 Requires:       procps
48 Requires:       python-pygtk-glade
49 Requires:       python-pygtk-gtk
50 Requires:       python-pyxdg
51
52 %description gtk
53 apport automatically collects data from crashed processes and compiles
54 a problem report in /var/crash/.
55
56 This package provides a GTK frontend for browsing and handling the
57 crash reports.
58
59 %package qt
60 Summary:        Qt4 frontend for the apport crash report system
61 Group:          Applications/System
62 Requires:       procps
63 Requires:       python-PyQt4
64 Requires:       python-pyxdg
65
66 %description qt
67 apport automatically collects data from crashed processes and compiles
68 a problem report in /var/crash/.
69
70 This package provides a Qt4 frontend for browsing and handling the
71 crash reports.
72
73 %package retrace
74 Summary:        Tools for reprocessing Apport crash reports
75 Group:          Applications/System
76
77 %description retrace
78 apport-retrace recombines an Apport crash report (either a file or a
79 Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
80 stack traces.
81
82 This package also ships apport-chroot. This tool can create and manage
83 chroots for usage with apport-retrace. If the fakeroot and fakechroot
84 libraries are available (either by installing the packages or by
85 merely putting their libraries somewhere and setting two environment
86 variables), the entire process of retracing crashes in chroots can
87 happen with normal user privileges.
88
89 %prep
90 %setup -q -n hardy
91 %patch0 -p1
92 %patch1 -p1
93
94 # only used by debian
95 rm apport/packaging.py
96
97 # set up the packaging backend
98 cp backends/packaging_rpm.py apport
99 cp %{SOURCE2} apport/packaging_pld.py
100 ln -s packaging_pld.py apport/packaging_impl.py
101
102 %build
103 python setup.py build
104 %{__make} -C po
105 %{__make} -C gtk
106 %{__make} -C qt4
107
108 #%{__make} -C doc
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 python setup.py install \
113         --optimize=2 \
114         --root=$RPM_BUILD_ROOT
115
116 %py_postclean
117
118 # Do the man pages
119 install -d $RPM_BUILD_ROOT%{_mandir}/man1
120 install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
121 # cron job
122 install -d $RPM_BUILD_ROOT/etc/cron.daily
123 install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
124 # create the dir for crash reports
125 install -d $RPM_BUILD_ROOT/var/crash
126 # install initscript
127 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
128 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
129
130 # KDE integration
131 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/mimelnk/text}
132 # application
133 cp -a qt4/apport-qt.desktop $RPM_BUILD_ROOT%{_desktopdir}
134 # mimetype and associated action
135 cp -a qt4/apport-qt-mimelnk.desktop $RPM_BUILD_ROOT%{_datadir}/mimelnk/text/x-apport.desktop
136 cp -a qt4/apport-qt-mime.desktop $RPM_BUILD_ROOT%{_desktopdir}
137
138 rm -f $RPM_BUILD_ROOT%{_docdir}/apport/package-hooks.txt
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 /sbin/chkconfig --add apport
145 %service apport restart
146 %update_mime_database
147 %update_icon_cache hicolor
148
149 %preun
150 if [ "$1" == "0" ]; then
151         %service apport stop
152         /sbin/chkconfig --del apport
153 fi
154
155 %update_mime_database
156 %update_icon_cache hicolor
157
158 %files
159 %defattr(644,root,root,755)
160 %doc doc/package-hooks.txt
161 %dir /var/crash
162 %{_mandir}/man1/*
163 %{_iconsdir}/hicolor/*/apps/apport.svg
164 %{_datadir}/mime/packages/apport.xml
165 %{py_sitescriptdir}/apport-*.egg-info
166 %dir %{_datadir}/apport
167 %attr(755,root,root) %{_bindir}/apport
168 %attr(755,root,root) %{_bindir}/apport-cli
169 %attr(755,root,root) %{_bindir}/gcc_ice_hook
170 %attr(755,root,root) %{_bindir}/apport-checkreports
171 %attr(755,root,root) %{_bindir}/package_hook
172 %attr(755,root,root) %{_bindir}/kernel_hook
173 %attr(755,root,root) %{_bindir}/apport-unpack
174 %attr(755,root,root) %{_datadir}/apport/testsuite/
175 %dir %{_datadir}/apport/general-hooks/
176 %attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
177 %dir %{_datadir}/apport/package-hooks/
178 %attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
179 %{py_sitescriptdir}/apport_python_hook.py[co]
180 %{py_sitescriptdir}/problem_report*.py[co]
181 %dir %{py_sitescriptdir}/apport
182 %{py_sitescriptdir}/apport/*.py[co]
183 %dir %{py_sitescriptdir}/apport/crashdb_impl
184 %{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
185 /etc/cron.daily/apport
186 %attr(754,root,root) /etc/rc.d/init.d/apport
187 %dir %{_sysconfdir}/apport
188 %config %{_sysconfdir}/apport/crashdb.conf
189 %{_sysconfdir}/apport/blacklist.d
190
191 %files gtk
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_bindir}/apport-gtk
194 %{_datadir}/apport/apport-gtk.glade
195
196 %files qt
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/apport-qt
199 %{_datadir}/apport/*.ui
200 %{_desktopdir}/apport-qt.desktop
201 %{_desktopdir}/apport-qt-mime.desktop
202 %{_datadir}/mimelnk/text/x-apport.desktop
203
204 %files retrace
205 %defattr(644,root,root,755)
206 %{_mandir}/man1/apport-retrace.1*
207 %attr(755,root,root) %{_bindir}/apport-retrace
208 %attr(755,root,root) %{_bindir}/apport-chroot
209 %attr(755,root,root) %{_bindir}/dupdb-admin
This page took 0.077647 seconds and 4 git commands to generate.