]> git.pld-linux.org Git - packages/apinger.git/blob - apinger.spec
- new spec
[packages/apinger.git] / apinger.spec
1 Summary:        Alarm Pinger - network monitor with mail notification 
2 Summary(pl):    Alarm Pinger - monitor sieci z powiadamianiem poczt±
3 Name:           apinger
4 Version:        0.1
5 Release:        1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.bnet.pl/~jajcus/%{name}/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconf
11 Patch0:         %{name}-user.patch
12 URL:            http://www.bnet.pl/~jajcus/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Alarm Pinger is a little tool which monitors various IP devices by simple ICMP
19 echo requests. There are various other tools, that can do this, but most of
20 them are shell or perl scripts, spawning many processes, thus much
21 CPU-expensive, especially when one wants continuous monitoring and fast
22 response on target failure.  Alarm Pinger is a single process written in C, so
23 it doesn't need much CPU power even when monitoring many targets with frequent
24 probes.  Alarm Pinger supports both IPv4 and IPv6.
25
26 %description -l pl
27 Alarm Pinger to ma³e narzêdzie monitoruj±ce ró¿ne urz±dzenia IP wykorzystuj±c
28 pakiety ICMP echo request/reply (tzw. ping). S± ró¿ne inne narzêdzia, które to
29 potrafi±, ale wiêkszo¶æ z nich to skrypty shell lub perl uruchamiaj±ce wiele
30 procesów, przez co mocno obci±¿aj±ce maszynê, szczególnie gdy kto¶ chce ci±g³ego
31 monitorowania i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
32 napisany w C, wiêc nie wymaga wielkiej mocy obliczeniowej, nawet gdy bada wiele
33 urz±dzeñ czêstymi pingami. Alarm Pinger obs³uguje zarówno IPv4 jak i IPv6.
34
35 %prep
36 %setup -q
37 %patch0 -p1
38
39 %build
40 aclocal
41 autoheader
42 autoconf
43 %configure 
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
49
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51 install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
52 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
53 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 /sbin/chkconfig --add apinger
60
61 if [ -f /var/lock/subsys/apinger ]; then
62         /etc/rc.d/init.d/apinger restart 1>&2
63 else
64         echo "Type \"/etc/rc.d/init.d/apinger start\" to start named" 1>&2
65 fi
66
67 %preun
68 if [ "$1" = "0" ]; then
69         if [ -f /var/lock/subsys/apinger ]; then
70                 /etc/rc.d/init.d/apinger stop 1>&2
71         fi
72         /sbin/chkconfig --del apinger
73 fi    
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS NEWS TODO README
78 %attr(755,root,root) %{_sbindir}/*
79 %attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
80 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/apinger
81 %attr(640,root,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
This page took 0.060445 seconds and 4 git commands to generate.