]> git.pld-linux.org Git - packages/apinger.git/blob - apinger.spec
- added missing Requires(): chkconfig or PreReq: rc-scripts
[packages/apinger.git] / apinger.spec
1 Summary:        Alarm Pinger - network monitor with mail notification
2 Summary(pl):    Alarm Pinger - monitor sieci z powiadamianiem poczt±
3 Name:           apinger
4 Version:        0.6.1
5 Release:        2
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://www.bnet.pl/~jajcus/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  3505e6503ec06363613f16713501bb33
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconf
12 Patch0:         %{name}-user.patch
13 URL:            http://www.bnet.pl/~jajcus/
14 PreReq:         rc-scripts
15 Requires(post,preun):   /sbin/chkconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Alarm Pinger is a little tool which monitors various IP devices by
20 simple ICMP echo requests. There are various other tools, that can do
21 this, but most of them are shell or perl scripts, spawning many
22 processes, thus much CPU-expensive, especially when one wants
23 continuous monitoring and fast response on target failure. Alarm
24 Pinger is a single process written in C, so it doesn't need much CPU
25 power even when monitoring many targets with frequent probes. Alarm
26 Pinger supports both IPv4 and IPv6.
27
28 %description -l pl
29 Alarm Pinger to ma³e narzêdzie monitoruj±ce ró¿ne urz±dzenia IP
30 wykorzystuj±c pakiety ICMP echo request/reply (tzw. ping). S± ró¿ne
31 inne narzêdzia, które to potrafi±, ale wiêkszo¶æ z nich to skrypty
32 shella lub perla uruchamiaj±ce wiele procesów, przez co mocno
33 obci±¿aj±ce maszynê, szczególnie gdy kto¶ chce ci±g³ego monitorowania
34 i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
35 napisany w C, wiêc nie wymaga wielkiej mocy obliczeniowej, nawet gdy
36 bada wiele urz±dzeñ czêstymi pingami. Alarm Pinger obs³uguje zarówno
37 IPv4 jak i IPv6.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42
43 %build
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
56 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 /sbin/chkconfig --add apinger
63
64 if [ -f /var/lock/subsys/apinger ]; then
65         /etc/rc.d/init.d/apinger restart 1>&2
66 else
67         echo "Type \"/etc/rc.d/init.d/apinger start\" to start apinger" 1>&2
68 fi
69
70 %preun
71 if [ "$1" = "0" ]; then
72         if [ -f /var/lock/subsys/apinger ]; then
73                 /etc/rc.d/init.d/apinger stop 1>&2
74         fi
75         /sbin/chkconfig --del apinger
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS NEWS TODO README doc/FAQ.html
81 %attr(755,root,root) %{_sbindir}/*
82 %attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
83 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/apinger
84 %attr(640,root,daemon) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
This page took 0.072161 seconds and 4 git commands to generate.