]> git.pld-linux.org Git - packages/apache1-mod_snake.git/blob - apache1-mod_snake.spec
fixed a small typo
[packages/apache1-mod_snake.git] / apache1-mod_snake.spec
1 %define         mod_name        snake
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An Apache module to allow for Python plugins and control
4 Summary(pl):    Modu³ do Apache pozwalaj±cy na kontrolê i wtyczki Pythona
5 Name:           apache-mod_%{mod_name}
6 Version:        0.5.0
7 Release:        2
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://prdownloads.sourceforge.net/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
11 URL:            http://modsnake.sourceforge.net/
12 BuildRequires:  %{apxs}
13 BuildRequires:  apache-devel >= 1.3.15
14 BuildRequires:  python-devel >= 1.5
15 Prereq:         %{_sbindir}/apxs
16 Requires:       apache
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20
21 %description
22 mod_snake is an Apache module which allows for execution of Python
23 code directly within the Apache server process. By including an
24 interpreter in the Apache process, Python CGIs are accelerated, Python
25 can be embedded within HTML and Python written modules can control the
26 internals of the webserver.
27
28 %description -l pl
29 mod_snake to modu³ Apache pozwalaj±cy na wykonywanie kodu Pythona
30 bezpo¶rednio w procesie serwera Apache. W³±czaj±c interpreter do
31 procesu Apache skrypty CGI w Pythonie s± znacznie przyspieszone.
32 Python mo¿e byæ umieszczany w HTMLu oraz modu³y Pythona mog±
33 kontrolowaæ wewnêtrzne sprawy serwera www.
34
35 %prep
36 %setup -q -n mod_%{mod_name}-%{version}
37
38 %build
39 %configure2_13 \
40         --with-apxs=%{apxs} \
41         --enable-dso
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_pkglibdir}
47
48 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
55 if [ -f /var/lock/subsys/httpd ]; then
56         /etc/rc.d/init.d/httpd restart 1>&2
57 fi
58
59 %preun
60 if [ "$1" = "0" ]; then
61         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
62         if [ -f /var/lock/subsys/httpd ]; then
63                 /etc/rc.d/init.d/httpd restart 1>&2
64         fi
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.058975 seconds and 3 git commands to generate.