]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blob - apache1-mod_auth_pgsql.spec
- merge translations from CNV.
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 Summary:        This is the PgSQL authentication module for Apache
3 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        0.9.10
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
12 Patch0:         %{name}-version.patch
13 BuildRequires:  postgresql-devel
14 BuildRequires:  /usr/sbin/apxs
15 BuildRequires:  apache(EAPI)-devel
16 Prereq:         /usr/sbin/apxs
17 Requires:       apache(EAPI)
18 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
22
23 %description
24 This is an authentication module for Apache that allows you to
25 authenticate HTTP clients using postgresql RDBMS.
26
27 %description -l pt_BR
28 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
29 PostgreSQL.
30
31 %prep 
32 %setup -q -n "mod_%{mod_name}-%{version}"
33 %patch0 -p1
34
35 %build
36 /usr/sbin/apxs \
37         -I %{_includedir}/postgresql \
38         -l pq \
39         -c mod_%{mod_name}.c \
40         -o mod_%{mod_name}.so
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_pkglibdir}
45
46 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47
48 %post
49 /usr/sbin/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50 if [ -f /var/lock/subsys/httpd ]; then
51         /etc/rc.d/init.d/httpd restart 1>&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         /usr/sbin/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc *.html
68 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.16784 seconds and 4 git commands to generate.