]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/blob - apache-mod_wsgi.spec
Release 4. Rebuild to silence apache warnings about build/runtime python versions.
[packages/apache-mod_wsgi.git] / apache-mod_wsgi.spec
1 # TODO:
2 # - build py2 and py3 variants both?
3
4 #
5 # Conditional build:
6 %bcond_with     python3 # use CPython 3.x
7
8 %define         mod_name        wsgi
9 %define         apxs            /usr/sbin/apxs
10 Summary:        WSGI interface for the Apache Web server
11 Summary(pl.UTF-8):      Interfejs WSGI dla serwera WWW Apache
12 Name:           apache-mod_%{mod_name}
13 Version:        3.4
14 Release:        4
15 License:        Apache
16 Group:          Networking/Daemons
17 Source0:        http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
18 # Source0-md5:  f42d69190ea0c337ef259cbe8d94d985
19 Source1:        %{name}.conf
20 URL:            http://code.google.com/p/modwsgi/
21 BuildRequires:  %{apxs}
22 BuildRequires:  apache-devel >= 2.0.52-7
23 BuildRequires:  apr-devel >= 1:1.0.0
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %if %{with python3}
27 BuildRequires:  python3-devel
28 %else
29 BuildRequires:  python-devel >= 2.3
30 %endif
31 BuildRequires:  rpmbuild(macros) >= 1.268
32 Requires:       apache(modules-api) = %{apache_modules_api}
33 Requires:       apr >= 1:1.0.0
34 # http://helpful.knobs-dials.com/index.php/Mod_wsgi_notes#PyEval_AcquireThread:_non-NULL_old_thread_state
35 Conflicts:      apache-mod_python
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
39 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
40
41 %description
42 The mod_wsgi adapter is an Apache module that provides a WSGI
43 compliant interface for hosting Python based web applications within
44 Apache. The adapter is written completely in C code against the Apache
45 C runtime and for hosting WSGI applications within Apache has a lower
46 overhead than using existing WSGI adapters for mod_python or CGI.
47
48 %description -l pl.UTF-8
49 Adapter mod_wsgi jest modułem udostępniającym interfejs WSGI dla
50 aplikacji WWW napisanych w języku Python i osadzonych w serwerze
51 Apache. Adapter jest w całości napisany w języku C w oparciu o
52 bibliotekę uruchomieniową Apache i ma mniejsze wymagania niż w
53 przypadku używania istniejących adapterów WSGI dla modułu mod_python
54 lub CGI.
55
56 %prep
57 %setup -q -n mod_%{mod_name}-%{version}
58
59 %build
60 %{__aclocal}
61 %{__autoconf}
62 %if %{with python3}
63 PYTHONBIN=%{__python3}
64 %else
65 PYTHONBIN=%{__python}
66 %endif
67 %configure \
68         --with-apxs=%{apxs} \
69         --with-python=$PYTHONBIN
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/61_mod_wsgi.conf
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 %service -q httpd restart
84
85 %postun
86 if [ "$1" = "0" ]; then
87         %service -q httpd restart
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README
93 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
94 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.077133 seconds and 3 git commands to generate.