]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- fixed Summary, added pl translations
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 %define         mod_name        ntlm
2 Summary:        This is the NTLM authentication module for Apache
3 Summary(pl):    Modu³ autentykacji NTLM dla Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        0.3
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://prdownloads.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
12 Patch0:         %{name}-symbol_fix.patch
13 BuildRequires:  /usr/sbin/apxs
14 BuildRequires:  apache(EAPI)-devel
15 Prereq:         /usr/sbin/apxs
16 Requires:       apache(EAPI)
17 URL:            http://modntlm.sourceforge.net/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
21
22 %description
23 This is an authentication module for Apache that allows you to
24 authenticate HTTP clients using samba or windows-like server
25 (using NTLM protocol).
26
27 %description -l pl
28 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
29 klientów HTTP poprzez sambê lub serwer na Windows (z u¿yciem
30 protoko³u NTLM).
31
32 %prep 
33 %setup -q -n mod_%{mod_name}-%{version}
34 %patch -p0
35
36 %build
37 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{_pkglibdir}
42
43 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45 %post
46 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47 if [ -f /var/lock/subsys/httpd ]; then
48         /etc/rc.d/init.d/httpd restart 1>&2
49 fi
50
51 %preun
52 if [ "$1" = "0" ]; then
53         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
54         if [ -f /var/lock/subsys/httpd ]; then
55                 /etc/rc.d/init.d/httpd restart 1>&2
56         fi
57 fi
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.06935 seconds and 4 git commands to generate.