]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- XSP package separated, and Required
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1 %define         mod_name mod_mono
2 Summary:        Mono module for Apache 2
3 Summary(pl):    Modu³ Mono dla serwera Apache 2
4 Name:           apache-mod_mono
5 Version:        1.0
6 Release:        0.10
7 Epoch:          1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://mono2.ximian.com/archive/1.0/%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  154720f6286105d513d1688f4a6e2b29
12 Patch0:         %{name}-apu-config.patch
13 URL:            http://www.mono-project.com/
14 BuildRequires:  apache-devel >= 2.0
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  mono-csharp >= 1.0
19 Requires:       xsp
20 Requires:       apache >= 2.0
21 Requires:       mono-csharp >= 1.0
22 Obsoletes:      mod_mono
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         apxs            %{_sbindir}/apxs
26 %define         _httpdir        /home/services/httpd
27 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
28
29 %description
30 This is an experimental module that allows you to run ASP.NET pages on
31 Unix with Apache and Mono.
32
33 %description -l pl
34 Ten eksperymentalny modu³ umo¿liwia uruchamianie stron ASP.NET na
35 Uniksie z serwerem Apache i Mono.
36
37 %package -n dotnet-xsp
38 Summary:        Mono ASP.NET Standalone Web Server
39 Summary(pl):    Server HTTP obs³uguj±cy ASP.NET
40 Group:          Networking/Daemons
41 Requires:       %{name} = %{epoch}:%{version}-%{release}
42 Requires:       mono-csharp >= 1.0
43
44 %description -n dotnet-xsp
45 Provides a minimalistic web server which hosts the ASP.NET runtime and 
46 can be used to test and debug web applications that use the System.Web
47 facilities in  Mono.
48
49 %prep
50 %setup -q -n %{mod_name}-%{version}
51 %patch0 -p1
52
53 %build
54 rm -rf $RPM_BUILD_ROOT
55 # Build Apache Module
56 %{__libtoolize}
57 %{__aclocal}
58 %{__autoconf}
59 %{__automake}
60
61 %configure \
62         --with-apxs=%{apxs} \
63         --with-apr-config=%{_bindir}/apr-config \
64         --with-apu-config=%{_bindir}/apu-config
65         
66 %{__make} \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 # Build Mono DLL
70 %{__make} -C src -f makedll.mak
71
72 %install
73 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_pkglibdir},%{_mandir}/man8}
74
75 install src/.libs/libmod_mono.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_mono.so
76 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
77 install man/mod_mono.8 $RPM_BUILD_ROOT%{_mandir}/man8
78
79 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/70_mod_mono.conf <<EOF
80 LoadModule mono_module modules/mod_mono.so
81 MonoApplications "/asp_net:%{_httpdir}/asp_net"
82 Alias /asp_net "%{_httpdir}/asp_net"
83 <Location /asp_net>
84     SetHandler mono
85 </Location>
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*
94 %doc ChangeLog INSTALL NEWS README
95 %attr(755,root,root) %{_pkglibdir}/mod_mono.so
96 %attr(755,root,root) %{_libdir}/ModMono.dll
97 %{_mandir}/man8/*
This page took 0.07185 seconds and 4 git commands to generate.