]> git.pld-linux.org Git - packages/apache-mod_gnutls.git/blob - apache-mod_gnutls.spec
3ceb5c0af75d712b2f14c71c32da063205fd39b6
[packages/apache-mod_gnutls.git] / apache-mod_gnutls.spec
1 %define         mod_name        gnutls
2 %define         apxs            /usr/sbin/apxs
3 Summary:        SSL v3, TLS 1.0 and TLS 1.1 encryption for Apache HTTPD
4 Summary(pl.UTF-8):      Szyfrowanie SSL v3, TLS 1.0 i TLS 1.1 dla serwera HTTP Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.2.0
7 Release:        0.2
8 License:        Apache Group License
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_gnutls/mod_gnutls-%{version}.tar.bz2
11 # Source0-md5:  80ab766a7b9cfbb730e789032ff26d68
12 Source1:        %{name}.conf
13 Source2:        %{name}-dhfile
14 Source3:        %{name}-rsafile
15 Patch0:         %{name}-libtool.patch
16 Patch1:         %{name}-no_certtool.patch
17 Patch2:         %{name}-paths.patch
18 URL:            http://www.outoforder.cc/projects/apache/mod_gnutls/
19 BuildRequires:  apache-apxs
20 BuildRequires:  apache-devel >= 2.0.42
21 BuildRequires:  apr_memcache-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gnutls-devel >= 1.2.0
25 BuildRequires:  libtool
26 Requires:       apache(modules-api) = %apache_modules_api
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
30 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
31
32 %description
33 mod_gnutls uses the GnuTLS library to provide SSL v3, TLS 1.0 and TLS
34 1.1 encryption for Apache HTTPD. It is similar to mod_ssl in purpose,
35 but does not use OpenSSL.
36
37 Features:
38  - Support for SSL v3, TLS 1.0 and TLS 1.1.
39  - Support for Server Name Indication
40  - Distributed SSL Session Cache via Memcached
41  - Local SSL Session Cache using DBM
42
43 %description -l pl.UTF-8
44 mod_gnutls używa biblioteki GnuTLS do obsługi szyfrowania SSL v3, TLS
45 1.0 i TLS 1.1 dla serwera HTTP Apache. Pod względem przeznaczenia jest
46 podobny do mod_ssl, ale nie używa biblioteki OpenSSL.
47
48 Możliwości:
49  - obsługa SSL v3, TLS 1.0 i TLS 1.1
50  - obsługa identyfikacji nazwy serwera (Server Name Indication)
51  - rozproszona pamięć podręczna sesji SSL poprzez Memcached
52  - lokalna pamięć podręczna sesji SSL korzystająca z DBM
53
54 %prep
55 %setup -q -n mod_%{mod_name}-%{version}
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59
60 %build
61 %{__libtoolize}
62 %{__aclocal} -I m4
63 %{__autoheader}
64 %{__automake}
65 %{__autoconf}
66 %configure \
67         --with-apxs=%{apxs} \
68         --with-libgnutls=%{_prefix} \
69         --without-apr-memcache
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/{conf.d,tls}}
76 install src/.libs/libmod_gnutls.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_gnutls.so
77 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/40_mod_gnutls.conf
78 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/tls/dhfile
79 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/tls/rsafile
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 if [ "$1" = "1" ]; then
86         echo "Generating dhfile/rsafile - this may take some time..."
87         d=/etc/httpd/tls
88         [ -f "$d/dhfile" ] || /usr/bin/certtool --generate-dh-params --bits 1024 --outfile $d/dhfile
89         [ -f "$d/rsafile" ] || /usr/bin/certtool --generate-privkey --bits 512 --outfile $d/rsafile
90 fi
91 %service -q httpd restart
92
93 %postun
94 if [ "$1" = "0" ]; then
95         %service -q httpd restart
96         rm -f /etc/httpd/tls/{dhfile,rsafile}
97 fi
98
99 %files
100 %defattr(644,root,root,755)
101 %attr(750,root,root) %dir %{_sysconfdir}/tls
102 %dir %{_sysconfdir}/tls
103 %attr(640,root,root) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_gnutls.conf
104 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.055237 seconds and 3 git commands to generate.