]> git.pld-linux.org Git - packages/apache-mod_cfg_ldap.git/blob - apache-mod_cfg_ldap.spec
- tabs in preamble
[packages/apache-mod_cfg_ldap.git] / apache-mod_cfg_ldap.spec
1 %define         mod_name        cfg_ldap
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to keep Apache VirtualHost configuration in an LDAP directory
4 Summary(pl.UTF-8):      Moduł do przechowywania konfiguracji serwerów wirtualnych Apache'a w katalogu LDAP
5 Name:           apache-mod_%{mod_name}
6 Version:        1.2
7 Release:        4
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/modcfgldap/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  055924d6488608f684b22e7b04cea2ea
12 Patch0:         %{name}-openldap-2.3.patch
13 URL:            http://modcfgldap.sourceforge.net/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2.0
16 BuildRequires:  db-devel >= 4.2.52
17 BuildRequires:  openldap-devel >= 2.3.0
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       apache(modules-api) = %apache_modules_api
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
24
25 %description
26 mod_cfg_ldap allows you to keep your virtual host configuration in a
27 LDAP directory and update it in nearly realtime.
28
29 %description -l pl.UTF-8
30 mod_cfg_ldap pozwala na przechowywanie konfiguracji hostów wirtualnych
31 w katalogu LDAP i uaktualnianie jej prawie w czasie rzeczywistym.
32
33 %prep
34 %setup -q -n mod_%{mod_name}-%{version}
35 %patch0 -p1
36
37 %build
38 %{__make} all \
39         APXS=%{apxs}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
44
45 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46 install cfg_ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/85_mod_cfg_ldap.conf
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %service -q httpd restart
53
54 %postun
55 if [ "$1" = "0" ]; then
56         %service -q httpd restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS ChangeLog INSTALL README TODO *.schema
62 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
63 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.11187 seconds and 4 git commands to generate.