]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- added summaries/descriptions from KSI/RH
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 Summary:        This is the PostgreSQL authentication module for Apache
3 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
4 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
5 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
6 Summary(es):    Autenticación vía PostgreSQL para Apache
7 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
8 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
9 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
10 Summary(no):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
11 Summary(pl):    Modu³ autentykacji PostgreSQL dla Apache
12 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
13 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
14 Name:           apache-mod_%{mod_name}
15 Version:        0.9.12
16 Release:        1
17 License:        GPL
18 Group:          Networking/Daemons
19 Group(cs):      Sí»ové/Démoni
20 Group(da):      Netværks/Dæmoner
21 Group(de):      Netzwerkwesen/Server
22 Group(es):      Red/Servidores
23 Group(fr):      Réseau/Serveurs
24 Group(is):      Net/Púkar
25 Group(it):      Rete/Demoni
26 Group(no):      Nettverks/Daemoner
27 Group(pl):      Sieciowe/Serwery
28 Group(pt):      Rede/Servidores
29 Group(ru):      óÅÔØ/äÅÍÏÎÙ
30 Group(sl):      Omre¾ni/Stre¾niki
31 Group(sv):      Nätverk/Demoner
32 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
33 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
34 BuildRequires:  postgresql-devel
35 BuildRequires:  /usr/sbin/apxs
36 BuildRequires:  apache(EAPI)-devel
37 Prereq:         /usr/sbin/apxs
38 Requires:       apache(EAPI)
39 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
43
44 %description
45 This is an authentication module for Apache that allows you to
46 authenticate HTTP clients using postgresql RDBMS.
47
48 %description -l cs
49 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
50 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
51 PostgreSQL.
52
53 %description -l de
54 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
55 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
56 einer Tabelle in einer PostgresQL-Datenbank prüft.
57
58 %description -l es
59 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
60 servidos desde un servidor web verificando datos en una base de datos
61 PostgreSQL.
62
63 %description -l fr
64 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
65 servis par un serveur Web en vérifiant des champs dans une table d'une
66 base de données PostgresQL.
67
68 %description -l it
69 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
70 serviti da un server Web controllando i campi di una tabella in un
71 database PostgresQL.
72
73 %description -l ja
74 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
75 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
76 À©¸Â¤Ç¤­¤Þ¤¹¡£
77
78 %description -l pl
79 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
80 klientów HTTP z u¿yciem bazy danych postgresql.
81
82 %description -l pt_BR
83 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
84 PostgreSQL.
85
86 %description -l sv
87 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
88 servade av en webbserver genom att kontrollera data i en
89 PostgreSQL-databas.
90
91 %prep
92 %setup -q -n "mod_%{mod_name}-%{version}"
93
94 %build
95 /usr/sbin/apxs \
96         -I %{_includedir}/postgresql \
97         -l pq \
98         -c mod_%{mod_name}.c \
99         -o mod_%{mod_name}.so
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_pkglibdir}
104
105 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 /usr/sbin/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
112 if [ -f /var/lock/subsys/httpd ]; then
113         /etc/rc.d/init.d/httpd restart 1>&2
114 fi
115
116 %preun
117 if [ "$1" = "0" ]; then
118         /usr/sbin/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
119         if [ -f /var/lock/subsys/httpd ]; then
120                 /etc/rc.d/init.d/httpd restart 1>&2
121         fi
122 fi
123
124 %files
125 %defattr(644,root,root,755)
126 %doc *.html
127 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.098512 seconds and 4 git commands to generate.